Custom Fonts not Working

  • Author
    Posts
  • #806108

    I purchased the Custom Design package yesterday. I have tried to change the fonts on my blog, but keep getting an error telling me the preview would not load. It advises to refresh to start over or to re-save fonts. Neither has worked. I’ve tried multiple times, giving the program time to apply the fonts. It’s still not happening. I sent an e-mail to Support yesterday and have not received a response. I’m trying the forum now. This is my first blog and I am very frustrated that I paid money for added functionality and it isn’t working. Help please.

    Thank you,
    Richard Alan

    The blog I need help with is villagedrummerfiction.wordpress.com.

    #806232

    Don’t worry about the preview. In my experience it is totally broken and I’ve only had it work a couple times out of the many, many times I’ve tried to use it.

    Since your site is set to private, we volunteers cannot see it. As an only suggestion since I can’t see the site, save your font selections and then log out of wordpress, clear your browser cache and cookies, restart your browser and then visit your site to see if the fonts show up on it.

    #806255

    Thank you for the quick reply. Unfortunately, it did not work. I have removed the private settings so you can look at the site. When I look at Custom Design, it shows the fonts I want, but they are not the fonts that are appearing. What next?

    Thanks,
    Richard

    #806292

    bethbeeman
    Member

    I am having this problem also…. it’s very annoying. And, what do you mean “preview is totally broken”. SERIOUSLY? I just paid for a site that doesn’t work? Great.

    #806293

    I see from looking at the CSS in your site that there are a number of typekit fonts set and defined, but I find nowhere where they are applied to anything. After choosing the font for the title/body/whatever, did you click the save or apply button?

    Take a look at this support document on custom fonts and work through it and see if it will then work for you.

    #806294

    @bethbeeman, the custom fonts work, it is just the preview at appearance > custom design > fonts that doesn’t seem to ever work. It is just to show you what your site will look like if you apply the fonts. It is an irritation, but it doesn’t mean the fonts side of things is broken or anything like that.

    Look through the support document I referenced above and work through it and see if that doesn’t help.

    #806295

    bethbeeman
    Member

    Thanks for responding and trying to help. This just should not be complicated and if the preview is there, IT SHOULD WORK. LOL… seriously I found complaints about it not working over two years ago and it still isn’t? Seems they should fix that.

    I already worked through the support document and have done everything except the advanced functions. My font is showing as loaded, just not showing on the site. In fact, it takes the header font and EONS to load on the site – and when it does, it’s the default not the one that is loaded and saved. (Oh, I cleared my cache too)

    In fact, I’m experiencing significant wordpress CMS slow downs…. seems pretty unresponsive.

    I have a custom designed webpage on WordPress.org that I’m hosting myself. I’ve managed to get that up and working and customized. I thought the WordPress.com might be easier, but it’s just as finicky.

    #806296

    @bethbeeman, There were no custom fonts two years ago. It started in June of 2011. Before that you could use typekit fonts, but that was done completely through typekit in general and you could go further if you also had the CSS upgrade (now part of the custom design upgrade), but it was a completely manual process and not integrated into wordpress.

    http://en.blog.wordpress.com/2011/06/15/new-upgrade-custom-design/

    What happens when you start to apply custom fonts is that wordpress requests and downloads the fonts that you want to apply to your account here. If typekit’s servers are experiencing a heavy load, then the download of those fonts make take a little time. Once the fonts are downloaded then they should start to appear on your site.

    Since your site is private, we volunteers cannot look at it to see if we see any custom fonts on it. Sometimes others may be able to see them, but you cannot. This can be caused by invisible proxy servers at your ISP that are not updating in a timely manner, or that are possibly over loaded or experiencing some problems.

    Since we can’t see your site, there isn’t anyway for us to check and I would suggest that you go directly through support unless you are willing to make it public for a short period so we can take a look at it.

    #806297

    bethbeeman
    Member

    Ah ha! The problem is Firefox. I’m on a mac and just tried Safari and it’s working. I’m running the latest version of Firefox. Seems like that’s the culprit.

    #806299

    justjennifer
    Moderator

    If it doesn’t show up in a refresh, I’d log out and clear my browser cache and cookies, shut down and then reopen my browser.

    #806300

    I have done everything in the support document (at least a dozen times). Yes I have saved it each time. I’ve tried using the change font function also. Each time it tells me my changes have been successfully updated and that it will take a few minutes to reflect on the blog. The custom font page shows the correct fonts that I chose. My blog has not changed. I’ve been working on this for over 24 hours. I don’t understand when you say you see my font selections, but don’t see them applied. The custom design page shows me “Currently Used Fonts” are “Site Title – LFT ELITE DISPLAY, Headings – LeMONDE, and Body – PT SERIF.” I don’t know what else to do.

    Richard

    #806301

    I’ve tagged this thread for staff attention and hopefully someone will drop by and look into things.

    @bethbeeman, restart Firefox with all addons disabled and see what happens (Tools > addons).

    #806302

    bethbeeman
    Member

    @thesacredpath I understand everything you are saying and truly appreciate your help. But, you folks looking at my site isn’t going to fix a browser issue :) I can easily make the updates and even “preview” works in Safari. I’ve cleared cache, logged out, reset and done everything but a restart of the computer and Firefox is still not working. Firefox can’t even the loaded fonts – that are visible in Safari. I’ll take a look at it tomorrow from work on IE and see if it’s working.

    Again, these fonts should work on all platforms. If they aren’t going to, I don’t want them on my site.

    #806303

    @bethbeeman, Yup, I just viewed your site in Safari and see your custom fonts. It is an issue with the latest version of Firefox as I don’t see them in Firefox either.

    #806304

    bethbeeman
    Member

    @sacredpath… that’s one thing I haven’t tried… I’ll try that. Thanks.

    #806305

    bethbeeman
    Member

    @thesacredpath…. well, at least I’m not “crazy” :)

    #806306

    Nope, you aren’t crazy unless I am also (I may be…).

    #806307

    bethbeeman
    Member

    What’s even a bit more scarey is that might site it still set to private, yet you could see it. Seems like that is broken too

    #806308

    This is interesting. I’m also using Firefox. I’ll give it a try on IE and let you know what happens.

    Richard

    #806312

    @bethbeeman, I might have checked just before you set it back to private.

The topic ‘Custom Fonts not Working’ is closed to new replies.