Custom Fonts not Working

  • Author
    Posts
  • #806314

    It does appear to be a Firefox issue. It looks correct on IE. I take back all the nasty thoughts I was having about wordpress. Now I have to dump on Firefox. Thank you so much for your help!

    Richard Alan

    #806324

    You are welcome, and this is something staff and the typekit people have to figure out.

    #806380

    Hello. I’ve been trying to reproduce this problem in a test, but everything is working properly for me both in the Appearance → Custom Design → Fonts previews as well as fonts on the front end viewed in Firefox 9.0.1.

    #806381

    Looking to get a couple more people to help me test this.

    #806382

    We finally determined that it is a Firefox problem vs a WordPress issue. If you call up my blog in Firefox it does not have the appropriate fonts and is difficult to read (fonts too small). It works properly in IE. Thank you.

    #806383

    All righty. One person in Montreal tested, and one person in Portland. Custom fonts work fine for both of them in Firefox 9.0.1. Are you guys still having trouble even if you clear browser cache (again, even if you did it before)?

    #806384

    We finally determined that it is a Firefox problem vs a WordPress issue. If you call up my blog in Firefox it does not have the appropriate fonts and is difficult to read (fonts too small). It works properly in IE. Thank you.

    #806385

    But it works properly for me in Firefox…

    #806388

    On http://villagedrummerfiction.wordpress.com/ , I cleared FF cache, turned off all add-ons, restarted browser and I see no custom fonts. In Safari I see custom fonts.

    Force reloaded main page of http://villagedrummerfiction.wordpress.com/ again, still no custom fonts. Force reloaded page again (after a minute or so) and then I could see the fonts. Force refreshed the page again and the custom fonts disappeared. Force refreshed the page again and the custom fonts came back. Force refreshed the page several more times and the site now seems to be consistently loading the fonts, at least until I cleared the cache again and they disappeared and it took a couple more forced refreshes before I could see the custom fonts again.

    They are far too inconsistent, especially for first time visitors to a site where they don’t show up until the person has clicked around on a couple or several internal links and the poof! there are the custom fonts and the site looks totally different right in the middle of a visit.

    When I can see custom fonts right away in Safari, but not in FF 9 on the same computer and internet connection, there is something wrong somewhere.

    This is the main reason why I won’t use online custom fonts on client sites unless they flat insist on it, and if they do, I send them a big disclaimer.

    #806389

    I hate to say this but. The fonts are not working properly on IE either. I thought they were because the size was increased (as requested), but the title clock and the header block are showing the same font (the one I set for the headers). I changed the fonts to verify. The Title is picking up the header font. At least it’s readable and I still published it. Is there something I need to be doing in terms of reporting this to Firefox and IE? Is it a browser problem or a custom font problem. What options do I have besides custom fonts? The fonts that come with the free blog are too small.

    Thank you.

    #806390

    timethief
    Member

    @thesacredpath @designsimply @villagedrummerfiction
    The fonts are working fine for me using both Firefox 9.0.1 and IE8. They have worked each and every time that I have entered this thread and clicked into the blog in question.

    #806391

    timethief
    Member

    @villagedrummerfiction
    I’m over 55 and visually challenged. The font size on the blog is easy for me to read just as it is now. Did you know that anyone on the interent can increase or decrease the font size on any site we visit in 2 seconds flat?

    #806392

    My wife said the same thing, but I have trouble reading it. It was better once I bolded the text, but still rather light gray colored. I wonder if you are seeing it correctly or the enlarged version. IF they look the same on both Firefox and IE, you are seeing the correct version (not the one I’m seeing with my Firefox). Thanks for your advice.

    Richard

    #806393

    timethief
    Member

    Yes I am seeing bolded text using both IE8 and Firefox 9.0.1 browsers. IMO the bolding is unneccessary.

    #806394

    bethbeeman
    Member

    I’m wondering if there is a difference between Firefox for windows and Firefox for a mac. I’m on a mac and the font customization doesn’t work for me. I can’t even see the fonts on Firefox. It does, however, work in Safari. I tried it at work on a windows machine and IE works. I wiill try to test Firefox on the windows machine tomorrow.

    #806395

    bethbeeman
    Member

    Oh and btw.. there is a HUGE difference between changing font sizes in code as opposed to just changing how you view it in a browser. Yes, people can change the browser, it is easy – but there are artistic reasons to want to change the size of a font in the native website language.

    #806396

    timethief
    Member

    @bethbeeman
    This thread posted by villagedrummerfiction pertains only to the Fjords04 theme. Please start another thread of your own for your Twenty Eleven CSS editing questions as CSS editing is theme specific. Here’s the link to do that with https://en.forums.wordpress.com/forum/css-customization#postform

    #806397

    bethbeeman
    Member

    @timethief It’s not a theme specific issue. It’s a custom font package issue. I’ll keep posting :)

    #806398

    timethief
    Member

    @bethbeeman
    I can see the font changes on your Twenty Eleven theme blog in both Firefox 9.0.1 and in IE8. If you wish to check corss browser compatibility you can use this free site http://browsershots.org

    #806399

    timethief
    Member

    edit: “corss” was meant to be “cross”

The topic ‘Custom Fonts not Working’ is closed to new replies.