Custom fonts not working in Firefox on Windows

  • Author
    Posts
  • #2430828

    sarahogxp
    Member

    Using “Proxima Nova” for both the heading and body fonts, selected in the customization admin panel… However, in Firefox (on windows ONLY) I am finding that the headings are rendering correctly and the body font is not.

    This blog is not public yet, so I am viewing the site through admin only. (Staff help needed here please) My client would prefer to have this issue fixed before we ‘go live’/public.

    I’ve searched for the this issue on Google, but all the solutions/fixes are dependent on having access to the server, which is not the case here. (This is a wordpress.COM setup, we are NOT using a privately hosted install)

    Is there a general fix for this problem? Or are users restricting their font choices, my client does not like any of the other fonts however, so I am not sure how to proceed.

    Thanks for any feedback.

    The blog I need help with is opengeoxplane.net.

    #2431133

    Hi, which version of Windows and which version of FF are you seeing the issue on?

    Also, are you seeing the issue in the Customizer when you visit your actual site?

    Since your site is private right now, I can’t see it with my Windows simulator. As just a test, can you try adding the following at the bottom of your custom CSS and see if that forces it to display?

    .wf-active body, .wf-active button, .wf-active input, .wf-active select, .wf-active textarea {
        font-family: proxima-nova-1,proxima-nova-2,"Noto Serif",Georgia,Times,serif !important;
        font-variant: normal !important;
    }

    #2431136

    sarahogxp
    Member

    Hi @thesacredpath, thanks very much for your reply.

    Versions are as follows: Windows 7 and FF 39.0

    I see the issue whether I am in the ‘Customizer’ view or not.

    I am attempting your test right now.

    We have decided to launch the website later today as I explained that this is a ‘minor’ issue to the client and I also let him know we will probably get a speedier fix for our issue if we are open to the public. :)

    But I am going to do your suggested test in the meantime and I will let you know if it works.

    #2431139

    sarahogxp
    Member

    Hi again,

    Drat – no luck, your suggestion made good sense and I tried to force the same on my default page elements as well as my p tag:

    body, button, input, select, textarea {
        font-family: proxima-nova-1,proxima-nova-2,"Noto Serif",Georgia,Times,serif !important;
        font-variant: normal !important;
    }

    But, alas this is not making a difference.

    I will be setting the website to public in a few hours and I will post again once it is ‘live’ so that others are able to access and test.

    Thanks again @thesacredpath

    #2431160

    @sarahogxp, let me know when it goes public and I’ll see what I can do about getting it to show the fonts correctly. It sounds like it may be a bug, but I’m sure we can fix that with some CSS and then I’ll file a bug report on it if it turns out to be a bug.

    #2431161

    sarahogxp
    Member

    Update : the site has been made public, anyone who is able to assist please take a look.

    Thanks

    #2431163

    sarahogxp
    Member

    @thesacredpath, I’ve done a few tests now that the site is public, and I am also seeing the same issue outside of the administration views. (i.e. logged out)

    #2431169

    You know, I’m seeing Proxima in FF 39 on Windows 7 in my simulator on your site. I tested by changing the font to Times New Roman and it definitely changed when I did. When I inspect a paragraph on your site, Proxima is shown and is shown as active.

    #2431172

    ehtis
    Staff

    Can see Proxima Nova fine at my end too. Firefox 39, Windows 10 (Insider Preview).

    Here’s a screenshot: https://cloudup.com/cj6llOj4MHY

    #2431185

    sarahogxp
    Member

    @thesacredpath and @ehtis – thank you for your tests.

    Strangely, I am still having this issue appear on my desktop machine and I do not have another setup that I can test on immediately, I will do so as soon as I can.

    From what you are saying – seems I might have some local browser settings that I need to reset, I will look into this and report back as soon as possible.

    #2431186

    sarahogxp
    Member

    Update : @thesacredpath

    OK fixed! Please close the issue
    Apologies to all who assisted with this, but it turns out that there is no problem with FF, but rather an user error

    If you ever get stuck with this issue please use the following fix:

    The problem occurred on my side because there was a setting I must have set for an unrelated reason in my browser configuration (i.e. about:config), unfortunately I do not recall what the setting was that I set, but I fixed the issue by resetting my browser’s configuration.

    https://support.mozilla.org/en-US/kb/reset-preferences-fix-problems

    NB: Make sure you understand that this will disable all your add-ons and reset all your settings.

    #2431193

    @sarahogxp, hooray and you are welcome, and thanks for posting the fix.

    #2431194

    Oh and no apologies needed. We learned something from you today. :)

The topic ‘Custom fonts not working in Firefox on Windows’ is closed to new replies.