Custom Header Image no longer showing up

  • Author
  • #154142


    I’m confused. Two weeks ago, I uploaded a custom image header for the ‘Connections’ theme — using a file of the exact required size (741 x 142 pixels at about 652 KB). Everything worked perfectly, and it’s looked and functioned great ever since. This morning, I decided to tweak the header image ever so slightly. So I uploaded the new tweaked image using the custom header upload window under Presentation in the Dashboard — exact same pixel size and same file size as before — and now all I get is a blank green box where the header ought to be. I tried going back to the original custom header, but I still get the green box. I deleted both images from the uploads directory and tried again from scratch, several times. Nada. Both images now show as “broken” when I view them in the uploads directory — including the original one which is unchanged and had worked fine before. What’s going on?


    What’s the URL of you blog so we can take a look?

    You might try clearing your browser cache and force reloading the page and see if it shows up.

    Delete both of the images (the first one and the second) and then try uploading it again. Also make sure the file has an extension (.jpg, etc) and that the file name has only letters and numbers, no special characters. You might also try reverting back to the original header image that comes with the the theme and then trying to upload it again.



    The URL’s
    Yep, force reloaded the page several times to no avail. The file names should be fine (“Ultraman.jpg”). Repeatedly deleted and re-uploaded the custom image files using the Presentation interface window. No good. Have also tried resetting header image to the original and starting from scratch. Still no good. Thanks in advance for any help…


    I’m seeing a header with your avatar at the left (reversed) and the title Man and Ultraman, basically black with some dark gray graphics. Is that your header?

    A couple things:

    (1) Due to your slideshow and the number of images you have on your first page, it is taking a long time for you main page to load even with my 5GB connection speed. I would set the maximum number of posts to per page to something less, say 5, in options > reading. Your header displayed after almost the entire rest of the page had loaded.

    (2) I would think about going to thumbnails for images in posts which will load much faster. Then your viewers can click on the thumbnail to get to the full-sized image.



    you need to use a different filename from the one you had before; have you tried that?



    Yes, it’s a different file name from the one before.



    Take thesacredpath’s advice and reduce the number of posts on your front page. The custom header is always the very last thing to load, and sometimes pages just don’t load fully at all. That could be what’s happening here. If you reduce the number of images it has to load, you make your header that much easier to view.

    FWIW, I can’t see a header using Firefox, latest version.



    Yes, thesacredpath, that’s the right header. But I haven’t seen it since my initial post here. Are you still seeing it on your end? I’ve reduced the number of posts visible on the front page to five, but no custom banner yet, even with a cleared cache and forced reload. Can’t see it in either Firefox or IE.


    Yes I’m still seeing it just fine although as said, it takes a while before it loads. Have you tried viewing your blog while logged out or with a different browser?



    For what it’s worth, I’m not seeing the header either… I’ve checked in both IE7 and Firefox and given it a long time to load; all I see is a pale green space. Any chance this might be related to snap preview? I’m noticing the preview when I look in IE and I know that’s caused some problems with headers in the past. You can check to see if it’s on in Dashboard > Presentation > Extras and turn it off.



    I loaded the header by itself

    and got this error:
    “The image “” cannot be displayed, because it contains errors.”

    Firefox on a Mac

    Anyone have any ideas?



    Okay, now I’m really confused. I opened that link and got the same error message as Judy. But then I opened it in Opera and I see it fine. The blog too. Opera! With all the problems we have with Opera on WP, who’d have thought it would actually work in Opera!

    I have no idea what’s doing it now, but I’d suggest deleting the file again and going back to the theme’s default image… if you can’t see even that, I’d say it’s a problem that needs backend access; you’ll have to contact support for that.



    Definitely weird. I got it to come up in Safari (i know, it’s crazy), but it took a long time. The file is 662kb or something like that.

    Can you make it smaller (kb-wise, not pixel-wise)?

    FWIW, the default header on the theme displayed just fine for me on FF when i used FireBug to edit out the custom header from the CSS.


    Oooof! Way too big for a header image.

    @psharbaugh, you need to optimize the header image and bring it down a bunch. Here is a good discussion on optimizing:



    ^^ 662 kb for a header! Oh my – oh. my Indeed thesacred path is right. Optimize it. :)



    I started a blog and went to Presentation and clicked on custom image header.
    When I uploaded it, completely the same thing. It won’t work at all. I got to the crop the header part and it said when you return to your homepage the header will be cropped!



    i have no clue wut to do. I have Windows Paint and i want to know how to get an image on it to be my header image. I really really really need help. I am confused. :S My blog’s address is: . Plz help!!!!!!!!!!!!




    On your dashboard, go to Presentation, then Custom Header and follow the instructions.



    The problem I’m having is that when I change the privacy setting on the blog to “I would like my blog to be visible only to users I choose,” the custom header doesn’t load. When I allow the blog to be visible to normal users, the custom header appears. Any thoughts?


    Is your header image stored at or somewhere else like flickr or another image site?

The topic ‘Custom Header Image no longer showing up’ is closed to new replies.