Need help? Check out our Support site, then

Custom Header Image Not Showing Up

  1. I've uploaded an image in my 'custom header option' (to replace one of the 6 pre-set images that comes with the template).

    My custom header image shows up in the preview section of the page but when I go to actually view my blog, it doesn't show up and there is a small red 'x' and a white space where my image should be.. Why isn't it showing up?

    The blog I need help with is

  2. This is what I see when I look in your site source code and try and view the URL for the image: 404 — File not found.

    I would suggest that you delete that image and then upload it again and see what happens.

  3. I've been having the same issue and I've spotted a few people on this here forum posting the same as well.

    Myself, I've already tried uploading it again, and it disappeared for the 2nd time as well.

    My guess is that something's up with image hosting. Don't know for sure, though.

  4. My guess is that something's up with image hosting.

    We cannot use header images that are hosted elsehwre. We must upload them into our Media Library.

  5. Well, in my case I did upload it into the Media Library. This is the direct link to the image file, which (at this point at least) returns a 404:

  6. I've just uploaded a new header image again. It works now. Will see if it continues to work or this one too will disappear. The new file is here:

    Timethief: thanks for your help so far! I can see you're doing your best to help a lot of folks here and it's much appreciated.

  7. Thanks for all of your help....will try to apply all of your hints.

  8. I have flagged this thread for Staff attention.

  9. Sorry for the trouble!

    We're looking into this.

  10. Can we have an eta for a fix on that please? I'm trying to put a custom header in place (standard 2011 template) and it forgets it every couple of minutes (the image is listed in media but is 'null'). In fact it seems to keep forgetting changes I've made generally on the site - so I'll upload a header and then it just says 'updated' without going to the crop stage. (Disk problems???)
    There are also times when I have clicked on update, it say things are updated, I check the live page, the change hasn't happened. I thought finger trouble at first but it has happened way too often for that, although I can't prove it. Maybe it's true what the others are saying about me being paranoid :)
    Hope you manage to sort it our soon because it means isn't really usable - very odd. Thanks.

  11. @financetalking
    Hi there,
    I have flagged this thread for Staff attention.

  12. I'm having the same problem. Just thought I'd let you know.

  13. We were able to track down the cause and are working on a fix now.

  14. @boandkris
    Will you please provide an active link starting with http:// to the blog in question?

  15. Actually, I spoke too soon. This should be fixed now.

    Please try again and let us know how it goes!

  16. Thanks! I'll give it another swing.

  17. I'm trying to upload custom image into the header of the basic blog website. I browse, click on the image, the file tile shows up in the window, I click upload and the file title disappears. I have no clue why.

  18. @timelesstreasuresblog
    The blog linked to your username is a free hosted blog that has no blogger created content at all in it. Please post an active link starting twith http:// to the blog you are having issues with.

    Have you made sure the image is the correct size required by the theme and that the image is an accepted file type? The dimensions for the header on the Twenty Ten theme are 940 in width and 198 in height. See: troublehooting images

  19. I'm new to all this, just so you know.
    My header image was working fine until after I changed my wordpress url name. I now have two blogs under one email account with the new url as the primary. Everything transfered over to the new url except suddenly the header image was gone and it seems to come and go. A widget image was missing but fixed when I manually changed the url to the new one. I don't know if changing the url of the blog had anything to do with the header image disappearing off and on or not.
    The new url is I have it set to private because I'm not ready to go public yet. Did I mess something up by ending up with two blogs under one email account or just a coincidence?

  20. Wait, I'm trying a lower image resolution now for the header. Maybe this will work. It might be just happening on my laptop.

Topic Closed

This topic has been closed to new replies.

About this Topic