Custom Link Not Showing Up Correctly On Menu

  • Author
    Posts
  • #1802975

    Hi,

    So I created a menu using a custom link (my blog’s URL) titled “Home,” plus two pages: About Me and Contact. The menu (set as the primary menu) is displayed at the top of my blog, right under the header.

    I have set all the links in my blog to appear in the bluish color, but for some reason, the homepage link is grey. Is there a way I can get the Home link to be blue like the others? I know this probably isn’t the worst or most complicated thing in the world, but it’s like an eyesore.

    I am using the Oxygen theme, if that’s helpful.

    Thank you so much!

    The blog I need help with is cyravelasquez.com.

    #1802994

    hafizr
    Staff

    Hi there,

    The home link is grey because that color is used to tell visitors that “you are currently on this page”. If you open your About Me page (http://cyravelasquez.com/about/), for example, now the “about me” menu item is grey.

    The following CSS will change the grey to blue:

    .main-navigation li.current_page_item a, .main-navigation li.current-menu-item a {
        color: #8bf4e2;
    }

    By changing the current page color, we’re no longer telling people what page they’re currently in, though. If you’re cool with that, then use the CSS above. I’d personally suggest to use a slightly different blue for this, something that will still look harmonious (compared to grey vs blue), but still indicate the current page-ness.

    I’d suggest this color instead: #75DFCE

    However it’s just my suggestion. Feel free to do whatever you want! :)

    #1802996

    Hi hafizr,

    Wow, I feel silly. Lol, guess the frustration got the best of me and I didn’t pay attention as closely as I should have.

    I’m guessing I would have to purchase the custom design upgrade to edit CSS, correct?

    Thank you so much for your help! You were very thorough and I also appreciated the suggestions. :)

    #1802997

    hafizr
    Staff

    I’m guessing I would have to purchase the custom design upgrade to edit CSS, correct?

    That’s correct. Sorry that I answered immediately assuming that you already have the upgrade :)

    #1803013

    No, my apologies for omitting that little tidbit. I’ll purchase the upgrade – there seems to be many more benefits. Thanks again for your help and time!

The topic ‘Custom Link Not Showing Up Correctly On Menu’ is closed to new replies.