Customizing choices not saving.

  • Author
    Posts
  • #1602266

    rasrock
    Member

    Hey,

    I’ve no problems creating, uploading and using a header and playing with the free customization but when ever I try to save it via Appearances > Header page or directly through Customize page it doesn’t happen and simply reverts back to a default.

    This wasn’t happening in the beginning so I’m either missing something (likely) or there’s a bug (unlikely).

    Also, once in the customize mode the link to the dashboard in the top left hand corner is missing also which may have something to do with it.

    Any ideas?

    The blog I need help with is infrakshun.wordpress.com.

    #1602332

    rasrock
    Member

    It all worked fine before my blog was emptied of content as requested, so I wondering if something might have happened then?

    #1602387

    rachelmcr
    Staff

    Hi there,

    I see that you’re currently using a custom header on your blog here: http://infrakshun.wordpress.com/

    This is the header I see on your blog: https://cloudup.com/c4ExdyoLTfd

    Is that the custom header you’d like to use, or are you trying to upload a new one?

    If you’re trying to upload a new one, can you let me know the exact steps you’re taking to upload it (either via Appearance > Header or in the Customize tool)? That will help me investigate the issue for you. Thanks!

    #1602388

    rasrock
    Member

    Its regarding the header but also customized changes in general.

    Dashboard > Appearance > Customize > Colours

    I make the changes and they are saved but as soon as I return to the dashboard or refresh the page they are gone. Dashboard access is also absent when using the customize tool.

    Or:
    Dashboard > Appearance > Header

    I go to “Header text” and make the changes and save them I then click on “visit your site.”

    Same problem.

    #1602389

    rasrock
    Member

    So, uploading a header is not the issue it’s simply a problem with saving changes once carried out.

    #1602393

    rachelmcr
    Staff

    Thanks for clarifying. It may be that your browser is saving (caching) an older version of your site, and then showing that when you go back to visit the site after making changes.

    Can you please try making some changes, visiting your site, and then clearing your browser’s cache? If you still don’t see the changes on your site, please let me know exactly what changes you tried to make and I can try to reproduce the issues you’re having. Thanks!

    #1602436

    rasrock
    Member

    Still the same problem.

    What is strange is that once I click on customize, access to the dashboard disappears. That’s not normal is it?

    So, the changes are exactly as I outlined above.

    I can be clicking on my “INFRAKSHUN” link at the top left of the home page or clicking customize from the dashboard – it still comes to the same thing: changes are not saved.

    I go to “colours” while in customize and press “save” – essentially do exactly what the tool says – and then I refresh the page (since I can’t go back to the dashboard) Changes disappear to show a change from yesterday morning i.e. white text on the header and beige background. This template keeps coming up whatever I do.

    #1602437

    timethief
    Member

    Hello there,
    Have you purchased a custom design upgrade?

    If you have not purchased the custom design upgrade note that no changes you try out aside from those such as Custom Background, Custom Header, etc. which are stated on the theme description pages in the features column (right hand side) will be visible to visitors.
    http://en.support.wordpress.com/custom-design/
    http://en.support.wordpress.com/custom-design/editing-css/
    http://en.support.wordpress.com/custom-design/custom-fonts/

    You do not need to load the design tools unless you have the Custom Design upgrade. All of these functions can be accessed from your dashboard – without loading the custom design tools – no upgrade required.
    Appearance > Header
    Appearance > Background
    Appearance > Theme Options (applicable only to some themes)
    Settings > Reading (set a static front page)
    Site Title and Tagline > Settings > General

    If you are using the preview mode for the Custom Design upgrade some of the settings in that mode will save but they won’t show up on the front end unless you purchase the upgrade.

    To go back to the free options, go to Appearance → Themes → Customize → Colors and click the “exit the preview” link in yellow at the top of the panel on the right.

    #1602438

    timethief
    Member

    @rasrock
    @rachelmcr
    I apologize, in advance, if what I posted is not helpful.

    #1602439

    rasrock
    Member

    No, I haven’t purchased anything nor am I using the custom design tool.

    #1602440

    timethief
    Member

    I have the Suits theme up on my test blog. I am running Firefox 26.1 on Windows 7 and I can change the header font color at > Appearance > Header
    Header Text
    __Show header text with your image.

    However, that change is not reflected on the blog so if the theme has this feature then there is a bug.

    #1602444

    rasrock
    Member

    Indeed.

    #1602445

    timethief
    Member

    When rachelmcr logs in again she will return to this thread to help.

    #1602446

    rasrock
    Member

    Thanks for your efforts timethief

    #1602447

    timethief
    Member

    You’re welcome.

    #1602448

    rasrock
    Member

    Yes, definitely something very screwy going on with the whole blog in general. The Tumblr sharing connections now don’t want to work either. Although the posts were being shared and shared links were working couple of days ago.

    Anyhow, I shall await the coming of rachelmcr …

    #1602470

    rachelmcr
    Staff

    Thanks for the additional details. Let’s dig in and figure out what’s going on. :)

    What is strange is that once I click on customize, access to the dashboard disappears. That’s not normal is it?

    Yes, that’s actually normal. I think I missed your comment about this earlier — sorry about that! The customizer will give you a live preview of the changes you’re making, along with a side panel with all of the customizer controls. We have some additional information about that here: Customizer

    I go to “colours” while in customize and press “save” – essentially do exactly what the tool says – and then I refresh the page (since I can’t go back to the dashboard) Changes disappear to show a change from yesterday morning i.e. white text on the header and beige background. This template keeps coming up whatever I do.

    When you’re in the customizer, you can click “save” to save your changes and then click “cancel” to leave the customizer tool. That will take you back to your dashboard. Clicking refresh while you’re in the customizer may make things a bit wonky. :)

    If that doesn’t make it work for you, can you please let me know exactly what change you’re making (for example, what color you’re selecting or what header text setting you’re choosing)? I understand where you are making the changes, but the exact setting you’re changing and what you’re trying to change it to can make a difference. That will also help me test the exact change you’re trying to make to see what’s going on.

    I have the Suits theme up on my test blog. I am running Firefox 26.1 on Windows 7 and I can change the header font color at > Appearance > Header
    Header Text
    __Show header text with your image.
    However, that change is not reflected on the blog so if the theme has this feature then there is a bug.

    Timethief, did you select any custom colors (e.g. the featured color pallettes) in the customizer? If so, those colors will override any header font color selection under Appearance > Header.

    I tested with the Suits theme default colors, and changing the header font color under Appearance > Header worked for me. I saw the change reflected on the blog. I’m happy to keep testing, though!

    #1602473

    rasrock
    Member

    If that doesn’t make it work for you, can you please let me know exactly what change you’re making (for example, what color you’re selecting or what header text setting you’re choosing)? I understand where you are making the changes, but the exact setting you’re changing and what you’re trying to change it to can make a difference. That will also help me test the exact change you’re trying to make to see what’s going on.

    I only refreshed the page before because of the problems I was having…

    Once in the customizer I go to Colours >Header Text > Select colour. I choose #470b03 then I thought I’d press default for the background settings to retain a grey or black palette. I can either go to the default button at the top or click on the first featured palette. Either way, the selected text it unaltered as it should be. OK. I then click “Cancel.”

    And once I do that, it immediately loses the changes and reverts back to white text in the header and beige background. It’s as though the page is fixed. Which to me at this stage suggests a bug as timethief mentioned.

    There’s really nothing more I can describe other than those basic steps. The key problem is after saving and then cancelling the changes are not being saved.

    #1602476

    rasrock
    Member

    I understand that the palettes can override the header text but I’ve gone to default and used all different ways to save the header text I require, but to no avail. It surely shouldn’t be this difficult to make a simple change?

    #1602491

    rachelmcr
    Staff

    Hi there,

    I just checked your blog, and it’s using a featured palette right now rather than the default color scheme for the Suits theme. To switch back to the default, you can click the default button in the very top right corner of the color panel. Here’s a screenshot to show where that is: https://cloudup.com/cRKJDZkWaqM

    Once you’re using those default colors, you can modify the header text color and the background color with the tools at the bottom of the color panel in the customizer. Be sure to click Save to save your changes, and then Cancel to exit the customizer.

    Can you let me know if those steps work for you?

The topic ‘Customizing choices not saving.’ is closed to new replies.