Dashboard loading is very slow using Firefox 3

  • Author
    Posts
  • #305394

    diogofsr
    Member

    Is it just for me or the Dashboard area is painfully slow?

    I run it on Firefox 3 at a Linux box and I can literally click on “Post”, go to the bathroom, grab a glass of water in the kitchen and come back in time to see the last stage of loading (sometimes not a full glass, but still).

    I have no past “Dashboard 2.7” experience as I started using WordPress less than a week ago but I had a sneak peek at my girlfriend’s and I don’t remember been this slow. Also, she told me that she indeed noticed a slow down.

    The frontend is actually ok with a normal loading. It is just the backstage area that is very slow.

    #305519

    dquartermane
    Member

    I am running Firefox 3 on windows and it works fine for me. Just letting you know.

    #305673

    diogofsr
    Member

    Thank you for your reply, dquartername.

    I just timed a “Post” action and caught a 1’01”.

    I asked my girlfriend to do such a thing and, although I didn’t times it, it went much more faster (maybe 5-10 seconds?).

    She is using it with Firefox 3.0.4 at Ubunut 8.04.

    I am using Firefox 3.0.4 at Ubuntu 8.10. So, it appears to be happening just here.

    Anyone out there with a Ubuntu 8.10 box could say if is this happening with you too?

    #305677

    diogofsr
    Member

    I forgot to mention that a have the 64 bits version of Ubuntu.

    #305678

    If you have any addons in FF, try disabling them. I have in the past has adblockplus muck things up and slow things down. You might have to “whitelist” all of wordpress.COM.

    #305681

    diogofsr
    Member

    More info.

    I tried with another computer with the same configuration (Firefox + Ubuntu) and it went ok.

    So, it appears to be definitely something here. Do you know what could it be?

    I erased my cache and cookies but it did no good in solving this problem.

    #305689

    diogofsr
    Member

    Nice, thesacredpath!

    I disabled them all and everything started to work well. So, one by one, I enabled them trying to isolated the troublemaker. Now I have all of them – adblockplus included – enabled I the performance is nice. I was unable to locate the specific problem as disabling them all and then enabling them fixed the problem.

    Thank you very much. :-)

    #305704

    diogofsr
    Member

    Unfortunately I stated “victory” too soon.

    After a while the agonizing performance went back.

    I will start investigating it trying to tweak “adblockplus” as advised by thesacredpath.

    #305708

    diogofsr
    Member

    I restarted Firefox and the performance went ok again so, I think I cannot say that disabling and enabling the extensions has worked because each time I did that I did also a restart. So, restart was the real “solution”.

    I added my blog to the adblockplus whitelist. I will continue using it to see with anything will melt apart again.

    #305748

    diogofsr
    Member

    As I said, I tried whitelisting my blog. No good. Same result.

    Then, I tried disabling the adblockplus all-together – Man! There’s a lot of ads in the web. No luck either.

    I am running out of ideas. My next shot would be delete the .mozilla directory (which is where the files about cookies, preferences and all are stored) but I really don’t wanna lose all of that (bookmarks, passwords…).

    Someone?

    #305750

    I don’t know if it could be a profile issue or not. Firefox keeps all your settings, bookmarks, etc., in a “profile.”

    http://support.mozilla.com/en-US/kb/Profiles
    http://www.borngeek.com/firefox/profile-tutorial/

    #305751

    Do you by chance have the wordpress “snow” feature running? It can severely slow things down since it is very processor intensive.

    #305752

    Wait, forget the last, that doesn’t show up on the admin pages.

    #305753

    diogofsr
    Member

    No, I disabled that feature (snow) as it puts my scrolling ability to its knees.

    #305762

    diogofsr
    Member

    Well, I deleted my .mozilla directory and the problem persist.

    #305768

    rosclarke
    Member

    Are you running it in https mode? That does slow things down. You could try using Gears to speed things up again (I have had limited success with this).

    #305853

    diogofsr
    Member

    The “https mode” was indeed on. I turned it off but the slowdown continues.

    It bugs me that the performance is ok in the early moments of a fresh start of Firefox but, as the time passes by, it becomes unbearable.

    The dirty fix for this is restarting Firefox every time I want to access the administration area or, much more important as it is the slowest of the actions, post or edit something.

    One question: The administration area, and more important, the post and edit area, load any flash application?

    #305894

    veronikab
    Member

    diogofsr, have you solved the problem? I’ve noticed the same in the last few days. I am running Firefox 3.0.5 on Windows, but so I was before and everything was fine, even with the new Dashboard. The only FF addon I have is Oldbar.

    #305895

    raul008
    Member

    Yeah, i disable Https but continue show this! :S

    #305896

    diogofsr
    Member

    diogofsr, have you solved the problem? I’ve noticed the same in the last few days. I am running Firefox 3.0.5 on Windows, but so I was before and everything was fine, even with the new Dashboard. The only FF addon I have is Oldbar.

    Actually, I don’t know.

    I started using another computer, ISP and internet connection (ADSL to Mobile) about a month ago and, because I was frustrated by this problem, I didn’t access my blog so often.

    That being said, I do not experience this problem right now.

    I think that could be something related with the fact that in this computer I did not check the “https” function, as it do not show it in the address bar but, because so much variables have been changed, I cannot say for sure.

The topic ‘Dashboard loading is very slow using Firefox 3’ is closed to new replies.