dashboard-widgets page doesn't work anymore

  • Author
  • #847914

    Posted a screenshot of my widgets page here:
    Screenshot taken after I clicked “Disable accessibility mode” but notice how the actual mode is also not shown properly.
    The page, as you can see, simply gives a full-width list of all possible widgets, both not-installed and installed ones.
    There is no drag area / side bar.
    And all widgets are shown in full (so not rolled up into bars).
    I still wonder if this isn’t just a case of some missing or faulty CSS.



    @kevinmayne Mate, sounds like a totally different problem, I’d make a different thread for it.

    My screenshots are on the first page, my pages are still looking like that now. Henkvansetten is having the same appearance :/


    In case it might help for debugging purposes, I’ve also posted the full source code (raw content) of the broken widgets page:


    @henkvansetten, thank you for the screenshot. I’ve posted it internally so I can get a 2nd opinion for where to go from here.

    I still wonder if this isn’t just a case of some missing or faulty CSS.

    When I test the widgets page, everything looks normal to me. Based on the information you guys have sent so far, I can’t really tell what’s happening on your side, but I can tell you that I did test the widgets page in several browsers including Chrome 17, Firefox 10.0.2, and IE8 and I was unable to reproduce the problem that’s showing in your widgets page screenshot examples.

    Next, what would be helpful is if you tried to capture some data from your browser. You can do this with a web inspector such as Firebug for Firefox or selecting View → Developer → Developer Tools in Chrome. Then load your widgets page and look for any errors in the network or console tabs. If we can pinpoint what files you’re having trouble loading from that, then we can give you further instructions that can probably help track down the issue.



    It was fine yesterday and the day before, but now I can NOT publish my blog to save my neck. I hope they fix it tomorrow.

    I haven’t changed or added any widgets, I just can’t get to the place to post my blog.



    I spoke too soon. It snapped back to normal for a little while and then it broke again. I have no idea what’s going on.


    Everything was working fine until a few days ago, for everyone here, I guess. Clearly the problem is not browser-dependent or something like that. So I would think the most logical step would not be to look for irregularities at the side of all these users, but to look for something that – within the last 3, 4, days – has been changed at the WordPress side. Some minor script change, something like that: something must have been changed at the WordPress side that’s now suddenly causing these problems for several people.


    Note that the problem you described is not happening for every user. The widgets page works for me without any problems, so I know that it does work on the WordPress.com side. I checked several browsers.

    I did check the code revision log for things that were updated 3 to 4 days ago–there are about 100 changes and I don’t know enough about this problem yet to know what to look for. Can you please provide additional information? If you check browser tools, you should be able to find a reference to what files are affected or possibly even an error message. Anything like that would be helpful.

    If you can’t find any error messages or information in your browser tools about what files are affected or what errors are happening, the next best thing is to look for similarities in the setups of the people reporting the problem and try to go from there.



    I’m having the same problem as in pyratus’s and henkvansetten’s screenshots, and in both FF 10.0.2 and the Ipad Safari.

    Firebug is a bit above my user grade, but here is the output from the FF error console when loading the widgets page, bunch of CSS errors:


    and the Dashboard:


    Both of these are from my primary blog http://factsandnorms.wordpress.com but my other blog http://endlessimmensity.wordpress.com/ is having the exact same issue.


    Thanks! I’ve passed this along to see if I can find out more.



    It may be that this is not happening to everyone, but I am pretty sure that it’s not a browsers fault. A few days ago it was just fine.

    my screen print is similar :



    It’s work! Finally! Thanks Hapiness Engineers!



    I still have the same widgetproblem, just as in the screenshot above, with different browsers. And when i try to change something in a widget and save, it says, are you sure you want to do that, please try again. And nothing is changed. And it happens over and over again.



    I’ve still got the same problem as in the above screenshot as well.


    It seems like people reporting this problem are mainly located in Europe, is this the case?

    We need more information. Can someone try checking the following things?

    1. Go to Users → Personal Settings and check the “Always use HTTPS” option. Try reloading the Appearance → Widgets page, and report back if that resolves the problem for you.

    2. Run a traceroute to s1.wp.com and s2.wp.com. At a Windows command prompt, run tracert s1.wp.com and tracert s2.wp.com Or in Mac Terminal, run traceroute s1.wp.com and traceroute s2.wp.com We’re looking for anything with a large number of timeouts in a row. If you see something like that, copy and paste all of the traceroute text and send it to us at http://en.support.wordpress.com/contact/ or post it to dropbox or pastebin and link to it in a reply here.

    3. Last, it would be very helpful for us to see the HTTP Response Headers for files served from the s0.wp.com, s1.wp.com, or s2.wp.com domains to your computer. One way to do that is to look at the Net tab in Firebug. Once you have that tab open, reload the widgets page and look for any lines that have s0.wp.com, s1.wp.com, or s2.wp.com in them. Click on those files and send us a screenshot of the HTTP Response Headers. Here is an example from my widgets page: http://cl.ly/F99j/o

    Thanks so much to anyone who can help provide any of the information listed above!



    @ Designsimply,

    Checking ‘always use HTTPS’ worked for me. Both widgets and menus are OK now. Thanks very much! (And yes, I’m in Europe.)

    As for steps 2 and 3, I’m sorry but I don’t understand how to tweak that… Hope this helps.



    Also in Europe here and experiencing this issue as well. Have checked the “always use https” option and it looks like things are back to normal.



    I too am in Europe.
    Ticking “Always use HTTPS” worked for me! Thanks!
    What a weird problem!




    Yes, I’m in Europe as well.

    1. “Always use HTTPS” does solve the problem.

    2. There are no timeouts in traceroute, but here’s the result, just in case.

    traceroute s1.wp.com
    traceroute to gs1.wac.edgecastcdn.net (, 64 hops max, 52 byte packets
    1 ( 30.553 ms 29.556 ms 29.275 ms
    2 ( 31.402 ms 31.101 ms 33.577 ms
    3 ge-1-3-7.rt0.the.uk.goscomb.net ( 33.101 ms 33.271 ms 33.567 ms
    4 xe-0-0-1-0.rt0.sov.uk.goscomb.net ( 33.829 ms 34.722 ms 33.602 ms
    5 xe-0-0-1-0.rt0.thn.uk.goscomb.net ( 35.022 ms 32.695 ms 32.484 ms
    6 ( 33.847 ms 33.262 ms 36.269 ms
    7 ( 33.804 ms 32.615 ms 33.472 ms

    traceroute s2.wp.com
    traceroute to gs1.wac.edgecastcdn.net (, 64 hops max, 52 byte packets
    1 ( 29.278 ms 29.449 ms 29.838 ms
    2 ( 33.442 ms 33.573 ms 34.017 ms
    3 ge-1-3-7.rt0.the.uk.goscomb.net ( 104.926 ms 35.615 ms 33.389 ms
    4 xe-0-0-1-0.rt0.sov.uk.goscomb.net ( 32.408 ms 33.035 ms 32.934 ms
    5 xe-0-0-1-0.rt0.thn.uk.goscomb.net ( 33.120 ms 72.019 ms 39.151 ms
    6 ( 33.156 ms 33.599 ms 33.150 ms
    7 ( 32.972 ms 33.477 ms 33.123 ms

    3. I’m getting a couple of dozen lines with s0, s1 and s2, so screenshots aren’t really practical. I dumped the whole thing into a txt file – it’s not very pretty, but hope you can use it.




    Actually, it seems to be okay now, even without using HTTPS.

The topic ‘dashboard-widgets page doesn't work anymore’ is closed to new replies.