Need help? Check out our Support site, then

Disable Comments

  1. I have tried to disable the comment box on the homepage. I followed the directions in help, and everything is unchecked under settings-discussions. The comments are disabled on all of my other pages but not the main home page. Is there something special I have to do for this page?

    The blog I need help with is

  2. By default the front page of the blog is the page all Posts are displayed on. It's the posts when displayed on their own pages after your click a post title or comment link that you disable or enable comments on, and not the dynamic page where posts are only showcased.

    This page > Settings > Discussion
    Discussion settings is where you set up defaults for comments.

    We can also override the default settings and enable or disable future comments on any individual post or page.

    Note: By default, new blogs on will have the Discussion hidden. You can reveal it by clicking on Screen Options on the top right corner of your Admin page, and checking the box that says Discussion so the module is included.

    You go to Pages > All Pages, hover over the page title, click Quick Edit, uncheck the option "Allow Comments", click Update. That's all.

  3. Is there a way to hide comments so it does leave a long trail of comments, distracting from the actual posts? I want to leave a small comment link that people can click on, which will transfer them to a separate comment page. Is this possible?

    Or is it possible to hide individual comments?

  4. No, comments will appear on the post or page that that the comments are associated with. You can however paginate and choose the number of comments that will appear below a post or page at settings > discussion in your dashboard.

Topic Closed

This topic has been closed to new replies.

About this Topic