Disable Comments

  • Author
    Posts
  • #1014389

    I have read the help item on disabling comments, and followed the instructions by unchecking the boxes, but the Reply/Comment tool/box still appears and is usable on allow the pages of my site. I want the site to operate as a website and not a blog, with no reader comments on either the home or any subsequent pages. How do I make this change?
    Blog url: http://nearnorthvoices.wordpress.com/

    The blog I need help with is nearnorthvoices.com.

    #1014472

    timethief
    Member

    Hello there,
    1. See: http://wpbtips.wordpress.com/2011/12/19/custom-menus/

    2. This page > Settings > Discussion
    Discussion settings is where you set up defaults for comments.
    http://en.support.wordpress.com/settings/discussion-settings/

    We can also override the default settings and enable or disable future comments on any individual post or page.
    http://en.support.wordpress.com/enable-disable-comments/

    Note: By default, new blogs on WordPress.com will have the Discussion hidden. You can reveal it by clicking on Screen Options http://en.support.wordpress.com/screen-options/ on the top right corner of your Admin page, and checking the box that says Discussion so the module is included. http://en.support.wordpress.com/modules/#list-of-modules

    #1014483

    Thanks for that. I tried everything those articles listed. On my primary blog page, the link for leaving a comment still appears at the bottom, at on all subsequent pages, the Reply Here and reply box still appear. I want to delete all reply and comment buttons and boxes, so that clicking on them is not even an option for viewers, but none of the articles seem to offer that as an option.

    #1014484

    Ok, I’m back. I just read a post on an external site that explained that unchecking the boxes under screen options didn’t actually disable anything, rather enabled tool boxes in which more boxes could be checked or unchecked to be enabled or disabled. This is very unintuitive for a non-techie like me, but it finally worked. Hoorah!

The topic ‘Disable Comments’ is closed to new replies.