Disable comments on a page

  • Author
    Posts
  • #1192357

    gunsnwar
    Member

    How can I disable comments on some pages of my blog? I want people to be able to leave a comment on posts and most of my pages, but there are a few pages in which I do not want to see comments, because they exist for a different reason. Is there a way to do it?

    The blog I need help with is gunsnwar.wordpress.com.

    #1192446

    raincoaster
    Member

    Edit the page and on the right-hand side you can change the discussion settings for just that specific post or page.

    #1192452

    justpi
    Member

    You can edit each page, or you can quick edit each page (faster), or you can select the pages and bulk edit them (even faster).

    #1192466

    gunsnwar
    Member

    Ok, found it. Thank you, both of you!

    #1192651

    Help. I cannot find the discussion setting on my page when I am in edit mode. http://ccfowler.com/

    #1192652

    justpi
    Member

    As the relevant Support doc says, if the Discussion module doesn’t show on the editor screen, you click Screen Options (top right) to make it appear.
    But you don’t need that module: it’s faster to go to Pages > All Pages, hover over the page title and click Quick Edit then check or uncheck the comments option and click Update.

    #1192653

    Thank you justpi! I very much appreciate your quick response :-)

The topic ‘Disable comments on a page’ is closed to new replies.