Disable Image commenting (new?)

  • Author
    Posts
  • #1112568

    Until you rolled out the new image handling, I never had an issue with comments being allowed on individual attached images with my Theme (Piano Black.) Now They are allowed and I don’t know how to disable it. Is it possible to do it without having to mess with the database (as was suggested in one thread I looked at)?

    The blog I need help with is alienredqueen.wordpress.com.

    #1112686

    timethief
    Member

    You can only have attachment pages with no comment box if you create the post under a no-comments-allowed default (in Settings > Discussion), then override that setting for the particular post after you publish it (post editor > Discussion module > tick “Allow comments on this post”, or Posts > Edit > Quick Edit > tick “Allow comments”). http://wpbtips.wordpress.com/2009/04/26/images-the-three-link-options/

    #1112732

    Why did they change this? This sounds like a pain in the butt and a lot of unnecessary steps. Booo. Well, thanks for the tips.

    #1112733

    If I change the default setting now, it won’t change on my previous post that already have comments, will it?

    #1112794

    Think I found an easier way… Where it says attachment link when you ad d the media, just change it to “None.” Then you can’t open the pic in another tab anyway, so no comments.

    #1112795

    timethief
    Member

    I’m glad to hear you achieved what you want. Happy blogging.

The topic ‘Disable Image commenting (new?)’ is closed to new replies.