disable image comments

  • Author
    Posts
  • #434918

    fotojo
    Member

    Hello, i have just finished trying to create a portfolio using the journalist theme…(www.anonography.wordpress.com) and have therefore disabled comments on the gallery pages.
    however, when using the gallery viewer, the comment box appears. This also accepts comments for each image. is there a way to deactivate this?
    thanks for your help.

    The blog I need help with is anonography.wordpress.com.

    #435066

    timethief
    Member
    #435121

    fotojo
    Member

    It still dosnt disable comments, when you actually open an image in the gallery viewer..
    i might have to display the photographs in a different style. then again, i am getting to grips with the concept of a comment for indidual images!
    thanks anyway.

    #435128

    raincoaster
    Member

    As far as I’m aware, there isn’t a way to do it when you link to Page in your image settings. If you link to File, they can’t comment, but then you don’t get the lovely framework of the theme. Up to you.

    #435132

    1tess
    Moderator Emeritus

    fotojo

    If you want a gallery with attachment pages that do not allow comments, it can be done. You can’t change the post you have now; you’ll have to make a new post.

    Before you add another post to your blog, go to Settings —> Discussion Settings —> Default Article Settings —> uncheck the box that says, “Allow people to post comments on new articles” —> Save.

    Go to your dashboard and add a new post. Upload your pictures again. But be sure to give them new titles; if you don’t then WordPress will do it for you by adding a “1” to the title and that makes things confusing. Add the “new” re-uploaded images and make a gallery of them. Now when you view the gallery the pictures open with no comment boxes below.

    If you want comments on the post itself, then go back and edit the Discussion module on the edit post page to allow comments. People can comment on the post, but not on the attachment pages now.

    Publish new post. Delete the original post/first set of images.

    #435134

    1tess
    Moderator Emeritus

    fotojo

    Wait, sorry that is too complicated! You don’t have to re-upload your pictures.

    Delete your post (save text somewhere else). Do NOT delete your image files.
    Turn off the Discussion for your blog as I described above.
    Add new post. Save. Remember the title. The easiest thing now is to publish the post.

    Privately published post won’t work. Draft status will, but WP won’t reveal the attachment status in the next step.

    Go to your (Media) Library and filter for unattached images. Follow the instructions here:
    http://en.support.wordpress.com/media/unattached-files/

    If you want comments on the post itself, then go back and edit the Discussion module on the edit post page to allow comments. People can comment on the post, but not on the attachment pages now.

    (or change the discussion setting for your whole blog, but remember to switch it back before making another post with a gallery.)

The topic ‘disable image comments’ is closed to new replies.