disappearing paragraph breaks

  • Author
    Posts
  • #38669

    suerandall
    Member

    Please help, I cannot get any paragraph breaks to appear in my posts. I keep updating and editing my posts to try and insert the breaks but they always just disappear when I save or publish.

    I am typing my text in Word application and copying and pasting to the blog. Is this causing a problem?

    #39011

    timethief
    Member

    (1) It’s not WORD that’s causing your problem. It’s the editor. This will do the trick.
    <p>&nbsp;</p>
    (2) However, WORD is problematic because microsoft invented their their own html code bits for WORD. Thus when we use it there’s a whole bunch of garbage code bits the wordpress programming must strip out.
    (3) If you want to prepare your posts off-line the way I do WORD is a poor choice. A better choice to make would be to download a free copy of BlogDesk http://www.blogdesk.org/en/index.htm

    #39012

    timethief
    Member

    sorry about the duplicate post :(

    #39029

    suerandall
    Member

    Thanks so much. I’ve downloaded BlogDesk and will see if I can find a place to insert that code into my most recent posting!

    #39037

    timethief
    Member

    You’re welcome :)

    #39200

    blogniagara
    Member

    I have the same problem and I am using Dreamweaver.

    #39201

    I would suggest an offline editor instead of Dreamweaver. It’s meant for making web pages and inserts all sorts of stuff into the file. Download and use one of the offline editors. Timethief has gathered the information about all of them together and posted it on her wordpress resources blog: http://islandtimethief.wordpress.com/2007/10/26/offline-blog-editors-reviews/

    #39202

    In addition, if you are pasting it into the wordpress editor window in Safari, it won’t work. Safari isn’t supported by the online editor made by TinyMCE. Firefox works very well, or Camino, but not Safari. If you use Safari you have to turn off the visual rich text editor. Users, click edit on the line with your name and then deselect “use visual rich text editor.”

    #39203

    blogniagara
    Member

    Thank you.

    #39204

    You’re very welcome. Happy blogging.

    #39205

    timethief
    Member

    @thesacredspace
    I think you meant -> Users -> Your Profile when you referred to the page where you can turn of the visual rich text editor.

    #39206

    @timethief
    That works! :)

    I sort of short-cutted it and shouldn’t have. You can get to it by clicking “edit” at the end of the line with your username as well.

    #39207

    timethief
    Member

    I just tried your shortcut – cool. ;)

    #39208

    Not sure if it’s really a shortcut or not, but certainly redundant?

    #39209

    timethief
    Member

    Ahhh … yes but isn’t redundancy a given when it comes to IT? :)

    #39210

    I would hope so. As we all know, “stuff” can (will) happen.

The topic ‘disappearing paragraph breaks’ is closed to new replies.