Div tag

  • Author
  • #110072


    I am having trouble using the div tag in my richtext editor. The editor cuts it out every time I save. I tried #ab {etc….} in my css, then <div id=”ab”… </div>, as well as variations on this and could get nothing to work. This code works perfectly on my Yahoo site, but not here. Am I making some kind of syntax error particular to wordpress? I’m using the them connections.






    Just for reference, you’ve answered your own post. Usually that means someone has answered the person asking the question and sometimes you wind up getting skipped. It’s not recommended.

    You’re telling us that it’s not working but you’ve not told us what specifically is occuring. Is the stuff you;ve entered into the CSS file staying there? Is it being removed? What about the post? Can you point at an example of what is occuring please?


    the div tag gets eaten by wordpress.com. it’s a long-standing bug.



    drmike and sunburntakamel, Thanks for the repies. Drmike, I won’t write myself again, but did it this first time to test if I received the email that the site said I would receive when someone answered my question with a post of their own (note, I check favorites). I didn’t receive one for myself or for any of the subsequent post. I double checked my email to make sure the address I had listed was correct. So there may be a glitch there.

    Regarding the actual div problem.
    1) I placed various forms of the div tag in my ccs: #ab{…} div#ab{…}, etc.
    2) After each try I referenced them in the richtext editor using <div id=”ab”>…</div> or some variant thereof.
    3) The ccs accepted and retained all variants of the div tag I entered
    4) but in each case the rich text editor failed to retain the <div…> coding. When I returned to the editor, all I found was , with the div tags gone.

    I also tried putting the div tags in the rich text editor between .... Got the same end result. The span tag works but not the div tag.

    I’ve been very thorough in exloring this and am a bit concerned because the div tag is such a powerful structural element. At this point I am tempted to assume that sunburntkamel is correct, that this is a bug. If that’s the case, is there anyone I can write to to have this addressed? Thanks. For now I’m making due with tables, but will look forward to additional comments on this.



    A feedback to staff is the way to go when it comes to reporting any possible bug.



    The good news is that this bug has been fixed https://en.forums.wordpress.com/topic.php?id=14547

The topic ‘Div tag’ is closed to new replies.