Do photos publish immediately?photos in text/photo credit

  • Author
    Posts
  • #595783

    cath888
    Member

    Hi, I want to publish my first post. It’s all written- and I’m trying to add photos. I found one of the photos on Flickr and want to insert it into my text…. the photo has the share icon for WordPress…. but it looks as if it will publish immediately if I tell it to post to WP from Flickr. Is there a way I can put the picture where I want it and publish it when I want to?
    Also…. I like the way this WP blog author credits photos. https://filipspagnoli.wordpress.com/2009/11/02/homelessness-a-collection-of-images/
    This author has a little “source” link below the photos. Can you tell me how I can do that, (I did write the blog author but have not heard back)? I want photos to flow along with my text, but of course want to honor to the photographer. Is there a best way to do this?
    Thanks for your help! Catherine

    The blog I need help with is edenstream.com.

    #595914

    raincoaster
    Member

    The way to do that is to download the photo to your hard drive, then upload it to your blog like a regular image, then underneath the photo just type the word Source and highlight that word and link it to the source page on Flickr.

    #595953

    justjennifer
    Moderator

    Even easier now. You can simply copy the address of the page on flickr, paste it into your post, making sure it is not highlighted as a link (unlink if needed) and the image will show up.

    #595957

    justjennifer
    Moderator

    And before that method will work you have to enable it on your blog under Dashboard>Settings>Media>Auto-Embeds> and check next to “When possible, embed the media content from a URL directly onto the page. For example: links to Flickr and YouTube.”

    #595961

    cath888
    Member

    Thanks much. I will try again to do this as you have said.
    Previously, I did save the photo to my hard drive. When I uploaded to my post and viewed as draft- I had a blue question box… and when I clicked that- I had a bunch of attributes and no picture.
    I saved to my hard drive with another photo from elsewhere and had no trouble- but wondered if I had broken the rules with Flickr somehow.
    Thanks again!

    #595962

    cath888
    Member

    I made sure my settings were correct as above.
    I copied the address, pasted to post and all I had was the address- no photo.

    When I right click to copy to my hard drive- I get an all rights reserved notice.

    I don’t see another way for me to take the photo other than through the WordPress icon which appears to place the picture on my blog, independent of my post.

    Sorry to miss whatever is probably very elementary and obvious.
    Thanks for helping me!

    #596060

    raincoaster
    Member

    What is the URL of the photo on Flickr? It may not be sharing-enabled.

    #596062

    cath888
    Member

    Thanks again for your reply. The URL is http://www.flickr.com/photos/zfayssal/4127653707/

    I have written and received permission from the photographer. It allows me the share it to WP, but appears to post straight to my blog. I want to add it to my text.

    Also, the photographer has asked that I not forget to add the copyright. I’m not sure I know how to do that- and am a little unclear about the box that is associated with each picture that says: Title, alt text, caption, link URL…. not sure what should be in the link URL box. I promise you that I have spent many hours reading forums and support- but still feel a bit at sea on these things.
    Thanks!

    #596083

    justjennifer
    Moderator

    Using oembed like I mentioned above:

    1. Paste that link in your post.
    2. Make sure it isn’t highlighted like a link. If so, in the Editor tool bar click on the “break link” button (looks like a broken chain link)
    3. Underneath the link write “Copyright Fayssal Zaoui and used with permission”
    4. Write the rest of your post
    5. Publish Post

    When you view your post, the photo will be already linked back to the photog’s flickr photostream.

    #596087

    cath888
    Member

    Jennifer…. I feel like a dweeb. I did EXACTLY as you said. I used the link in the post you see above. I have my settings right. I broke the link. When I look at the draft, there is no picture.

    #596094

    justjennifer
    Moderator

    You won’t see it in the draft, but you will see it in the preview. :)

    #596095

    cath888
    Member

    Hi! it doesn’t show in the preview :(

    #596107

    justjennifer
    Moderator

    What do you see in the Preview? Did you remember to check the box to allow Auto-embed in Settings>Media like I mentioned?

    Here’s a post on my demo blog showing a photo from my own flickr account as an example. http://ablogdemo.wordpress.com/2011/04/09/oembed-test-post-flickr/

    #596151

    cath888
    Member

    Thanks so much for staying with me. I do have the ‘allow auto-embed box’ checked. I had already written my post, so I just pasted the link above the writing in my post. It reads:

    lonely child

    I broke the link. It did take on the characteristics of the rest of my text (italics).
    I can start over and go through the process with a new post… but that is not the only picture I want to insert. Thanks!

    #596162

    cath888
    Member

    I started over… did all you said… the picture we have been talking about was visible in my preview- so I pasted my text in. When I went to paste in another URL to another picture- I’m back to the same problem. I have followed all the above instructions and get no picture. Help! I’m ready to pull my hair out.

    #596163

    I’m utterly confused. However, I suggest raincoaster’s method. I don’t find any problem by doing it.

    #596164

    cath888
    Member

    Hey Guys!!! Guess what!!! I think it was the italics. When I pasted the URL in to my text- it took on the attributes of my text. I went in and changed the text in the URL from italics to plain text, I got a picture. Happiness!!!
    Thanks everyone for sticking it out with me.
    The end.

    #596167

    justjennifer
    Moderator

    You’re very welcome! So glad you got it to work for you.

    Correct that you can’t style the link itself and, like the Twitter Blackbird Pie, it has to be on a line by itself and not appear as a highlighted link.

    Happy blogging!

    #596171

    Oh, so thats why. Hope you have fun!

    #596198

    cath888
    Member

    Okay… maybe not quite the end. I have my photos up, (using the methods above), but now I would like for the copyright statement that I have typed beneath the photo not to be as large as my text. Can anyone tell me how to or if it’s possible to change that?

The topic ‘Do photos publish immediately?photos in text/photo credit’ is closed to new replies.