Need help? Check out our Support site, then

Domain Help

  1. I have Premium with registered as included in premium service, but I cant get the site to work. Site is primary but keep getting DNS needs to be updated on dashboard. DNS link takes me to Using the DNS tools provided by your domain registrar, remove any existing nameservers and add the following:

    The blog I need help with is

  2. It looks like the domain has not been registered. You can register and associate it with your blog from your domain management screen.

  3. Thanks for reply! From the paid upgrades page for my account it list both domain names.

    PRMARY: Manage Domain Subscriptions
    Expiring Will stop functioning on April 7, 2014 Edit DNS Manage Domain Subscriptions
    Expiring Will stop functioning on April 7, 2014 Edit DNS

    The primary domain for your blog is The other URLs above will redirect to that domain.

  4. I'll tag this thread for Staff assistance. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

  5. Thank you very much! I appreciate it!!

  6. You're welcome.

  7. Both whois and Domain Helper show as not being registered

    To get to work you need to do two different things in addition to buying a package - - needs to be registered - needs to be mapped to a blog here

    It looks like you might have mapped a domain name that is not registered - you should have gotten some sort of credit or something when you bought the bundle - that credit should allow you to register the name

    Your description of what you see sounds like only for Domain Mapping

  8. I took a look and everything is working properly.

    If you don't see the change yet please try clearing out your browser cache.

    Looking forward to your reply.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.