Need help? Check out our Support site, then

Domain mapping causes invalid key error message

  1. I registered for my blog through the domain upgrade in the admin. When I set as the primary domain and try to read the blog while logged in, I receive an invalid key message and cannot view the blog at all.

    Here are the things I've already tried:

    1. Cleared browser cache and cookies - ERROR persists
    2. Used a different browser - ERROR persists
    3. Reset password - ERROR persists
    4. Logged in to an unrelated blog ( and then tried to read - ERROR persists
    5. Attempted to read other blogs with custom mappings (such as while logged in - ERROR persists
    6. Blocked 3rd party cookies in browser - NO ERROR, but doesn't show as logged in while reading blog (no admin toolbar)
    7. Searched forums for help and found others with the same issue unresolved - NO HELP
    8. Submitted request for help to WordPress Support - NO RESPONSE

    My conclusion is that any user who is logged in (including me - bakerlady) will receive the invalid key error and not be able to read my domain mapping.

    Please advise on a resolution. WordPress should not provide premium features that breaks standard functionality.

    The blog I need help with is

  2. Have you waited the prescribed "up to 70 hours" for the DNS to settle down? Until at least a day has passed, don't change passwords or anything. Wait. It simply takes time.

  3. You did purchase the Domain Mapping? - put me on your which displays just fine (just not with the domain.

    Support is not immediate it can take a while. It can also take 24 to 72 hours for the domain changes to take effect.

    When I moved two sites recently onto .COM worked fine for me - no broken anything.

  4. @raincoaster - The domain was brand new, so it should be instant across all DNS servers (there is no cache of a previously non-existent domain). And yes, it's been almost a week now. Also, this affects all other sites with domain mappings that I try to view while logged in. So this is not something peculiar about my domain.

    @auxclass - Yes, purchased domain mapping. I have intentionally kept the domain as because I can't view the site at while logged in, and based on my tests, other users won't be able to either. Why would I activate a domain that blocks me and others from viewing my blog?

  5. This one is hard to follow for all the jokes about cookies, but it describes the same issue and has been unresolved for 3 years: Unable to view domain mapped blogs.

  6. Then you need to contact staff via your dashboard Help button. We've reached the limit of what we can do for you.

  7. DNS changes are never instant, even for newly setup ones. However, typically most people can see DNS updates within a few hours or sooner even.

    It's my understanding that the 'Invalid key' message only appears if you are trying to reset your password and the key sent by your browser doesn't match the username you entered. In my experience, clearing browser cache very often resolves this problem. In your case, something else is going wrong for you. The upgrade itself doesn't break the standard functionality though. There are thousands and thousands of people using custom domains who can view their mapped domains while logged in without seeing that error.

    Can you make sure you are allowing through third party cookies for * as well as

    I'm interested in resolving any possible underlying bug, but it requires more digging. If you'd rather try something like a manual password reset or another route, let me know and I can try that for you.

  8. Please keep in mind that we answer as fast as we can and response times can vary depending on the number of requests ahead of you.

  9. 1. This isn't a DNS issue. Let's not discuss that anymore.
    2. I don't care about thousands of folks who don't have the problem. I have it, and that's what's important.
    3. I do not block any cookies, and I have already explicitly set both * and on the allowed cookies list. Error persists.
    4. To be quite clear, I cannot view ANY domain mapped site while I am logged in. This isn't just my own blog., and any others I've tried all give me the same error.
    5. This isn't just my login, either. When I log under my husband's account (, I receive the same errors when viewing ANY domain mapped site.
    6. I have attempted this on Firefox 3.6, Firefox 4, Internet Explorer 8, Windows XP, Windows 7, cleared cookies and many other variations. The error persists.
    7. The only time I've been able to view a domain mapped site on the network is by BLOCKING third-party cookies, but that means I can't access the admin toolbar while reading my own domain mapped site.

    I'll be happy to provide you any other level of detail you'd like to troubleshoot further. I can even give you HTTP headers, if that helps. I don't want set up my own hosting and migrate my domain just to overcome this issue, so I'll gladly jump through any hoops to get this to work.


  10. Okay, I'm not totally sure what to test next just yet! This is a tough one to troubleshoot because I've tried to get the same problem to happen a few times in testing and I can't reproduce it. When I check your account, it looks fine to me in testing.

    I'm not sure HTTP headers will help, but they can't hurt! Can you post one please? Bonus points if you can catch anything with "remote-login.php" in the URL because I *think* it might be related to that function.

    By any chance, do you have access to test from a different internet connection? Maybe a phone with a 3G connection possibly?

    Sorry if pointing out the DNS clarification made you mad. I just wanted to clarify it so that someone else reading this thread later would know that DNS changes are not instant. I understand this issue is important to you, but also the upgrade does not break the standard function of the site like you said. Don't worry though!, I'm sure we can figure out the trouble together (and I may also need to get some additional help tomorrow).

  11. What does the error look like exactly to you? Does it say "Invalid key." and nothing eles at all on the page? Is there a "Back" link on the page too?

  12. This is a real longshot, but I'm remembering something from years ago and wondering if you've updated any of your firewall or virus scanning software in the past week? Or Flash?

  13. Good idea actually, testing from an alternate computer and connection is an easy way to rule out something like anti-virus, firewall, or some other kind of filter from the computer or local network interfering. And it's a very good educated guess imo.

  14. This other forum topic actually provides some HTTP header details and descriptions of what is occurring: Unable to view domain mapped blogs.

    When trying to browse the a domain mapped site, it appears to load all the HTML, but as it begins executing the JavaScript, it runs the remote login function. The page hangs, then redirects to something like this:

    (I intentionally modified this URL's IDs so that it won't reveal any security information).

    The only text on the otherwise white screen of death is:

    Invalid key. Back

  15. Aha!, so it does have to do with the remote-login.php file... hm.

    Oh, I need the real IDs. Can you email the real URL as a reply to the support request you made before so I can look at it more closely?

  16. @bakerlady, scratch that last request. I don't think I need the URL. I tried several tests today and still could not reproduce the problem you've reported. I have a few more ideas though.

  17. I'm having the problem for my blog too- and this is directly after mapping a new domain (paying for an upgrade to remove "wordpress" from my site domain name).

    This problem only happens on my Windows 7 computer on all browsers, but not my Mac Laptop.

  18. Disabling Java script allows me to view domain-mapped blogs, but I can't comment while logged in as my user.

  19. @allenob, are you absolutely certain you have enabled third party cookies for * as well as ?

    Do you have any anti-virus, firewall, or similar software installed at your location that could be interfering?

    Is there any chance you can try logging in from a different internet connection to see if the same problem happens from a different location and network connection?

  20. Hi guys, any updates? :) And are there any other users with this trouble?

  21. michaelepicray

    Yep. I get it when I try to log on to my blog and at least one other (I don't go to too many blogs).

    And my blog.

    Except for updating existing programs like antivirus and anti-malware, I've made NO changes to either my machine, the configurations on it, or my account.

    When I first started Blogging here, my blog opened with no utility bar at the top, and I had to use the Dashboard to access my functionality. Now that it opens with the utility bar, it doesn't open without keying on the "back" command as mentioned above. ("Invalid key - Back" message)

  22. michaelepicray

    NOW when I try to access wordpress blogs posted on CNN, I get invalid key back message - and it will not allow me to see the post at all. I'd suggest you find the problem and fix it before CNN and everyone else says fooey on WordPress!!!

  23. michaelepicray

    The problem appears to be in your log in programming. When I am NOT logged in to my wordpress account, I can access wordpress blogs without difficulty. When I am logged in, I get the invalid key stuff.

  24. @michaelepicray
    I have flagged this thread for Staff attention. Thanks for your patience.

  25. To be perfectly honest, I doubt it's a problem in our system, or we'd be seeing far more than two reports.

    I don't see Chrome mentioned here yet. Would you please try logging in with Chrome?

    If that doesn't work the first time, please open an Incognito Window through Chrome. This is a very important troubleshooting step, as it shuts off all add-ons, as well as Chrome's cache and cookies.

  26. I have just experienced the same problem on one of my sites with domain mapping - I know the site's fine, having checked it from another computer.
    My virus settings (through Avast) were updated automatically earlier today; perhaps that's got something to do with it? I am now going to poke around their settings...

  27. When I try to go to the site this is what the URL does (even though I'm not trying to go to the site as a logged in owner; in fact I first realised this was happening when I clicked on a link in Google to my own site):

  28. michaelepicray

    No. I will NOT try logging in with Chrome. I do not have Chrome and will not install it. I don't need fifty million browsers. If your system only works with chrome, then it appears that I made a bad choice to base my blog on your system.

    Your system is the ONLY one that I have this problem with. And I ONLY have the problem when I try to access ANY WordPress blog while logged in. If I log off, then I can directly access ANY WordPress blog without the problems.

    The problem is either with YOUR PROGRAM or with the way YOUR PROGRAM interacts with other programs! I already did the preliminary trouble shooting for you by identifying WHEN (under what circumstances) the problem arises. Now it's your turn to do something besides blame others and minimize the issue.

    Only two people with the problem? You apparently haven't seen the other thread on this issue. I was referred to this thread from that one. And the problem isn't new either. But hey... if you put off doing anything about it long enough, maybe someone will start a new thread and refer people there so you can pretend that it's not really a problem.

  29. michaelepicray

    By the way - I'm just using a workaround now since you don't seem to care about fixing it. If I get the error message, I either click the "back" command, which allows access, or if it doesn't, then I go to my blog and log off, after which the error message doesn't appear again until I log back on.

  30. michaelepicray

    And while we're on the subject of crappy program features, why does youir program keep rejecting my PW? Last night, I ended up putting in a "new" PW to gain access to the program... which of course was the SAME PW I used before, typed exactly the SAME way. Then this AM, my dashboard rejected my PW, but took it after I ENTERED IT THREE TIMES. i'D THINK THAT IF IT WAS "WRONG" THE FIRST TIME, iT WOULD BE WRONG THE NEXT TWO.

    Oh... and lest you get snarky and try to blame ME for the PW issue, like saying I must have miskeyed or something, I have it on auto - so the computer entered it the same way it's been entering it since I acq

Topic Closed

This topic has been closed to new replies.

About this Topic