Need help? Check out our Support site, then

Domain mapping causes invalid key error message

  1. michaelepicray

    ... acquired an account here.

  2. I also started having the problem that I cannot access certain wordpress blogs when I am logged in. Last week, I was suddenly unable to access, which I am subscribed to, even though I could access it before without any problem (when logged in). I have no problem with accessing that blog when I am not logged in. I have seen it with about four other blogs too.

    I just want to know what I need to so to rectify it. Are there any settings I should change in my account, on my browser (Google Chrome), Windows XP, etc?

  3. michaelepicray

    Good luck. The "help" people told me that it was probably somehow my fault - that the problem was probably because of my browser, or something that I was doing because they only had TWO people complaining about it. They suggested I install MS Chrome because that's the primary troubleshooting tool. I call BS on that.

    I'm thinking that what we are being forced to deal with here is an incompetent or lazy programmer who doesn't know how to fix the problem, so denies it exists. If you know others who have the problem, suggest to them that they should come to this forum and log a complaint so the "only two" stuff goes away.

    What I'm forced to do is, when I run into the block, I open another tab (Firefox is my main browser) and log off WordPress, then go back and cycle the page I was denied entry to and that works.

  4. michaelepicray

    Hey, Mac

    You said:
    "To be perfectly honest, I doubt it's a problem in our system, or we'd be seeing far more than two reports.

    The arrogance just DRIPS from your reply!!! Just search "invalid key" in the WordPress search box."

  5. michaelepicray

    This problem has been going on for FOUR YEARS!!! Don't you think someone should do something about it?

  6. It's actually quite weird because i don't have a problem with viewing most wordpress blogs, just literally a small handful. Having said that, the last time I experienced a "you're the only one out of all our customers attitude" attitude from a company, I took my issue to the regulator and won. (It is was different issue - misleading advertising in a print publication.)

  7. michaelepicray, since neither of us can duplicate this issue, we can't even begin to figure out a cause or solution if the problem can't be narrowed down. The first thing to do is to narrow this down to hopefully a browser-specific issue, but since you aren't willing to simply install Chrome and check this, we really can't proceed. It's nearly impossible to fix an issue that we can't experience first-hand if we also can't narrow down the likely possibilities.

    lowsaltfoods, would you please be willing to try another browser, like Chrome if you're using Firefox, or visa versa? And please do let us know if that makes any difference.

  8. I'm getting the same problem, but only for the one domain that I've registered. If I'm logged into WordPress and go to (in Chrome and Explorer), I get the white screen with the message: "Invalid Key. Back" and the back link does not work. If I'm not logged in, I can view the site fine. I can visit my other blog without any problems, whether I'm logged in or not. This is really frustrating and has only emerged recently. Everything was working well just a few weeks ago and I made no changes to my system or virus protection. Nor did I try to change my password in WordPress.

  9. If it's any consolation, my experience of this seems to have spontaneously fixed itself. No idea why, but suddenly I can view my site when logged in fine again.

  10. Okay, I am also having the same problem (I will refrain from explaining it in any detail since those with greater tech-savviness have already done so). Ironically, I've been trying to resolve it with support staff on a private thread and they too regard this as something completely unique and an isolated problem. They also have me jumping through various diagnostic hoops to no avail. Whether using Chrome (yes, Chrome!!!), Firefox, or Explorer, on multiple computers, I have the same issue: the dreaded "Invalid Key: Back" screen when signed in, whether accessing my own or other WordPress blogs. I changed my domain in January but only began to have this problem in late July or early August, and it still persists.
    So let me add my voice to what I hope will become a growing chorus in order to stimulate constructive action: THIS IS CLEARLY A GLITCH IN THE WORDPRESS SYSTEM!!! WORDPRESS STAFF, PLEASE STOP ASKING US TO DIAGNOSE THE ISSUE FROM OUR SIDE AS IF THESE WERE ISOLATED ANOMALIES. TAKE THIS SERIOUSLY!!!
    Incidentally, not sure if this is meaningful but today I began receiving "Invalid key [6]. Back" instead of plain ol' "Invalid key: Back."

  11. Incidentally, not sure if this is meaningful but today I began receiving "Invalid key [6]. Back" instead of plain ol' "Invalid key: Back."

    I started receiving that message yesterday as well.

  12. One kind volunteer who was experiencing this problem helped us further debug the issue.

    Unfortunately, the problem we uncovered is not one we can fix directly; the problem for this specific person was caused by a bug in their Internet Service Provider (ISP).

    First, some background. As you all know, knows you're logged in because of a cookie it sets in your browser. Cookies, though, are specific to one domain, so doesn't know about the cookie and so doesn't know that you're logged in. We use that remote-login URL to allow and to compare notes about whether or not you're logged in. If says you're logged in, that URL will set a cookie for, and everything's hunky dory: you now have a cookie on both and and so are logged in everywhere.

    For your security, each URL like can only be used once. If you try to go to one of those URLs a second time, you'll get the dreaded "Invalid key [6]" error on an ugly useless page.

    That's essentially what was happening in our volunteer's case, but it wasn't their fault. It was the fault of their ISP.

    For some reason, whenever our volunteer tried to visit the URL to get the cookie, their ISP stepped in and visited that URL first. So when the real person visited, it was actually the second visit that saw, and spat out the ugly error we all know and hate.

    There's not much we at can do to fix the problem from our end. At some point, we intend to fix the symptom of this problem: we want to change our procedure so that you don't get stuck in an endless loop of ugly errors. Instead, you'd get stuck as not-logged-in. You'd still be logged in in your blog's admin section, so you could still add posts, moderate comments, view stats, etc., but you wouldn't be logged in when viewing your blog: no admin bar, and no prefilled comment form. Clearly, that's not good behavior, just better than what currently happens.

    Unfortunately, we don't have any ETA for when such a symptomatic fix might happen.

    The actual problem in our volunteer's case is something only the ISP can fix. There's some bug in their system; the ISP shouldn't be making that first request to, which breaks the real person's request to that URL.

    I believe our debugging volunteer has satellite internet and that their ISP is trying to be clever about prefetching content (to attempt to get around the lag inherent in all satellite connections). That cleverness appears to be buggy.

    Others with satellite internet may be in a similar situation.

    We'll continue to work on making the experience better (as in, not terrible) and will look for alternate methods of truly solving the root problem. I'm sorry to say, though, that any fixes will probably not happen soon.

    In the meantime, you can use one of these annoying workarounds to view the contents of your blog:
    1. Set your browser to block cookies from (or whatever your domain is)
    2. Log out of before visiting your blog.

    Neither is good, and both are annoying. (Also remember that, if this ever does get really fixed, you'll want to unblock cookies.)

    I apologize for the frustration. Please continue to let us know about any problems you encounter on

  13. Hi,

    I just wanted to add to this. My ISP is Sky in the UK. I am using Chrome, and am faced with the exact same problem when logged in and viewing my own blog at,

    I hope a solution comes around soon.


  14. Hello,

    Wanted to mentioned that I, too, cannot view my own blog nor other blogs while logged in under my account. My blog is

    A solution would be greatly appreciated.


  15. @cuethebango
    Will you please provide us with some details so we can try to help you?

    1. How are you connecting to the internet and to The way you connect to the internet (mobile, satellite, DSL, dial-up) and to your blog, and how many proxy server jumps etc. it takes to connect can cause problems. There maybe be problems with your ISP and/or with the proxy servers.

    2. Are you using http:// or https:// see

    3.Which browser and version of it are you using?

    4. Have you tried clearing your browser cache and cookies?

    5. Is your browser version up to date? You can upgrade any browser version here.

    6. Do you have third party cookies enabled?

    7. Do you have JavaScript enabled?

    8. Do you have another browser you can try?

    9. You can use this link to see if your Flash is up to date. If it’s not up to date then this is where to download and install the latest version of Flash.

    10. Have you had any recent operating system and/or security program updates?
    Sometimes operating system and/or security system updates can cause problems so check for known issues.

  16. michaelepicray

    Look - Every time someone complains you all come up with a reason that it's somehow someone else's fault. Well if that's the case then you must be the only competent site on the internet because I do not have this problem with ANY OTHER SITE - and what's really weird about the thing is that I'm using THE SAME ISP EVERY TIME!!!

    The problem is YOUR fault!!! YOU are doing something WRONG!!! I can't even go from my dashboard to one of my articles when I'm logged in. I can't edit from the dashboard either. And I am prevented access to OTHER web sites if I logged on HERE first. If I log on anywhere else - I have NO problem accessing other sites that require me to be logged in - ONLY WHEN I FIRST LOG IN HERE!!! If I try to use a function in another site after logging on here, it denies me access and I have to open word press and log off, then log in at the other site after which I can access anything else.

    IT'S NOT Chrome, It's not Firefox. It's not my ISP. It's YOU!!!

  17. Just an FYI, I've been having this problem a lot, specifically with WordPress blogs that have moved to their own domains over the past month or so. I'd be surprised if it's a browser, OS, or cache related issue as I just got a new MacBook Pro and am using Chrome for the first time and the problem persists (previously on OS 10.4 using Firefox).

    I am getting the Invalid Key [6] message quite frequently when following WP short URLs from Twitter, as well as from the RSS feed within Google Reader. When I manually type the main domain into the address bar, I get the same message. If I click on the "Back" link next to the invalid code message, same thing. No way to navigate to the site at all.

    Not sure if that extra info is helpful. I can try clearing my cache but given the sheer volume of sites I then have to re-log into, t is quite the drag...and it really shouldn't be necessary.

  18. sharanam, by any chance, are you using Hughes as your ISP?

    Hughes has a feature called "Turbo Page" which retrieves a cached page when enabled, saves them bandwidth, and doesn't work with mapped domains due to a misconfiguration on their end.

    I recommend calling the Hughes support center and asking to have the Turbo Page feature disabled on your account. That should solve the problem.

  19. Good diagnosis macmanx. Yes, Hughes is my ISP (the unfortunate reality of living in the middle of nowhere), and I just asked them to disable the Turbo Page. I tested one of the links I was having problems with from Twitter and the page loaded just fine. Thanks much!

  20. @michaelepicray
    Your shouting at me the hallmark of a blogger who refuses to remain solution focused. Have you used this link to see if your Flash is up to date? If it’s not up to date then this is where to download and install the latest version of Flash.

  21. :Logically there is nothing that WordPress can do to take account for ISPs which cache tokens and remain secure. These tokens have to be time sensitive, if you allowed the ISPs store and reuse a token you would also be allowing anyone sniffing your local network or working in a network centre anywhere between you and the WordPress server.

    mdawaffe is absolutely correct when he says the only thing that WordPress can do is change the symptoms. That will be a big improvement though, if your ISP incorrectly reuses tokens you will be able to log in via your dashboard as usual but when you view a domain-mapped site you will see it as you do when logged out, without the WodPress toolbar at the top.

  22. I've been having this problem (esp trying to read and just read through several threads including this one, which was the most helpful. Yes, hughesnet is my ISP. And yes, if I log out of wordpress I have no problems.

    So as I understand it my choices are to turn off the "turbo" feature, or do a lot of logging in and out. I don't post blog entries or comments THAT often, maybe 2 or 3 times a week, so I'm torn at this point. I wonder if any HughesNet customers could tell me if they noticed any significant slowdown in browsing after turning off the "turbo" feature. I do a LOT of casual surfing and would choose the latter option if it meant faster browsing.

  23. I started a WordPress blog end of November and started getting the Invaled key 6 page when attempting to access WUWT site. But not always. everything else seems to work. I run an XP with Modzilla through HughesNet.This is not the first time that the HughesNet system has caused me problems. I will try the Disable Turbo fix. pg

Topic Closed

This topic has been closed to new replies.

About this Topic