Domain Mapping Goes Into Infinite Loop

  • Author
  • #639726


    I just purchased and set up domain mapping for my wordpress blog ( so that I can see it under a domain I already own ( I had previously set up my domain (purchased through NetFirms) to redirect traffic to, but I decided I’d rather have my wordpress blog’s address appear as instead of

    After updating the nameservers on NetFirms and waiting until WordPress saw the change, I added the domain to my WordPress blog. When I set as my primary domain and try to browse to either or, however, my browser goes into an infinite loop between the two addresses (with nothing being loaded). If I set to be my primary domain, then everything works fine (except for the fact that my redirects to instead of vice versa, which is what I want).

    While the infinite loop is going on, the address bar shows:

    and this is the page source that appears is:

    <HTML> <HEAD><META HTTP-EQUIV=Refresh CONTENT=”0; url=”> </HEAD> </HTML>
    Blog url:



    Hmmm… After some more testing, it appears as though Netfirms is still in control of directing where goes to. I tried changing the address that points to under the Netfirms control panel and that seems to be the end result.

    That is, with WordPress domain mapping: redirects to, and then redirects to whatever I enter under the Netfirms control panel. I was under the impression that, with Domain Mapping, WordPress would have final control over where would end up pointing because of the name server changes.



    Actually, you just need to set the domain as your primary via Upgrades -> Domains in your blog’s Dashboard. Then, everything should work properly.



    As stated in my opening post, that’s exactly what I did, but it didn’t work, and it prompted this very Support question. I’ve just changed it back for the time being so I can actually see my blog and work on stuff.


    When is set to primary and I try viewing it works for me without any trouble. I tested with Chrome, Firefox, and Safari on a Mac. It sounds to me like something at the browser or network level is stuck for you. Could you please try clearing your browser cache as a first step? If that doesn’t help, is it possible for you to turn your modem completely off and then back on again? If you’re still having trouble after that, could you let us know if you’re using a Mac or a PC and what browser and browser version you are using?



    I tried on a completely different computer (my PC at home) and different ISP with both Internet Explorer 8 and Firefox 4 and they both resolve to the redirect address I entered in NetFirms (which I changed to redirects to which then redirects to the address I entered in NetFirms.

    If I change the redirect address in NetFirms, both and eventually resolve to it. I tried it just now and it worked instantly.

    Trying it all again after clearing my browser cache made no difference.

    I have now left as the primary domain under WordPress and have left as the redirect for under NetFirms (which shouldn’t have control over the domain redirect now, right?). Could you try the address again and verify that it is loading up my blog and not google?


    I’m not sure exactly what option you are updating at NetFirms, but as long as the name servers are pointed to NS1.WORDPRESS.COM, NS2.WORDPRESS.COM, and NS3.WORDPRESS.COM and you have applied the domain mapping upgrade in your blog dashboard, then the traffic should be controlled by servers and it should route properly. (And it’s correct that settings changes other than name servers made at NetFirms should no longer have an effect.) If you changed the name servers back and forth, it’s possible you’re causing some delays. You should make sure to set the name servers to NS1.WORDPRESS.COM, NS2.WORDPRESS.COM, and NS3.WORDPRESS.COM and leave them. Note that it can take up to a few days for DNS updates to fully propagate throughout the internet. How long it takes depends on how often your ISP updates against the master DNS databases. It varies by location, and that’s one reason that some people can see an update right after a change is made and others cannot.

    I checked again and it is working fine for me right now.

    It sounds to me like you just haven’t waited long enough for the settings to propagate. What is the date/time of the last time you made any changes to the DNS settings for your domain? You should wait a at least a day or so from that point and then try checking it again.



    These are the settings that I have:

    Netfirms nameserver settings
    Netfirms domain forwarding setting
    WordPress domain mapping settings

    I did not change the nameservers again after setting them to the wordpress ones earlier today (around 1:00pm CST).

    You’re probably right about the propagation thing. I’ll wait a day or so and see what happens.


    Sounds good. Let us know if it doesn’t sort out on its own in the next day or so.



    I visited this morning and it is now correctly loading up my site. Looks like everything is OK!



The topic ‘Domain Mapping Goes Into Infinite Loop’ is closed to new replies.