Need help? Check out our Support site, then

Dragging widgets to sidebar fails

  1. Attempting to drag widgets in usually simply selects text. Sometimes, if I fiddle with it, I can get the widget to look like it is dragging, but it won't "drop". Also, the page won't scroll up when I take the Text widget, which is what I want to add to my sidebar, and hold it against the top of the page.

    The problem occurs in both Chrome and Firefox on Linux Mint Mate Maya.

    Most of the help I have turned up for the problem of widgets failing to drag to the sidebar suggests "turning off the plugins" but my blog doesn't have any plugins, so far as I can tell.

    Suggestions appreciated, thank you.

    The blog I need help with is

  2. Bump.

  3. If you have already checked there are no plugins enabled you can follow these steps to check if it is a javascript issue :

    Other options would be to check there are no updates outstanding for WordPress or your theme, and to try a different theme and see if you still have the same problem.

    Let me know how you get on.

  4. @motivatedtribe
    Hello! WordPress>ORG support is here > and the codex does not apply to free hosted WordPress>COM blogs.

  5. @tarverator

    If you are not running one of the browsers and versions listed at please try upgrading or switching first.

    Note: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see >

    If you are running one of the browsers and versions listed at please do these four things:

    1. Try clearing your browser’s cache:

    2. Make sure that you have third-party cookies enabled:

    3. Try with all browser extensions or add-ons temporarily disabled.

    4. Try enabling HTTPS:

    If it’s still happening, let us know exactly which browser (and version of it) you’re using by checking here if necessary and also post any error reports you get.

  6. It does not work in either Firefox 20 or Chrome 26 after clearing the cache, enabling third-party cookies, disabling extensions, and enabling HTTPS.

  7. Thanks for responding. Are you using no script of some other browser adds on? If so disable them please.

  8. I also tried logging into Windows and using both IE10 and Chrome, and it doesn't work in either of those either.

    What script could possibly be common to four browsers across two OSes that I have failed to turn off, that is preventing this from working?

  9. I tagged this thread for a Staff follow-up. Please subscribe to it so you are notified when they respond.

  10. Hi @tarverator,

    I took a look at your site's Dashboard and I wasn't able to replicate any issues with dragging and dropping widgets in to your sidebar. I took the liberty of adding the Text widget for you since you mentioned that you were specifically wanting to add that one to your sidebar.

    I did want to mention that if you are having issues with holding the widget against the top of the screen and it not scrolling up, you might want to grab the widget and then scrolling up with your mouse wheel. It's a trick I use when I'm in a hurry!

  11. Thanks, I see the text widget there but I am unable to access it to add the text! (I have HTML code for a PayPal "Donate" button that I want to paste in.) Even if that worked, I would like to fix the underlying problem. I also have support topics open for the insert/edit link not working in the rich text editor, and for the homepage appearing empty as soon as I log in. Maybe these problems are all related?

    I will try downloading Opera, a completely different browser than I have tried previously, and see if any of these things work there.

  12. I tried a completely clean install of Opera, which has never been on this machine before. Only ever went to one website, and tied to manipulate widgets in

    Same problem: Widgets don't drag, and ones already in the sidebar don't "open" for maintenance.

  13. Hey there,

    Looking through the other threads which you have open, it's sounding like nothing is really working on for you.

    A very good portion of our site relies on Javascript in order to function correctly. If you have Javascript turned off or if you have some sort of JS-limiting application in place (whether anti-virus or a browser extension), then it would explain why all of the specific items which you mentioned would fail to work.

    I would recommend that you check your system to ensure that Javascript is enabled and allowed for

  14. Thanks, but JavaScript is definitely on. Please look at the other two threads I have open, to see the full extent of the problem.

    Something seems to go wrong as soon as I log into wordpress, regardless of browser or platform. What could be wrong with my account? Is it something that I have control over? It does not help that all I see on!/settings/account/ when I am logged in is the blue banner and an otherwise blank white screen.

  15. Hi @tarverator,

    It was the other two threads that lead me to believe that there was a global setting on you machine, such as JS being disabled or restricted for

    There is not anything wrong with your account. We've tested it on a user level and have not been able to replicate any of the issues which you have been describing.

    At this point I would recommend trying a completely different computer or a different network or both. Make sure that you are not behind any firewalls, as that can also prevent certain types of scripts and content from loading.

  16. I tried it on my partner's Mac (different machine), at her house (different network) with Safari (different browser), and all three things worked ( page visible, dragging widgets, insert/edit link).

    So how do I figure out what is keeping my machine/network/browser from working? I can boot my laptop into Windows, and I have another old Linux laptop. I can go to the Library and try a different network. I have several browsers. I will experiment with different combinations to see if something works, and I am open to further suggestions also. Thanks.

  17. I have reproduced the problem on a completely different computer running a simlilar installation of Linux Mint on the same network as I usually use, which is Fido over my tethered phone. So, I reason, the culprit is either Fido or Linux Mint but not the hardware. Previously, the problem had shown up on the same hardware running Windows (in two different browsers) but that was all over the same network. This points to the network. I will try a different network later. In the meantime, is there a quick way to scan a network for firewalls or other blockages? Has anyone else had trouble with Fido tripping up WordPress? I don't experience any other problems that I'm aware of.

  18. Heya!

    I believe that you may have found the culprit. We provide a smartphone app which works great for most things that you might need to do for your site, however the unreliability of mobile-phone tethering may cause issues, not just with our site but with any number of other sites across the internet.

  19. I can't get wise how to get photo and text in widget side bar.
    I follow your instruction, it doent work, nothing on side bar.

  20. Hi @persijs,

    Your issue may very well be caused by a different issue, as this one appears to be unique. Could you please start a new thread and we can address it there?

    Thank you!

  21. I am at the Public Library, and guess what? Everything works fine. I don't know whether to laugh or cry. I have blown hours and hours on this. Ooooooooo.... that Fido!!!

    Thanks everyone for your help at this end.

  22. Heya @tarverator,

    I can't tell you how thrilled I am that we figured it out! Thanks for giving us a heads up about it.

  23. You are welcome. The conversation continues here: ...I hope. :)

  24. I was waiting for an answer, how to insert photo and text to side widget not, your futile talking. If you can't manage it, ask advise to your staff.

  25. @persijs: Please stop posting again and again on the same issue. I gave you a preliminary reply more than a week ago on the first thread you started, but you failed to respond. You posted again on a different thread, we directed you to your original thread, again you failed to respond. If you return to your original thread I can tell you what to do:

Topic Closed

This topic has been closed to new replies.

About this Topic