Dragging widgets to sidebar fails

  • Author
    Posts
  • #1238079

    tarverator
    Member

    Attempting to drag widgets in http://tarverator.wordpress.com/wp-admin/widgets.php#available-widgets usually simply selects text. Sometimes, if I fiddle with it, I can get the widget to look like it is dragging, but it won’t “drop”. Also, the page won’t scroll up when I take the Text widget, which is what I want to add to my sidebar, and hold it against the top of the page.

    The problem occurs in both Chrome and Firefox on Linux Mint Mate Maya.

    Most of the help I have turned up for the problem of widgets failing to drag to the sidebar suggests “turning off the plugins” but my wordpress.com blog doesn’t have any plugins, so far as I can tell.

    Suggestions appreciated, thank you.

    The blog I need help with is tarverator.wordpress.com.

    #1238369

    tarverator
    Member

    Bump.

    #1238371

    If you have already checked there are no plugins enabled you can follow these steps to check if it is a javascript issue :

    http://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors#Step_3:_Diagnosis

    Other options would be to check there are no updates outstanding for WordPress or your theme, and to try a different theme and see if you still have the same problem.

    Let me know how you get on.

    #1238374

    timethief
    Member

    @motivatedtribe
    Hello! WordPress>ORG support is here > http://wordpress.org/suupport and the codex does not apply to free hosted WordPress>COM blogs.

    #1238375

    timethief
    Member

    @tarverator

    If you are not running one of the browsers and versions listed at http://browsehappy.com/ please try upgrading or switching first.

    Note: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see > http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

    If you are running one of the browsers and versions listed at http://browsehappy.com please do these four things:

    1. Try clearing your browser’s cache:

    http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=32050

    2. Make sure that you have third-party cookies enabled: http://en.support.wordpress.com/third-party-cookies/

    3. Try with all browser extensions or add-ons temporarily disabled.

    4. Try enabling HTTPS: http://en.support.wordpress.com/https/

    If it’s still happening, let us know exactly which browser (and version of it) you’re using by checking here if necessary http://www.whatbrowser.org/ and also post any error reports you get.

    #1238377

    tarverator
    Member

    It does not work in either Firefox 20 or Chrome 26 after clearing the cache, enabling third-party cookies, disabling extensions, and enabling HTTPS.

    #1238378

    timethief
    Member

    Thanks for responding. Are you using no script of some other browser adds on? If so disable them please.

    #1238379

    tarverator
    Member

    I also tried logging into Windows and using both IE10 and Chrome, and it doesn’t work in either of those either.

    What script could possibly be common to four browsers across two OSes that I have failed to turn off, that is preventing this from working?

    #1238380

    timethief
    Member

    I tagged this thread for a Staff follow-up. Please subscribe to it so you are notified when they respond.

    #1238383

    amightywp
    Member

    Hi @tarverator,

    I took a look at your site’s Dashboard and I wasn’t able to replicate any issues with dragging and dropping widgets in to your sidebar. I took the liberty of adding the Text widget for you since you mentioned that you were specifically wanting to add that one to your sidebar.

    I did want to mention that if you are having issues with holding the widget against the top of the screen and it not scrolling up, you might want to grab the widget and then scrolling up with your mouse wheel. It’s a trick I use when I’m in a hurry!

    #1238384

    tarverator
    Member

    Thanks, I see the text widget there but I am unable to access it to add the text! (I have HTML code for a PayPal “Donate” button that I want to paste in.) Even if that worked, I would like to fix the underlying problem. I also have support topics open for the insert/edit link not working in the rich text editor, and for the wordpress.com homepage appearing empty as soon as I log in. Maybe these problems are all related?

    I will try downloading Opera, a completely different browser than I have tried previously, and see if any of these things work there.

    #1238385

    tarverator
    Member

    I tried a completely clean install of Opera, which has never been on this machine before. Only ever went to one website, http://tarverator.wordpress.com/wp-admin/ and tied to manipulate widgets in https://tarverator.wordpress.com/wp-admin/widgets.php#available-widgets

    Same problem: Widgets don’t drag, and ones already in the sidebar don’t “open” for maintenance.

    #1238387

    amightywp
    Member

    Hey there,

    Looking through the other threads which you have open, it’s sounding like nothing is really working on WordPress.com for you.

    A very good portion of our site relies on Javascript in order to function correctly. If you have Javascript turned off or if you have some sort of JS-limiting application in place (whether anti-virus or a browser extension), then it would explain why all of the specific items which you mentioned would fail to work.

    I would recommend that you check your system to ensure that Javascript is enabled and allowed for WordPress.com.

    #1238389

    tarverator
    Member

    Thanks, but JavaScript is definitely on. Please look at the other two threads I have open, to see the full extent of the problem.

    Something seems to go wrong as soon as I log into wordpress, regardless of browser or platform. What could be wrong with my account? Is it something that I have control over? It does not help that all I see on https://wordpress.com/#!/settings/account/ when I am logged in is the blue banner and an otherwise blank white screen.

    #1238390

    amightywp
    Member

    Hi @tarverator,

    It was the other two threads that lead me to believe that there was a global setting on you machine, such as JS being disabled or restricted for WordPress.com.

    There is not anything wrong with your account. We’ve tested it on a user level and have not been able to replicate any of the issues which you have been describing.

    At this point I would recommend trying a completely different computer or a different network or both. Make sure that you are not behind any firewalls, as that can also prevent certain types of scripts and content from loading.

    #1238392

    tarverator
    Member

    I tried it on my partner’s Mac (different machine), at her house (different network) with Safari (different browser), and all three things worked (wordpress.com page visible, dragging widgets, insert/edit link).

    So how do I figure out what is keeping my machine/network/browser from working? I can boot my laptop into Windows, and I have another old Linux laptop. I can go to the Library and try a different network. I have several browsers. I will experiment with different combinations to see if something works, and I am open to further suggestions also. Thanks.

    #1238393

    tarverator
    Member

    I have reproduced the problem on a completely different computer running a simlilar installation of Linux Mint on the same network as I usually use, which is Fido over my tethered phone. So, I reason, the culprit is either Fido or Linux Mint but not the hardware. Previously, the problem had shown up on the same hardware running Windows (in two different browsers) but that was all over the same network. This points to the network. I will try a different network later. In the meantime, is there a quick way to scan a network for firewalls or other blockages? Has anyone else had trouble with Fido tripping up WordPress? I don’t experience any other problems that I’m aware of.

    #1238394

    amightywp
    Member

    Heya!

    I believe that you may have found the culprit. We provide a smartphone app which works great for most things that you might need to do for your site, however the unreliability of mobile-phone tethering may cause issues, not just with our site but with any number of other sites across the internet.

    #1238395

    persijs
    Member

    I can’t get wise how to get photo and text in widget side bar.
    I follow your instruction, it doent work, nothing on side bar.
    http://www.persijs.wordpress.com

    #1238396

    amightywp
    Member

    Hi @persijs,

    Your issue may very well be caused by a different issue, as this one appears to be unique. Could you please start a new thread and we can address it there?

    Thank you!

The topic ‘Dragging widgets to sidebar fails’ is closed to new replies.