Editor Continues to Struggle with HTML Listings

  • Author
    Posts
  • #2471837

    So a few months ago, I noted a bug with the way the new “Beep Beep Boop” editor handles the HTML code listings on my site:

    https://en.forums.wordpress.com/topic/new-editor-has-trouble-handling-html-code-listings?replies=5#post-2365038

    More recently I have experienced similar but slightly different parsing errors. This time it’s happening whether I use the “new” editor or the “old” one, though I’m not sure whether that’s because the old one’s been completely supplanted at this point.

    Basically, my site is all listings of JavaScript programs that are meant to be run in a web browser. The JavaScript itself is enclosed in HTML’s “html”, “body”, and “script” tags, and I sometimes also build my programs’ UI using other HTML tags.

    Once upon a time, I would publish my code by escaping the “&”, “<” and “>” characters in my HTML file (with the “amp”, “lt” and “gt” sequences) and copying the escaped text into a “pre” element in my post.

    This approach no longer works. When I try to do things that way, everything after the first “<” in my code listing disappears into the ether.

    As a workaround, I have been replacing “<” and “>” with “[[” and “]]”, along with a note that the reader will have to substitute the proper characters manually. That’s kind of a huge bummer for everyone involved, though.

    For an example, see my most recent post:

    https://thiscouldbebetter.wordpress.com/2015/09/25/generating-a-voronoi-tessellation-in-javascript/

    Can someone at WordPress please take a look at this? Thanks.

    The blog I need help with is thiscouldbebetter.wordpress.com.

    #2472128

    I hate to be a pain, but it’s been a while since I logged this error, and no response so far. Is there any way to know if this bug is a candidate to be fixed? Is there a publicly accessible bug tracker somewhere?

    #2472129

    timethief
    Member

    When we need Staff help with issues Volunteers cannot resolve we type modlook into the sidebar tags on our forum threads like this one. How do I get a Moderator/Staff reply for my question? https://en.support.wordpress.com/getting-help-in-the-forums/#how-do-i-get-a-moderatorstaff-reply-for-my-question Then please subscribe to this thread so you are notified when they respond. To subscribe look in the sidebar of this thread, find the subscribe to topics link and click it.

    #2472131

    Thank you, timethief.

    #2472132

    supernovia
    Staff

    Actually, for security reasons, we don’t allow execution of JavaScript at WordPress.com. You’re welcome to continue posting source code, though. More info here:
    https://en.support.wordpress.com/code/

    #2472140

    we don’t allow execution of JavaScript at WordPress.com

    Understood. That’s the way it’s been since forever, or at least since 2011.

    The problem I’m reporting is different, and just started happening relatively recently. It’s the text representation of the code listing that’s not rendering correctly. Old posts still show up correctly, but I can’t edit them or the editor mangles them on save.

    I’m pretty sure that this is a bug, not a security feature–in fact, it seems likely that it may actually be a security vulnerability. I’d just like to know that it’s bring looked at.

    I’ll try the latest workarounds described at the page you linked, but I’m a little pessimistic.

    #2472143

    supernovia
    Staff

    Oh I see. What if you just use the [code] shortcode?
    https://en.support.wordpress.com/code/posting-source-code/

    #2472147

    supernovia
    Staff

    We’re getting some spam on this post, so I’ll go ahead and close it out. But I do think using the code shortcode will help a bunch. Cheers!

The topic ‘Editor Continues to Struggle with HTML Listings’ is closed to new replies.