Editor stopped working?

  • Author
    Posts
  • #155273

    jamesewelch
    Member

    It worked for me after the first fix (posted by previous WP staff member) and it appears to work for me now, too.

    #155274

    tellyworth
    Staff

    Is anyone still experiencing the problem? If so, please follow my advice above.

    #155275

    I wonder if everyone experiencing the problem went to bed?

    #155276

    raincoaster
    Member

    I just scrolled through the comments: can anyone confirm that my workaround actually works for this problem? ie you highlight the entire post, copy it, and then, while it is still highlighted, you click Publish.

    It has worked in the past. I’ve seen it suggested many times in this thread, but if someone came back and said “yes, it worked” or “no, it didn’t” I cannot find it.

    #155278

    I just tried that with my “lupins” post but it doesn’t seem to have worked. :(

    #155279

    Quickly check your blog’s RSS feed to see if it’s been picked up. Or if you were editing an older post, Google that exact link and check the cache. Or right click your mouse and go back until you can get to the exact place you were before.

    #155280

    raincoaster
    Member

    Archie, thanks for the update. Damn! It worked so well for so long…and the error is still happening.

    I thought there was something weird about ten hours ago; I was teaching someone how to change the admin email on her blog and no matter what we did, it wouldn’t save. Wouldn’t save the widget changes either. Nothing saved except changing the nickname. That’s when I knew something was up, but I didn’t know what. A quick forum search showed nothing at that time. Sorry, I should have posted a heads-up, just in case warning.

    #155281

    tellyworth
    Staff

    Once again: if anyone is still experiencing the problem, please follow the advice in my post above:

    https://en.forums.wordpress.com/topic.php?id=16996&page=4&replies=127#post-127238

    We cannot help without a clear description of the problem – which, so far, we do not have.

    #155283

    sharonb
    Member

    I am currently experiencing an interesting problem.

    I have a post in draft it consists of some text and an image are already inserted in it.
    I went to the insert/edit image dialogue box set the alignment(to the left) and vertical and horizontal space and selected update.
    The image would not display in my edit box formated in the update way.

    Then I realised that I could not switch from visual view to code view. It id displaying as visual but my tab says I am in code view in other words I can see no code. It is most curious.

    I can not save any more text either in this post yet just created another post and saved that OK

    The image is housed at Picasa but that should not make any difference

    I have a copy of the post in a text file so I am not worried about losing as such just think it is related to the above issues.

    I am Firefox 2.0.0.7 on using a MacBook with MacOX 10.4
    I have cleared my cache, and done a full restart but the problem persists

    #155284

    @ tellyworth, caches and RSS feeds may be a geeks best friend but I am just a dabbler who uses easy stuff like WordPress. I have other work-arounds which I have tried. It seems to be an image problem. I uploaded an image, added some text ABOVE it and posted. The first time The whole post simply disappeared as if I had never posted it. The next time, I did the same and this time the post was recognised but there was nothing in it (other than the title, the header and the footer). OK. I thought. I posted another version of the same post, with a different title. Same result. Next I deleted the image and uploaded it again. same result. I tried another image, different title. same same! grrr – next I posted an all text post under the same title – this worked. I left it for several hours then tried again. At the top of the post I added extra text followed by the image and left the original text as was at the bottom. Didn’t work – the text at the bottom stayed and nothing else appeared. Next I deleted the image and added another image (well, the same image, renamed) and tried again – still no change. One thing I have noticed is that I had reached around 50% of my 50Mb storage quota but this morning it is showing 32% usage. I have just looked at my RSS feed (duh, I should have realised what that is.) and it shows no change from the all text version. Ok, I am experimenting with social network buttons (thanks, Rain for your comments several months ago on another thread) and uploaded about a dozen little gif and png images this morning and on a subsequent, all text post – these worked and appeared – I tried them with the the problem post and they worked there as well. Retried with a jpg image and it still failed! So now I am confused – I hope I haven’t confused you. I can copy and paste this to support if you think I should.

    #155289

    withmalice
    Member

    Currently for me, any time I try to put pictures in a post, they will save to post – but when I hit publish, within the published piece: no pictures.
    Cannot get any pictures to load at all. Have tried different sources, even pictures that have been published within my blog before, no dice.

    #155298

    I still can’t edit–ANYTHING! I don’t know enough about computers to try anything else. ALl I know is that since about 7pm (CST) Thursday,. I’ve NOT been able to edit old posts or add new ones.

    I’ve tried saving things in “save and continue editing” and in “Save” all by itself and nothing is saved in either.

    Please–somebody—what’s going on???? Couldn’t WordPress include a note-an explanation–SOMETHING on the main page to explain what’s going on????

    This has been a problem now fore 12 hours!. An explanation…PLEASE!!!!!

    LK

    #155300

    worththetrip
    Member

    I reported this problem last night (post disappeared after I clicked save) and have followed all the helpful suggestions. There was about a five minute window last night when the editor seemed to be working again, and I was able to cut and paste the post I had worked on as a word document, and even was able to add two pictures. But I wanted to do a little tweaking to the text, and that’s when the editor stopped working again.

    I’ve tried this both in Firefox and IE, and the problem is the same. Here’s what happens:

    1) When I edit in visual mode, everything looks like it’s working as it usually does, but when I click Save, none of the edits stick.

    2) If I click on the code tab, nothing happens. The text still comes up in the visual mode, even though it’s toggled over to code. I can’t get the page to come up in HTML, although whenever I am first bringing up the draft, it flashes for a second or two in HTML.

    I’ve gotten to a point now where I can tell if the problem is still with us just by clicking on the code tab. If my draft still comes up in visual mode once I’ve hit code, then I know it’s pointless to try editing. I don’t know if this info will help but once you hit the “code” tab, the “visual” tab no longer works, so you can’t toggle back and forth.

    #155301

    standing8
    Member

    Having this problem as well. Tried editing several times, saving and continuing as well as simply saving and nothing. My text disappears completely. The funny thing is in my Dashboard, it shows that I edited the posts I wanted to but none with no actual changes. I’ll look into that workaround.

    #155302

    nelas
    Member

    I’m having the same issue (code editor not showing and posts not getting saved – tested in firefox and opera, after clearing chage and full restart). After opening a draft and clicking in the tab “code” Firebug extension from Firefox shows up an error, pointed below. Hope this might help.

    this._parseAttributes is not a function
    cleanup(“get_from_editor”, “<p>The following lines are based on scattered data, flawed statistics and biased ideas. The author h…”)tiny_mce_gzip.php (line 2774)
    cleanup(“get_from_editor”, “<p>The following lines are based on scattered data, flawed statistics and biased ideas. The author h…”, Object undoRedoLevel=true isTinyMCE_Control=true)sourcecode-mce.js (line 55)
    _customCleanup(Object undoRedoLevel=true isTinyMCE_Control=true, “get_from_editor”, “<p>The following lines are based on scattered data, flawed statistics and biased ideas. The author h…”)tiny_mce_gzip.php (line 70)
    _cleanupHTML(Object undoRedoLevel=true isTinyMCE_Control=true, Document post.php, Object mode=specific_textareas editor_selector=mceEditor, body.mceContentBody, undefined, true, true, undefined)tiny_mce_gzip.php (line 208)
    triggerSave(false, false)tiny_mce_gzip.php (line 191)
    switchEditors(“content”)tiny_mce_gzip.php (line 3077)
    onclick(click clientX=0, clientY=0)post.php (line 1)
    [Break on this error] var attribs = this._parseAttributes(content.substring(startPos + 4, endPos)…

    #155303

    thrillskilla
    Member

    I have the same problem too! :-(

    http://thexboxdomain.net/

    #155305

    astralyz
    Member

    I got same problem with WORTHTHETRIP..

    1)I can’t edit my post as once I click save, nothing happens.
    2)Also when I click edit on my post, it comes out in visual mode only, I can’t go to the code mode. Once I click code tab, nothing happens, it is still displayed visual mode.

    I tried both in Mozilla Firefox and IE but don’t work as well.
    On IE, I got error message.

    So,does the website got problem?

    #155308

    pjwalker911
    Member

    What is the problem with understanding the problem? The f@%@^** editor does not work! For anybody. Period.

    I don’t see what this would have to do with browsers. Clearing cache does not work. This is a WP system bug and only they can fix it. So this could go on for a long while…..

    #155309

    I’m having a similar problem: I published a post, but then when I used the “Edit” function to add a “More” tag, the change didn’t appear after I hit “save.” (I tried this several times, in both Safari and IE.)

    I’m using the Tarski theme, and the post in question is here:
    http://thepumphandle.wordpress.com/2007/10/19/are-osha-stats-really-good-news/

    #155310

    sassifer
    Member

    Thepumphandle – I’m having the exact same problem. I can’t insert my “more” tags. This is incredibly frustrating. And I too am having the “View Code” problem as well…

    I agree, this isn’t a browser problem. This is WP through and through..

    First my account is mysteriously suspended, then my post is entirely lost.. and now I can’t even edit things properly. All in the span of one month!

    Hmm..

The topic ‘Editor stopped working?’ is closed to new replies.