Need help? Check out our Support site, then

Editor-visual icons disappeared, blank text box

  1. I've read all I can about this problem, reset browsers several times, tried 2 browsers, 2 computers, admin via https, etc - no result. Theme Kubrick (changed that also, then reverted). In Kubrick, can't find Settings option to disable visual editor in order to uncheck it. OSX.10.7.4, Safari 6.0, Firefox 12. Any new ideas, please?
    Blog url:

  2. Hey there,

    You should be able to switch between the Visual and Text (HTML) editors through the tab on the top of the edit box.

    If the visual editor is missing, try following these steps to resolve the problem. If that doesn't work, let me know, and we'll try a few other steps.


  3. Hello, P!
    Thanks for advice. Had already tried the steps you recommended, several times. Have just run the range of checks again - no joy! For now, I can publish only by using 'New Post' (menu bar, rt-hand side). I see Visual icons here. If I have a typo, or bad formatting, I have to C&P the text off the published page, make corrections, re-publish (while trashing the previous version).
    I then add Categories via Edit Post and Update. I still see no visual icons in the main edit box. Choose 'Text' tab, it (the word) turns red but nothing happens. Choose 'Visual' and there's nothing - no icons, no text.
    If I choose 'Edit' a post, it's the same. The text is in the box, invisible - I can see a word count, and I can fully edit/add Categories and Tags before updating successfully
    (I've also changed Theme several times, then reverted to Kubrick. Have ticked and unticked 'https'. option. No joy. I'm baffled!

  4. Dear WordPress Support,

    I’m really stuck, since several days and many hours of trying to solve my multiple problems. All this, despite posting a new thread on the Forum and receiving an online suggestion from your support colleague, pcrumm.

    System: MacBook Pro; OSX 10.7.4. Preferred browsers: Safari 6.0, Firefox 14.0.1. No WordPress problems when I recently (2 months ago) upgraded to present OS system/version. I’m not into CSS (but could be), and have basic HTML knowledge.

    I have exhaustively followed all your relevant Help/Support pages, plus the forums, and still cannot resolve my problems.

    The principal one is to do with Add New/Edit [item]. There are some peripheral annoyances, also.
    1: Add New/Edit: I see no visual icons. Click ‘Visual’ and the text pane collapses. Click ‘HTML’, the letters turn red, but nothing else happens.
    2: I therefore try to post using the pull-down ‘New Post’ (rt-hand side of menu bar). This shows 1 line of visual icons, and I can C&P pre-composed and formatted text (from TextEdit in any format), add a photo and caption (full control of Image options). I can add Tags, but not Categories. I can publish (except when I often receive an ‘Invalid action/request’ message, in which case [a] nothing gets published or [b] I can find the item sitting in ‘All Posts’, i.e., it’s successfully published (erratic, in other words).
    3: If I publish successfully as in step 2 above, by going to the Dashboard/Edit Post’ option, I still see no visual icons, I still cannot choose ‘Visual/HTML’ with any result, the text pane remains blank, but the Word Count registers correctly. And I can’t edit any image. I can, however, check Categories and revise Tags, and then Update from that window.
    4: As mentioned, I have tried ALL your suggested remedies - browser caches, etc, https toggled on and off, changing themes, working on different computers and browsers - nothing seems to identify or isolate the problems.
    5: I also now understand the crucial differences in what can be done on a account, rather than on
    6: The same situation applies to my other WP sites, with different Themes (one is Hidden in preparation for publishing, one other is experimental only, and I’ve tried adding yet another site - they all show up with the same, consistent (non)-results - which points to the problem being here, at my end, I assume.

    All this is driving me crackers, by now! I just hope that you can suggest some way to solve this nest of problems. I’m happy to say that I never experienced any problems at all until now, having started out about 18 months ago - something that adds to my sudden bewilderment, as you’ll appreciate.
    Best, philinsofia.

    Mnay thanks.

    Yours faithfully,
    WP blog:

  5. Hi there,
    I have flagged this thread for Staff attention.

  6. time thief,
    many thanks for a fast reaction - very grateful!

  7. First, please try disabling all browser add-ons or extensions. Some, especially ad blockers, can disabling the Visual Editor.

    If that doesn't help, try going directly to Posts -> Add New in your blog's Dashboard.

  8. macmanx,
    thanks for suggestions above. Followed these on Safari & Firefox, disabled AdBlock, etc, reset/cleared caches, quit browsers, restarted computer. No difference in WP, I'm sorry to say.
    Re Dashboard/Posts/Add New or Edit: that was my preferred way to add/edit. That's where, initially, I found the blank edit box and no vis-icons, which is still the case. Using the New Post was/is merely a less convenient workaround.

  9. Are you using the https version instead of the http version of your site? A lot of people with different problems find that this solves them.

  10. raincoaster,
    I have tried both. Checked just now, am not on https. Will change the setting in a moment, and see whether anything happens - fingers crossed!

  11. Also, if you're using IE in Compatibility mode, that screws things up.

  12. rain coaster,
    thanks again. No, not on IE (!) - Safari & Firefox (both latest versions, on Mac OSX10.7.4. And, to confirm, recent updates to OS and browsers didn't cause any problems. They 'magically' appeared, well after any updating.
    Tried https on both browsers. Slower (as per WP support warning), but otherwise no change. Will set up third browser, Chrome, and try out.

  13. Sorry about that, there was definitely a problem on our end. You're all fixed up now!

  14. I've just read your message, macmanx,

    Hey ho! I had a quick look at Dashboard/Next Post, and it seems my beloved vis-icons are all back there! I'll try a post soon, full of confidence.
    Hey, guys (all of you), many, many thanks! I was in despair.
    Now, i'll submit the world to my views again, thanks to whatever you did.
    Super, Phil.
    (PS: Will let you know how I get on, thanks.)

  15. I've now tried an experimental post, using Dashboard/Posts/New, I added an image and some text successfully, with Visual Icons appearing; all absolutely fine - until I try to Publish! Nothing! I can do a Preview, but no more (i.e., can't Publish).
    I'm really close, thanks to your help, but…

  16. Do you see any errors when you publish? If so, would you please quote them.

    If not, what appears to be preventing you from publishing?

  17. hello macmanx,
    thanks for your latest. I had a new item, nothing special, prepared last evening, in order to check that the system was now up and running. I used my preferred method via Dashboard/Add New, and all was OK until I hit 'Publish'. Nothing happened, but the item was saved as a Draft in All Posts. So, I tried this again after reading your question - Dashboard/Edit Post, did no editing, just clicked on Publish. Again, nothing - no discernible activity. So, I have just composed a new item, a simple 'disregard this experiment' thingy, text plus headline, uncategorised. Go to Publish. Nothing. No activity, as with the previous item. So, two Drafts are now sitting there, and it seems I just cannot Publish. No error messages, no spinning balls (Mac), nowt!

  18. Ok, I see the problem, we're looking into this again. Sorry about that!

  19. macmanx,

    thanks for your patience and persistence - I'm extremely grateful.

  20. Am having another 'go' at publishing. No progress. To be more specific: in the Dashboard/Publish dialogue box, I can activate all the (Save Draft, Preview, Move to Trash) commands, except Publish. The 3 settings in that dialogue are also all OK.

  21. I'm sorry, we're still looking into this particular problem. We hope to have it solved soon.

  22. macmanx,

    Thanks! Tried again after reading your latest.
    Dashboard>Add New - still won't Publish (as before), appears as a Draft in All Posts.
    I CAN do the following: QuickPress>Publish, and New Post (menu bar)>Publish.
    Still on https, by the way.

  23. Sorry, we're still looking into it. For now, stick to the New Post tab until we can track down what's going on here.

  24. Ok, you're all fixed up now. Sorry for the delay!

  25. macmanx,

    Thank you very much indeed. I'll try it all out overnight, and hope to report tomorrow that this thread can be closed!
    Again, many thanks for all the trouble (and time) you've devoted to this.


  26. You're welcome!

  27. macmanx and colleagues,

    I have successfully published in 3 ways: via Dashboard/Add New; New Post; QuickPost.
    New Post is still a bit temperamental ('Invalid request' is frequent), but that is not really a problem, given that my preferred method via Dashboard seems to be fine now, for both a new post and for editing existing items.
    Given your advice about AdBlock, etc, I have set these NOT to operate when I'm on WordPress.
    Fingers crossed, I seem to be OK now. My thanks, yet again, for some real support and help.


  28. We're still working on the "Invalid request" issue. It's a bit difficult to track down as it seems to be random, but we'll have it figured out soon.

    Sorry about that, but glad to hear that everything else is working!

Topic Closed

This topic has been closed to new replies.

About this Topic