Email forwarding to Gmail not working

  • Author
    Posts
  • #1995585

    benfrankylin
    Member

    I have a domain name with WordPress. I only used 1 email forward so far and it’s not working.

    I created the email forward (email redacted) to be forwarded to (email redacted)

    I got the confirmation in Gmail. Clicked it. WordPress said my mail would now be forwarded there and it has been.

    I followed WordPress and Gmails instructions so that I can send emails back so that it shows from “(email redacted)” instead of my Gmail address.

    However, it’s not working.

    When I click “Add another address I own” in the Google settings, I fill in the name and email address, but then it says:
    SMTP server: smpt.website.com (Is this even correct? How do I find out???)
    username: (What username do I use? The one I use to sign into WordPress???)
    password: (Again, my WordPress password???)

    I tried entering my wordpress information and it didn’t work. I tried entering my Gmail info, didn’t work. Tried entering my forwarding email address info, didn’t work. I left it blank and it didn’t work.

    I’m at a loss.

    The blog I need help with is benfrankylin.wordpress.com.

    #1995670

    timethief
    Member

    I’ll tag this thread for a Staff follow-up. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

    #1995693

    benfrankylin
    Member

    Thank you!

    Because last time I did this, it didn’t ask me for a SMTP thing and it didn’t ask for a username or password.

    Now it’s asking and I have no idea what to enter.

    Thank you again.

    #1995876

    amightywp
    Member

    Hi there,

    As long as you have gone through the process of adding your domain as an alias to your gmail account (as detailed in Gmail’s help article here: https://support.google.com/mail/answer/22370?hl=en&ctx=mail) by going to their Gear icon >> Settings >> Accounts and adding your domain as a “Send email as”, then you should be able to either use the Gmail app on your iPhone or Android smartphone immediately.

    Alternatively, if you would like to set up your alias as a separate account, you should be able to follow these instructions:

    http://www.nathanpjones.com/wp/2014/01/using-gmail-aliases-in-ios-7/

    For setting your mail up in iOS7. Let me know if you need similar instructions in Android and which version you are running and I can see what I can find online!

    #1995892

    tlrr
    Member

    Gmail has recently changed the way it works and now will not allow you to send mail as if you have simply forwarded an email address to your gmail account :-(

    #1995895

    That is correct: as far as I can tell gmail now REQUIRES you to know the SMTP settings to set up a “send mail as” address. I have the same problem as benfrankylin: I checked with my domain that wordpress is handling the mail forwarding, but I do not know the exact SMTP address or username to use.

    #1995896

    timethief
    Member

    @tlrr
    Thanks for providing that relevant information. Is there a document stating that which you can link to here please?

    #1995897

    The gmail support doc: https://support.google.com/mail/answer/22370

    I have also tried to walk through the process with my gmail account – there appears to be no option which avoids needing to input SMTP settings.

    #1995898

    timethief
    Member

    @currentadventure
    Thank you so much for that link. I have tagged this thread for Staff attention. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

    #1995899

    macmanx
    Staff

    According to Google’s docs, it’s just a recommendation, not a requirement.

    What sort of trouble are you having exactly?

    #1995900

    I can’t provide the info gmail asks for to set up the “send as” address, so it will not add the forwarded address to my gmail account.

    SMTP is not described as optional in the link I posted. Those are the instructions I’m following (as a gmail user, not a “Google Apps for Business” user). Specifically, when I try to actually add the address, there is no “skip this step” option for SMTP (and leaving the SMTP information blank gives an error).

    What doc says it’s optional? (if it is a recent change, there could be an inconsistency there too)

    #1995901

    macmanx
    Staff

    From the document you linked to:

    We recommend that you configure your email client with two outgoing SMTP servers, one for Gmail and one for your other address. Or, you can use Gmail’s outbound servers with a different “from” address. If you’ve already configured the alternate address, your message will be sent from:(email redacted), sender:(email redacted), regardless of which custom from configuration you chose.

    WordPress.com does not offer email services, that includes SMTP. If you are just forwarding to your @gmail.com address, your email will have to be sent from your @gmail.com address.

    If you want to also send email from your domain, you’ll need to sign up with one of these third-party email services: http://en.support.wordpress.com/domains/add-email/

    More details: http://en.support.wordpress.com/email-forwarding/#changing-your-from-address

    #1995902

    timethief
    Member

    @macmanx
    Thanks for the catch here. I was distracted because I’m multitasking and should have followed through myself. I’m sorry I didn’t. :(

    #1995903

    macmanx
    Staff

    No worries, I appreciate you bringing it to my attention. :)

    #1995904

    Thanks. I think that does answer my questions.

    #1995905

    macmanx
    Staff

    You’re welcome!

The topic ‘Email forwarding to Gmail not working’ is closed to new replies.