Email not working again after mapping domain to WordPress

  • Author
    Posts
  • #1262287

    salusfitness
    Member

    About a month ago I mapped my domain http://www.salusfitness.ca to WordPress. My email stopped working, temporarily, as was warned might happen. I then obtained the DNS information from my email provider, entered it (in every possible combination I could think of), and still a month later my email is not working.

    I have written to support for help and have had no response.

    This is the DNS information exactly as I entered it:

    CNAME autodiscover salusfitness.ca.
    MX 10 mail.salusfitness.ca.
    A webmail 127.0.0.1
    A webmail 69.93.196.192

    I am not sure what I am doing wrong. Can anyone help me?

    The blog I need help with is salusfitness.ca.

    #1262385

    auxclass
    Member

    A webmail 127.0.0.1

    Looks like a local host to me – I would delete it

    Did

    A webmail 69.93.196.192

    come from your email host?

    Not sure about the

    CNAME autodiscover salusfitness.ca.

    either

    Someone has already flagged this for the staff to help you also

    #1262386

    salusfitness
    Member

    Thanks.

    Yes – A webmail 69.93.196.192 – came from my host.

    #1262519

    Hello,

    Sorry that you’re having issues getting your email setup properly.

    I noticed the same issues that @auxclass did with the records you are trying to add. Who is your email host? They may have a guide for setting up email that I can help you locate, otherwise you’ll have to get the correct records from them.

    #1262525

    salusfitness
    Member

    My host is Aquanode and they have set up email hosting for me.

    The records they provided me are as follows:

    salusfitness.ca. 14400 IN A 69.93.196.192
    localhost 14400 IN A 127.0.0.1
    salusfitness.ca 14400 IN MX 0 salusfitness.ca.
    mail 14400 IN CNAME salusfitness.ca.

    #1262528

    There are a couple issues with the records that they’ve provided.

    I would recommend trying these:

    A webmail 69.93.196.192
    A mail 69.93.196.192
    MX 10 mail.salusfitness.ca.

    As a note: because they are not providing you with a CNAME, if they ever change their IP address from 69.93.196.192, you will need to update your records.

    #1262544

    salusfitness
    Member

    Thank you for you help. My email is working again.

    #1262548

    My pleasure. Please let us know if there’s anything else that we can do to help.

    #1262607

    salusfitness
    Member

    Okay sorry, I thought this was fixed, but it isn’t.

    I have incoming email but not outgoing. I contacted my email host and they said that you (WordPress) need to allow the CNAME entry on my DNS otherwise my email is not going to work.

    Please can you tell me how I can add the CNAME entry to make this work?

    #1262624

    I’m not sure how a CNAME entry would affect your outgoing mail. Did they specify which CNAME entry you needed?

    You can add a CNAME entry the same way you added your MX and A records… for example:

    A webmail 69.93.196.192
    A mail 69.93.196.192
    MX 10 mail.salusfitness.ca.
    CNAME something mail.salusfitness.ca.

    In the case of the example above, something.salusfitness.ca would become an alias for mail.salusfitness.ca.

    #1262625

    salusfitness
    Member

    The only CNAME entry they have provided is this:

    mail 14400 IN CNAME salusfitness.ca.

    I tried adding in CNAME mail.salusfitness.ca but it wouldn’t allow it.

    I don’t understand what the “something” is that I’m supposed to add in. Am I missing some information?

    Thanks.

    #1262627
    mail 14400 IN CNAME salusfitness.ca.

    Would translate to the following within “Edit DNS” in your dashboard:

    CNAME mail salusfitness.ca.

    Here’s why the entry they are asking you to add is wrong. It would alias mail.salusfitness.ca to salusfitness.ca. But salusfitness.ca now points to your WordPress.com site, and WordPress.com does not handle mail.

    Are you receiving any bounce-backs or errors when trying to send email to other people, or are the messages just not being received?

    #1262629

    salusfitness
    Member

    Okay that makes sense to me (sort of).

    When I try to send an email, a message pops up that says:

    “Cannot send message using the server mail.salusfitness.ca

    The server Port 25 cannot be contacted on the default ports.

    Select a different outgoing mail server from the list below or click Try Later to leave the message in your outbox until it can be sent.”

    My host also said that if the CNAME entry could not be created, I could use the company’s server (mail.aquanode.ca) instead of mail.salusfitness.ca – but that doesn’t seem to work either. I get the same message pop up when trying to send an email (except the part about Port 25).

    #1262630

    I am able to connect to mail.salusfitness.ca on port 25.

    Domain names get stored on your computer in a “DNS cache” so browsers can load websites faster. Sometimes when a change is made to a domain name, such as your DNS records on WordPress.com, the previous records are stored on your computer, and you can’t load the new records.

    These stored domains are usually updated every 48–-72 hours on your computer, but you can force it to update sooner by “flushing” your computer’s DNS cache.

    You can find instructions on how to flush your DNS cache here:
    http://www.whatsmydns.net/flush-dns.html

    Could you please try flushing your DNS cache and let me know if you continue to have troubles accessing mail.salusfitness.ca on port 25?

    #1262631

    salusfitness
    Member

    Okay thanks. I flushed the DNS cache and it seems to be now accessing Port 25.

    I am still unable to send an outgoing email though. The message in Connection Doctor says “Could not connect to the SMTP server. Check your network connection and that you entered the correct information in the Account preferences” (which I have done)

    #1262633

    You’ll need to verify those settings with Aquanode.

    What is the SMTP address that you are trying to connect to?

    #1262637

    salusfitness
    Member

    I have verified the settings with Aquanode.

    Thanks for all your help and patience. I’m going to switch to a different host and hopefully get this fixed.

    #1262638

    Sorry for all your troubles, if you’re looking for a different email host, we have a list of others that we deal with on a more regular basis here:

    http://en.support.wordpress.com/domains/add-email/

The topic ‘Email not working again after mapping domain to WordPress’ is closed to new replies.