email notifications include entire post

  • Author
    Posts
  • #889061

    When I create a new post, an email goes out to all my subscribers with the entire post in the body of the email. The problem is that my posts are short stories and I only want to first sentence or so to be in the email notification. How do I make this happen.

    Thanks

    The blog I need help with is astarinmyhand.wordpress.com.

    #889214

    timethief
    Member

    Hello,
    You can set your RSS Feed for post to “summary” here> Settings > Reading
    For each article in a feed, show
    __Full text
    __Summary
    click “save changes”

    #889347

    OK thanks for that.

    Does that setting apply to both RSS feeds and emails?

    #889349

    auxclass
    Member

    Yes

    #889350

    OK thanks. I appreciate all the help.

    #889355

    @astarinmyhand
    You’re welcome from me. (I’m the same person ie. timethief but I’m currently logged in under my username account for my personal blog).

    #889470

    cjbenham
    Member

    timethief, I thank you too. I was trying to figure out how NOT to include the entire new post in the email notification. Is there anywhere to keep RSS feeds showing whole post, but only brief summary in email notifications to subscribers?
    Thanks!

    #889471

    raincoaster
    Member

    Not at WordPress.com there isn’t.

    #889501

    janepell
    Member

    If you insert a “more” tag in your posts, does that override showing Full Text in a feed or email?

    I had never, until now, been able to get my own posts via email even though I was subscribed. So I’ve never seen what others see. No I am subscribed and I have Full Text selected but I always use a “more” tag.

    If “more” tag does not cut off the full post, any suggestions as to what’s going on?

    #889502

    timethief
    Member

    It’s the RSS Fed “summary setting” that’s the one that matters when it comes to what goes out in the emails. I found that out the hard way myself. All my posts had “the more tag” in them I was very unhappy when I discovered that tag does not do the trick.

    #889503

    janepell
    Member

    Hi.
    Thanks for the quick reply. I’m a little confused though. I do have Full Text selected and I want full text to show in emails.

    I use the “more” tag because I want the home page to show a bunch of posts, not just one.

    Your answer sounds like the opposite solution to what I’m looking for, but maybe I’m misunderstanding. I want both a “more” tag for the blog home page and I want full text for the emails.

    Thanks,
    Jane

The topic ‘email notifications include entire post’ is closed to new replies.