Embed to Gigya Shortcode Help Please

  • Author
    Posts
  • #701673

    bloodsong
    Member

    http://bloodsongtermagant.wordpress.com

    which won’t show you anything, but that’s my blog. or one of them. i bought a random quote rotator from oxylus flash, to (try to) embed on one of my pages.

    now, following this extremely useful and popular tutorial by panos:
    http://wpbtips.wordpress.com/2010/07/22/gigya-shortcode-3-widgets/

    i know i have to convert my swf file’s embed code into gigya shortcode. however, whenever i try to do it, the widget does not work. i thought instead of overloading poor panos, i’d ask folks at large, hoping there are more people who know how to properly do this.

    so, here is the embed code for my swf app:

    <!-- START: EMBED CODE -->
    <style type="text/css">
    html{
    margin:0;
    padding:0;
    height:100%;
    width: 100%;
    background-color: #000000;
    }
    body {
    margin: 0;
    padding: 0;
    height:100%;
    width: 100%;
    min-width: 1200px;
    min-height: 600px;
    }
    #oxylusflash{
    min-width: 1200px;
    min-height: 600px;
    height: 100%;
    overflow: hidden;
    display:block;
    outline:none;
    }
    </style>
    <script type="text/javascript" src="js/swfobject.js"></script>
    <script type="text/javascript" src="js/swfaddress.js"></script>

    <script type="text/javascript">
    // DOCUMENTATION: http://code.google.com/p/swfobject/wiki/documentation
    var flashvars = {};
    flashvars.xmlFile = "data.xml"; // SET XML FILE HERE
    var params = {};
    params.scale = "noscale";
    params.salign = "tl";
    params.bgcolor = "#000000";
    params.seamlesstabbing = "false";
    params.swliveconnect = "true";
    params.allowfullscreen = "true";
    params.allowscriptaccess = "always";
    params.allownetworking = "all";
    params.base = "";
    var attributes = {};
    attributes.id = "oxylusflash";
    attributes.align = "top";
    swfobject.embedSWF("main.swf", "alternativeContent", "100%", "100%", "9.0.0", false, flashvars, params, attributes);
    </script>
    <!-- END: EMBED CODE -->

    THIS is what i translated that into:

    [gigya src="http://bldsong.net/dabz/Quotes/main.swf" width=400 & height = 220 & flashvars.xmlFile ="http://bldsong.net/dabz/Quotes/data.xml"]

    (i had a longer one, but all those params didn’t really seem needed.)

    i get the flash widget’s blank background, but i don’t get my random quotes.
    my guess is, there’s something screwy with the flashvars.xmlFile thing. because that’s not a full parameter, it’s… part of an array?? i’m stumped, and i didn’t get any reply on the oxylus support forum on this.

    is this widget just not going to work via gigya shortcode because of the external xml file it is using for its operation? i have no idea, to be honest.

    thanks for any help or suggestions to try!

    The blog I need help with is bloodsongtermagant.wordpress.com.

    #701914

    If you notice int he top “script” section where it says, javascript? It appears like the code needs both javascript and flash, so I doubt it is going to work.

    #701976

    bloodsong
    Member

    oh, is that right? i thought perhaps all SWF files had javascript running them. hey, i dunno nothin! ;D

    thanks!

    #701977

    bloodsong
    Member

    wait…

    all flash apps, including the embedded ones on panos sample pages, are blocked by no-script. so… that does mean they’re all run by javascript, doesnt it?

    ???

    #701978

    The code you pasted is for self-hosted blogs. It cannot be used in a wp.com blog or converted into anything. As TSP already pointed out, if you see “script” or “javascript” in a code, you can forget it. The codes that can be converted into a gigya shortcode start with this tag:
    <embed
    or this tag:
    <object

    As for you last remark, if by “blocked” you mean stripped out by WP, then no that doesn’t apply to javascript only: WP strips out the codes that start with script or embed or object or iframe or form.

The topic ‘Embed to Gigya Shortcode Help Please’ is closed to new replies.