Embedding Google map appears blank

  • Author
  • #804629



    I am trying to embed a Google map into my blog but it is appearing blank.

    I have followed the instructions on this page

    When I embed the iframe into HTML and publish it, the shortcode below is created, but when I view the page it is just blank.
    [googleapps domain="www" dir="maps" query="f=q&source=s_q&hl=en&geocode=&q=melbourne&aq=&sll=-33.873651,151.20689&sspn=0.063495,0.062656&vpsrc=0&ie=UTF8&hq=&hnear=Melbourne+Victoria,+Australia&t=m&z=13&ll=-37.813187,144.96298&output=embed" width="425" height="350" /]

    I am using the Brand New Day theme (not sure if that makes any difference)

    Any help is appreciated. Thanks!



    Are you sure you grabbed the HTML Link to embed in a website? My test post code is entirely different. And I tested in Brand New Day and the post appears there with my test code, but yours does come up blank.

    The site linked to your username is using Vertigo, so could you also give us the link to the site where you are having this problem?



    Thanks for your help justjennifer. I don’t know exactly why this doesn’t work, but I have found a way to make this work for me.

    This is the HTML that I tried (I have removed the ‘View Larger Map’ link that google adds) is:
    <iframe width="425" height="350" frameborder="0" scrolling="no" marginheight="0" marginwidth="0" src="http://www.google.com/maps?f=q&source=s_q&hl=en&geocode=&q=sydney&aq=&sll=37.0625,-95.677068&sspn=60.935792,64.160156&vpsrc=0&ie=UTF8&hq=&hnear=Sydney+New+South+Wales,+Australia&t=m&z=14&ll=-33.873651,151.20689&output=embed"></iframe>

    When I click publish, that snippet turns into this:

    [googleapps domain="www" dir="maps" query="f=q&source=s_q&hl=en&geocode=&q=sydney&aq=&sll=37.0625,-95.677068&sspn=60.935792,64.160156&vpsrc=0&ie=UTF8&hq=&hnear=Sydney+New+South+Wales,+Australia&t=m&z=14&ll=-33.873651,151.20689&output=embed" width="425" height="350" /]

    But on the site, there is nothing. Notice how this says ‘googleapps’ in the shortcode whereas on http://en.support.wordpress.com/google-maps/ it has ‘googlemaps’

    So I made my own shortcode by taking the URL (which you can find in the iframe):


    Modifying the domain in the URL from ‘www.google.com’ to ‘maps.google.com’ and finishing with:

    [googlemaps http://maps.google.com/maps?f=q&source=s_q&hl=en&geocode=&q=sydney&aq=&sll=37.0625,-95.677068&sspn=60.935792,64.160156&vpsrc=0&ie=UTF8&hq=&hnear=Sydney+New+South+Wales,+Australia&ll=-33.873651,151.20689&spn=0.0449,0.062656&t=m&z=14&output=embed]

    And it worked!



    I’m glad it worked, but sorry you had to jump through hoops to get it to do so. Were you logged in to googleapps when you created the map?



    If by googleapps you are referring to Google Apps (for Business) then no I wasn’t, however I was signed into my Google account (for Gmail, Docs, etc…)



    If you are using Google Apps for your ss48.org domain email, then you might have been. That’s the only thing I can think of that would cause the map code to be different. ??



    As a matter of fact I am. Seems strange that this could have an effect on the map code, but believable. Every other code I’ve seen reads googlemaps rather than googleapps.

The topic ‘Embedding Google map appears blank’ is closed to new replies.