Need help? Check out our Support site, then

embedding youtube videos

  1. I tried embedding videos from youtube. but i was not successful.

    is there a way to do this?

  2. I have the same problem!
    For videos from the problem persists as well!
    Can anybody help us out?
    Or maybe this could be an idea for a new feature?

  3. i am assuming this can go here...i am trying ot embed audio from file lodge and the post editor keep removing my html code...
    keeps it until i push "save" and then *poof* it disappears

  4. Sometimes embeded flash videos trigger the adblock extension in firefox. Since the flash video is coming from an external source...

  5. We're filtering out all object tags, which is how youtube and google videos work. It's a bit of work to scrutinize these tags but we aim to make the feature available eventually.

    Until then, keep linking to the youtube or google url.

  6. can anyone explain why this worked previously and not now? embedding youtube videos worked like a charm before, and indeed, it's become crucial to my band's blog. why do you have these features seduce us and then take them away?
    as another poster (vidness) stated, blogger has no problems with these, offers 300megs of image uploads, and i can hang a nice tag cloud in the side bar. too bad, i was really getting into wordpress..

  7. Well i don't know why you are not allowing the object tags but i don't like it. Please change it soon.

  8. please please please :)

  9. I had the same problem for the videos with both youtube and google. Might the same problem preventing flickr badge also.
    I have been using wordpress for more than 2 month now, i love it and do not want to change. But clearly this feature would be on my priority list far ahead customisation to templates.

  10. Now, I'm having a problem too.. Earlier, I was successful on embedding it. The next day, it doesn't work anymore. (my blog is not showing any embedded flash). My categories were suprisingly not functional or gone bonkers as well..

  11. As Andy said

    "We're filtering out all object tags, which is how youtube and google videos work. It's a bit of work to scrutinize these tags but we aim to make the feature available eventually.

    Until then, keep linking to the youtube or google url."

    If you want to use Youtube vids you have to type this

    [youtube= http:// / the url for the video ]

    Without the spaces, and your video should work.

  12. There's a link in the FAQ to an article that walks you through this as well explaining how to work out the link.

  13. Great. Where's the FAQ ?

  14. Top sticky thread in this forum (highlighted in red) or here

  15. Thanks.
    To cut a long story short for other users looking for instructions. You can find the FAQ here:

  16. You should be reading the FAQ anyway though. :)

  17. I post YouTubes sometimes and it's:

    [youtube=PAST THE URL LINK HERE]

  18. Could someone please explain to me the difference between the URL and the KEYCODE, or alternatively where I can locate keycodes at You Tube?

    Using DrMike's example, I can copy/paste the keycode he's provided and upload that video to my blog. But I cannot locate any keycodes myself at You Tube, hence am unable to upload my own video. I've read the FAQ and it doesn't state where the keycode is, so it must be so obvious that it doesn't need stating ...

  19. My mistake. I did mess up on that one. I was thinking of the plugin i use on my blog which only uses the keycode. Here's the usage as an example:

    URL of a video: http: //

    The code you use: [youtube=]

    Sorry again. (I support *WAY* too many things...)

    -dr(Need sleep....)mike

  20. I started having probs. with embedded youtube a couple of days ago. The initial image appears fine, but when you click the 'play' button it says 'Loading...', but never loads. Again, vids play fine on the youtube site.
    FYI I've tested it at work and at home, in FF and IE (in both places I have a firewall, as all sensible folk should). Please feel free to go to my site and let me know if it works for you.

    (originally posted at but this thread seems more relevant)

  21. Mod hat: removed double posts.

    I can't see YouTubes from here as the site is blocked. I'm hoping someone else can take this one. Podz?

  22. ok, but [youtube=] works on hosted blogs. Is there a way to play YouTube on Wordprass hosted at "paid hosting" service?

  23. armcurl: experienced the same since like 10 days ago. GoogleVideos are also affected. Details here:

  24. Maras, there are a number of plugins that will allow you to play YouTube videos on your own WP blog hosted elsewhere. You can find a list of them here. There also exists another one called WP-Extreme which is the one I use myself and the one I roll out for my clients. It can play self hosted videos as well as those hosted elsewhere.

  25. Found the solution to my problem.
    The videos that were refusing to play on WP had their setting 'Allow other sites to host this video' set to false.
    Simple really.
    It seems this setting shows the video's first frame as a still, but doesn't allow ppl to play it.
    Anyway, fixed now. :)

  26. Hmm, never knew that they had such a setting. I don't remember seeing that on any page over there. *grumble*


  27. i still cant put my youtube video. I used the embed html from youtube and then paste in in my blog(gallery) html box, and its not there. When i check the html box, my embed code was gone.

    I even tried using [youtube=]

    but the exact html code came out instead of the video.

    what happend?

  28. TJ, can we see a sample of this on your blog please? It should be working if you're following the instructions above. If you've copying and pasteing the code from YouTube like you say you are, then you are doing it wrong I'm afraid. Here's the link again for instructions on how to do it.

  29. OK - so I played with this tonight and the video was showing just fine. Now I've got a big blank spot. Is there something I'm missing?

    nevermind - looks like YouTube was down.

  30. I have tried several times now, but it won't work for me. I know the only thing I need to do is to format it like this:
    But it won't work for me, it just shows the exact format:

    What can I do? Can someone help me?

    EDIT: My solution was to turn off this under profile: Use the visual rich editor when writing [*]

Topic Closed

This topic has been closed to new replies.

About this Topic