Enabled "Require name" on discussion settings not not working

  • Author
    Posts
  • #1365771

    We have checked the box in Discussion Settings indicating that we require commenters to provide their name and e-mail address to comment, yet it’s not requiring them to do so. What else do we need to do to get their names to be required? A detail that may or may not make a difference: our blog is set to private and all our users are set as Contributors. Might that make a difference?

    The blog I need help with is glmsdoctorslounge.org.

    #1365930

    timethief
    Member

    I’ll tag this thread for Staff assistance. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

    #1366041

    rachelmcr
    Staff

    Hi there,

    The setting for “Comment author must fill out name and e-mail” only applies to users who are logged out of WordPress.com. Because your blog is private, all users who are able to view your blog are registered at WordPress.com. When they comment, you will be able to see the name and email address they have set in their WordPress.com account. (If they haven’t set a name in their account settings, you will see their WordPress.com username.)

    You can read more about these settings here, if you are interested: Who Can Comment

    If you have any questions about this, please let me know!

    #1366048

    So if they didn’t set up their WordPress account with a name in it, there’s no way to require one when they comment?

    #1366054

    rachelmcr
    Staff

    When someone comments with their WordPress.com account, it automatically includes their name — it’s just that the default name is their username. If you’d like, you can ask your contributors to update their public display name in their Public Profile settings here:

    https://wordpress.com/?ssl=forced#!/settings/public-profile/

    The display name is what will appear when they leave comments on the blog. I hope this helps!

The topic ‘Enabled "Require name" on discussion settings not not working’ is closed to new replies.