Enabling comments on old posts

  • Author
    Posts
  • #375700

    davefagg
    Member

    For a while I had disabled comments on my blog posts (http://davefagg.com.au/blog) but now wish to enable them.
    I’ve enabled the comments facility for new posts, but even though I’ve enabled comments on each individual old post, I can’t seem to make a comment.

    I’m using Vigilance.

    The blog I need help with is davefagg.com.au.

    #376011

    You will have to open each post that was published while the comments were turned off globally and turn comments back on.

    You can do this more quickly by going to post > edit, finding the posts with the comments off, clicking the checkbox to the left of the name on each, then go to the “bulk actions” pulldown, select “edit” and then click “apply”. In the window that opens, select “allow comments” from the comment status pulldown and then click the update button. You might have to perform this on multiple pages if you have a lot of posts that were published while comments were turned off globally.

    #376017

    davefagg
    Member

    Did that – still not working. Each of the older posts has a “comments off” byline and won’t allow comments.

    #376018

    davefagg
    Member

    Got it now – I had put a time limit of 3 days on comments, so I guess the older posts (being older than 3 days each) are not allowing comments.

    #376020

    Ah yes, the comments time limit. That would do it.

The topic ‘Enabling comments on old posts’ is closed to new replies.