Enterprise theme – Can’t use a custom image for header

  • Author
    Posts
  • #478962

    martincasc
    Member

    I don’t know if this only affects to me or not, but I want to change the header background on Enterprise theme, I don’t like the fonts in the header and want use a custom header, but when I upload the image, it’s can be processed..

    Looking in my Multimedia, the images has been uploaded, but the change can be processed and can’t be used on the header. Also if I upload the image from the custom header option, the picture it’s upload and resized in any size..

    So, automatically change the size and the image it’s upload, but can’t be used for custom the header.

    The blog I need help with is elderechoargentino.wordpress.com.

    #479059

    timethief
    Member

    What’s the file extension on the image? It has to be either .jpg, .jpeg,.png or .gif
    Also did you presize it to exact specs? I never ever upload anything that requires cropping because the image quality is not retained.

    #479060

    timethief
    Member

    I’ll go try and try one on my test blog and let you know what happens.

    #479063

    timethief
    Member

    You are not alone. I tried to uplaod a header of the correct size and wit is a jpg file. this is what I got:

    File type does not meet security guidelines. Try another.

    This needs to be reported to Staff.

    #479068

    martincasc
    Member

    Yes, that’s the same problem. I’ve tried with .png and .png with transparencies and same issue.

    Bets,

    #479078

    shimworld
    Member

    Mine works fine, assuming you meant the “Header” which requires 960 x 80 pixels and not the “Background” which I haven’t tried. http://shimworld.wordpress.com/

    #479080

    martincasc
    Member

    @shimworld: yes! an image 960 80 pixels, background works fine since a few weeks ago.

    #479082

    timethief
    Member

    Okay I just made second header 960 x 80 pixels and this time it uploaded fine. There is no reason why the first one didn’t, unless the image editor had a coughing fit or something along those lines.

    #479083

    martincasc
    Member

    Well, now it’s working, but I can hide the original text :S The image upload fine, but then I see the image and the original header text, and I can’t hide. I’ve tried hide the text, save changes, and the upload the image and the text appear again, and the background (not header) has gone :S

    #479139

    martincasc
    Member

    Well, the original text still appearing up the custom header image on the configuration box, but in the blog it looks fine.. you can see it on my blog right now…

    Thanks timethief for the support and all the wordpress team for this great job, now I understand why you are the best.

    Best,

    #479166

    timethief
    Member

    @martincasc
    The header looks great now. In fact the whole theme looks very elegant on your blog. I like the logo and your color choices too.
    Happy blogging. :)

    #479418

    pdadams
    Member

    I’m having the same difficulties Just switched to Enterprise Theme.
    Whenever uploading image, cropping, changing text color (aka blog title), it appears fine in the preview, but when saving changes and reviewing on blog, only the text color appears changed. uplodaded image does not.

    Code for my upgraded CSS re: header is:
    #header {
    background:#FFFFFF;
    width:960px;
    height:120px;
    overflow:hidden;
    border:1px solid #E4E4E4;
    border-top:none;
    position:relative;
    margin:0 auto;
    padding:0;
    }

    Any assistance would be appreciated.

    #479419

    pdadams
    Member

    P.S. when the height was set to 80px as per the original styleheet, still had the same difficulties.

    #479422

    I just uploaded a custom header for my blog with the Enterprise theme…it’s the right size, 960 x 80, but I can’t get it to appear. I’ve tried .jpg and .png versions of the header. They appear to get saved just fine, but they don’t appear on my blog.

    http://frozenroyalty.net

    #479423

    I’ve had to remove the custom header, since it isn’t working.

    #479424

    I’ve tried reverting back to the original CSS style sheet and I still can’t get the custom header to appear. Anyone got an idea?

    #479425

    timethief
    Member

    @pdadams and kingsfan
    Hello there. This is a Support Forum thread. As you two have CSS editing issues you ought to be posting a thread to the CSS Customization forum where the Volunteers who help with CSS find it so they can help you. This is the link that’s found in the left hand sidebar of the front page of the forum > https://en.forums.wordpress.com/forum/css-customization

    #479426

    I’m not sure this is a CSS issue. Then again, I don’t know, since I’m not a CSS guru. :-) All I know is that I can’t add a custom header (it doesn’t show up) while using the Enterprise theme. This happens with the original style sheet or one that I tweaked slightly, but only to change the text color for link text.

    #479427

    timethief
    Member

    If you have edited the CSS on any theme at wordpress.com you can no longer use the custom image header uploader. Once you have edited the CSS then the header image URL must be included in the CSS stylesheet.

    #479428

    OK…but in that case, why doesn’t the custom header feature work with the original stylesheet re-installed?

The topic ‘Enterprise theme – Can’t use a custom image for header’ is closed to new replies.