Error connecting Jetpack

  • Author
  • #759643


    Hi, I’ve been trying to get Jetpack up and running but post-install when I try to connect to I get the following error:
    Your Jetpack has a glitch. Something went wrong that’s never supposed to happen. Guess you’re just lucky: secret_1_malformed
    Try connecting again. Error Details: The required “secret_1” parameter is malformed.

    Connecting again does not resolve anything. I’m using Jetpack v1.2.1 on WordPress v3.2.1.
    I tried searching to see if anyone else has come up with a solution but to no avail. Help me Obi Wan Kenobi, you’re my only hope.
    Blog url:


    Let me see what I can find out. I will ask Obi Wan. :)



    This is a very unusual error. Congratulations :)

    Could you please try connecting again? We’ve added some logging on our side that should help us figure out what’s going on.



    Why thank you, I did try my best.
    I just tried connecting again several times.



    Our logging caught your connection attempt, thanks.

    It has confirmed that something is amiss, but not really told us why.

    Could you send us a list of the other plugins you currently have active?



    Sure. All currently active plugins:
    AJAX Thumbnail Rebuild, Akismet, Better Delete Revision, Contact Form 7, Dashboard: Available Disk Space, Display Posts Shortcode, Exclude Pages from Navigation, Exec-PHP, Extended Blogroll, FD Feedburner Plugin, Google Analytics for WordPress, List category posts, No Self Pings, Relevanssi, Reveal IDs, Scripts Gzip, Smart 404, Subscribe to Comments, Stats, WP-PageNavi, WP-Polls, WP-PostViews & WP-ServerInfo.



    Well, you definitely won’t need Stats if you get Jetpack up and running, so would you please disable that?

    Also, “No Self Pings” may be causing an issue. Would you try disabling that as well?

    Please try connecting again with both of those disabled and let us know how it turns out!



    Good morning, you’re either in Europe as well or burning the midnight hours.
    I have disabled both and tried again, still the same result alas.



    Alright, hang in there. We need to do a bit more digging.

    Sorry for the trouble!



    No trouble at all, as long as I get it working before the Stats plugin goes the way of the dodo I’ll be happy.



    For deduction’s sake I just tried disabling everything, enabling Jetpack and connecting again; same result.


    Just wanted to let you know that we haven’t forgotten about this. It’s still on our radar to dig deeper into and see what’s happening. Thanks for your patience.



    No worries, patience is a virtue. :)



    Could you please install our test/debugging plugin?

    You can get the ZIP file at:

    You can install it by doing the following.
    1. Go to your Admin → Plugins
    2. Click the “Add New” button (near the top of the page)
    3. Click the “Upload” link (near the top of the page).
    4. Upload the ZIP file you just downloaded from the above link.
    5. WordPress will take you through an installation procedure.

    If that fails, you can unzip the ZIP file and upload the results directly to your host using FTP (or whatever your hosts recommends).

    After installing and Activating the plugin,
    1. Go to Admin → Plugins → Jetpack Compatibility TEST
    2. The page may take a bit to load. It will output a bunch of ugly looking debug information.
    3. Click the “Select All” button.
    4. Copy the selected text.
    5. Send all that text you copied to support using the form at

    That’s a lot of steps, I know. Hopefully we’ll be able to fix the problem with all the extra information this debug output provides.



    Oops. There was a bug in that test/debugging plugin. I’ve fixed the bug.

    When you install it, make sure it calls itself version 1.2. Sorry for the extra hassle.



    That wasn’t a lot of steps. 1) install plugin, 2) copy/paste output.
    Sent, I hope it helps.


    For reference, should anyone else run into the secret_1_malformed error with Jeptack, hopefully this plugin will solve your troubles:

The topic ‘Error connecting Jetpack’ is closed to new replies.