Error in rss feed

  • Author
    Posts
  • #1506225

    cbjkelvin
    Member

    There is something wrong with my site feed: http://lundiao.wordpress.com/feed/

    This page contains the following errors:
    error on line 811 at column 25: Input is not proper UTF-8, indicate encoding !
    Bytes: 0x1F 0xE5 0xB1 0x8B

    http://validator.w3.org/feed/check.cgi?url=http%3A%2F%2Flundiao.wordpress.com%2F

    Sorry

    This feed does not validate.
    line 811, column 52: XML parsing error: <unknown>:811:52: not well-formed (invalid token) [help]
    <description><![CDATA[我是半個檳城人。 -黄糩璊。 我還沒出生。 -魏家祥。 屋外搭棚須7天前申請。 -市議會。 分類:刁民 …
    ^
    In addition, interoperability with the widest range of feed readers could be improved by implementing the following recommendations.
    line 14, column 95: Self reference doesn’t match document location [help]
    … rel=”self” type=”application/rss+xml” />
    ^
    line 25, column 9: title should not be blank [help]
    <title></title>
    ^
    line 25, column 9: Image title doesn’t match channel title [help]
    <title></title>
    ^
    line 28, column 131: Unregistered link relationship: search [help]
    … .wordpress.com/osd.xml” title=”論 · 刁” />

    What wrong with it?

    The blog I need help with is lundiao.wordpress.com.

    #1506310

    timethief
    Member

    You’re right. There is an issue with your feed.

    Your RSS feed contains invalid XML:
    XML error: Invalid character at line 811

    <?xml version=”1.0″ encoding=”UTF-8″?>
    <rss version=”2.0″
    http://ismyblogworking.com/lundiao.wordpress.com

    I’ll tag this thread for Staff assistance. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

    #1506325

    jackiedana
    Member

    It looks like there is an error on the post from 23 May 2012:
    https://lundiao.wordpress.com/wp-admin/post.php?post=2171&action=edit

    I set that post to draft status, and your feed validated. I’m not sure caused the issue, but my best guess is that there’s a Chinese character in the title or the post itself that isn’t encoding properly.

    #1506351

    cbjkelvin
    Member

    It works! Finally! Thank jackiedana, & all the wordpress staff! Thanks!

The topic ‘Error in rss feed’ is closed to new replies.