Every blog entry I've ever written is attempting to load up at once.

  • Author
  • #862351


    I’m just wondering if something is up with WordPress at the moment and that this issue is affecting everyone, or is it just me?

    I have my blog set up to only show the three most recent entries, it just makes it easier to load the page and is nicer on the eye. However, as of this afternoon (5th of April), it’s now trying to load all 190 of my postings onto the page at once.

    Everything on my dashboard is still set up the same as it was, so I’m hoping that this is just a glitch in the system.

    If anyone has any pointers, ideas or know what the deal is, that would be much appreciated.


    The blog I need help with is purpleblancmange.wordpress.com.



    Unfortunately, it’s not a glitch. WordPress.com has just implemented “infinite scroll” onto your page. It’s what wordpress.com thinks will help your viewers since they won’t have to keep clicking “older entries”. But actually, wordpress.com just made it worse because now all of everybody’s readers have to wait forever for the ever-loving home page to load. WordPress.com made a big mistake (either they didn’t think about it or they didn’t care). If you don’t like infinite scroll, timethief has an excellent post on disabling it here..



    Thank you purpleblancmange for asking this question and a HUGE thanks to timethief for the workaround.


    Iano10, thank you so much for the link to timethief’s blog! I’ve looked in to their help directions and as yet, it doesn’t seem to be working with the theme that I’m using, but I’ve asked if she has any ideas.

    Complexwoman, I only asked because I’m too stupid to work out a fix for myself, but at least iano10’s link was brilliant in that it gave me a point of reference.

    As much as I love WordPress, I really do wish they’d stop doing things like this. It’s almost got to the stage where everytime I log in to my own blog, something has changed and that’s just beyond irritating!

    Infinite Scroll is simply dreadful, WordPress. Please reconsider or give us folk a simple button that allows us to switch it off. Surely that’s not too much to ask, is it?



    Chaotic Soul does not have footer widgets. First temporarily switch first to any theme that does have footer widgets like Twentu Eleven and go here > Appearance > Widgets Install a single empty text widget into any footer wirdget area. Then you will be able to disable “infinite scroll” on this page Settings > Reading. Disable this:
    To infinity and beyond Scroll Infinitely and click “save changes”
    Then switch your theme back to Chaotic Soul > Appearance > Themes
    P.S. I just did this on my test blog and it does work exactly like I said it would here > http://onecoolsitebloggingtips.com/2012/03/16/disabling-infinite-scroll-on-your-wordpress-com-blog/


    Thanks for your reply timethief, I think I’m having a senior moment and I had to ask my wife to see if I was missing something – I was, by all accounts.

    What you’ve said here now makes perfect sense, however there is now one issue that I cannot seem to get my head around; if I choose a new theme and do as you’ve very helpfully suggested, I would obviously then have to re-select Chaotic Soul… thing is, I can no-longer find it for some reason in the theme listings. Hopefully I’m just being blind, but is this still a current and active theme that I can select again after following your tips?

    Forgive me for probably missing the obvious, it’s been a terribly long week, my head is buzzing and I feel like I just need someone to hold my hand through this. While you’re dishing out miracles, how about making my kids sit still and quiet for 10 minutes…



    You cannot find Chaotic Soul here > Appearance > Themes no because the blog blog is already wearing it. After you switch to any theme with footer widgets like Twenty Elevn and do as I explained in my post and in this thread you will be able to select Chaotic Soul here > Appearnce Themes because it won’t be the theme on the blog at that time.


    Thanks very much for your kind help, I genuinely do appreciate it. I’ll run this in due course – just going to get Easter out of the way first.

    Very kind of you.



    You’re welcome and best wishes for a lovely long weekend.



    Thanks so much for this..Really helped me with my Chaotic Soul theme. Though I was considering changing my theme if i find one I like, and now I am afraid to do that – not really sure I wanna see that infinite scroll again.

    I think such a thing should be tested with readers and bloggers before its implemented like this, to see if people actually want it before you enforce it on them!

The topic ‘Every blog entry I've ever written is attempting to load up at once.’ is closed to new replies.