Excerpts are appearing on front page (Oxygen theme), instead of full posts?

  • Author
    Posts
  • #1029582

    taryn0615
    Member

    I’m using the Oxygen theme for a blog (hellofromeurope.wordpress.com). I have set the Settings>Reading to show full posts, not excerpts, but the post(s) still display with only excerpts on the front page. How do I fix this? (There is no More tag in the post.)
    Blog url: http://hellofromeurope.wordpress.com/

    The blog I need help with is hellofromeurope.wordpress.com.

    #1029792

    abdullah47
    Member

    Settings > Reading > For each article in a feed, show For each article in a feed, show
    Full text
    Summary

    Select full text.

    #1029794

    timethief
    Member

    @taryn0615
    This page > Settings > Reading is where we can set only the RSS Feed to “summary” or “full text”. Doing that does not change the length of posts on the blog.

    Take a close look at how the Oxygen magazine styled theme is designed to display posts.
    http://theme.wordpress.com/themes/oxygen/
    http://oxygendemo.wordpress.com/

    The theme is displaying exactly the way it is designed to display, which is excerpts only on the front page of the blog but it does have an active excerpt box below the post editor, so you can control the length of the excerpt displayed. This is the workaround you can use to override excerpt display on the front page and display a whole post instead.

    When creating a post or page on your WordPress.com blog, you have two editing modes available to you: Visual Editor and Text Editor (HTML).

    You compose your whole post first in the Visual editor and before you publish it you switch to the HTML (Text) editor, copy all the code you find there, paste it into the Excerpt box, and publish the post. http://en.support.wordpress.com/splitting-content/excerpts/#creating-excerpts

    This will have to be done on every post.

    #1029795

    taryn0615
    Member

    THANKS very much, @timethief! You’re a star! My daughter will be delighted.

    #1029796

    1tess
    Moderator Emeritus

    @taryn0615

    The setting for the feed won’t affect the way your posts appear on your home page. That is only for how your RSS goes out to subscribers.

    The oxygen theme is set up so that it shows the first few lines of each post on the front page. “Read more” or “continue reading” don’t appear either because that is how the designer set the theme up.

    To make full posts appear on your front page, you will need to use the custom excerpt function. Write your post as usual, then switch to the text editor. Select and copy all. Paste the code into the excerpt module. Note that embed and shortcode won’t show. YouTubes, galleries, and slideshows won’t work. Folks will have to view your posts with them included by clicking on the title of the post.
    http://en.support.wordpress.com/?s=custom+excerpt

    #1029797

    1tess
    Moderator Emeritus
    #1029798

    1tess
    Moderator Emeritus

    ~~~eventing timethief: should have refreshed after returning to the laptop…

    #1029799

    1tess
    Moderator Emeritus

    argh!! evening
    (typos)

    #1029800

    1tess
    Moderator Emeritus

    Oxygen also seems to force one to select a featured image even with the custom excerpt filled in. I’m not sure what size it needs to be but if one is not selected then there is a grey rectangle above each post.

    #1029801

    taryn0615
    Member

    Thanks, @1tess! I appreciate the great support!

    #1029802

    1tess
    Moderator Emeritus

    You are welcome. I think you can find out the size needed for the featured image on the themes showcase timethief linked to.

    I’ve not worked with that theme but it looks interesting. ≥^!^≤

The topic ‘Excerpts are appearing on front page (Oxygen theme), instead of full posts?’ is closed to new replies.