Need help? Check out our Support site, then


Experiencing FOUT again

  1. I've been experiencing FOUT in the last couple of days, most noticeably in post titles. I was wondering if it could be related to WP's recent addition of more fonts. I've not had this problem for about a year and have not changed any of my settings. I'm using Chrome Version 44.0.2403.125 (64-bit) on a MacBook Pro. My download speed is the same as always. As I've noted in the past, I'd much prefer a briefly blank screen to one that reveals changing fonts.

    The blog I need help with is piedtype.com.

  2. Thanks for posting again, windwhistle. Every theme that I have tried has FOUT across each browser or platform I use; Chrome, Safari, Firefox, Windows, Mac. The default font displays before the custom font loads (FOUT: Flash Of Unstyled Text). I tried two Premium themes, and they also have FOUT. The FOUT does not show up when previewing a theme, so one is unable to prescreen. We also have a pretty fast internet connection. I have read the previous discussions around this issue, and those solutions of digging into the CSS are not an option for a free account at WordPress.com. Would the Customization upgrade give me access to a high enough level of code to fix the problem? I might do that, and grumble about paying $30 a year to make it work...

  3. I don't know what's needed. I've got all the upgrades/customizations on my blog and have not made any recent changes that would cause FOUT to start occurring. And yet, there it is again, for the first time in months. I hate it and feel it instantly degrades the quality of my blog in the eye of the visitor. If there's a CSS solution, as there has been in the past, I'm not knowledgable enough to implement it without help.

  4. Volunteers cannot resolve these kind of issues. Please type modlook into the sidebar tags on this thread for Staff help. How do I get a Moderator/Staff reply for my question? https://en.support.wordpress.com/getting-help-in-the-forums/#how-do-i-get-a-moderatorstaff-reply-for-my-question Then please subscribe to this thread so you are notified when they respond. To subscribe look in the sidebar of this thread, find the subscribe to topics link and click it.

  5. @timethief

    Thanks for the "modlook" tip.

    Please know that windwhistle started those referred threads -- those are the css fixes that are not available to wordpress.com users.

  6. Actually windwhistle does have a CSS editing upgrade.

  7. Hi windwhistle,

    When we recently added free Google fonts to all sites across WordPress.com, we changed the way web fonts are loaded. On slower connections, we used to show a blank page before the content loaded - now, we display the content in the theme's default font first, so no one sees a blank page. We realize this means that there may be a flash of a different font before the page finishes loading, but we think overall this is better for folks on slower connections than seeing a blank screen.

    This CSS snippet should return your site to the previous behavior on loading:

    .wf-loading body {
      visibility: hidden;
    }
  8. Hi rachelmcr,

    I, for one, strongly disagree with that design decision. The conspiracy theorist in me sees that as a way to force people into the custom upgrade... I urge WordPress to reconsider.

  9. Thank you, rachelmcr. That seems to have fixed it. For what it's worth, I'll bet most WP bloggers would prefer a second or two of a blank page to FOUT.

  10. thistimethisspace
    Member

    @hwalksintoabar
    Note that we can all use Google fonts free of charge - no upgrade required. https://en.blog.wordpress.com/2015/07/31/free-google-fonts/

  11. Thanks, @thistimethissspace, but the alternate fonts do not correctly load.

Topic Closed

This topic has been closed to new replies.

About this Topic