Export/Import fails (more info). Ideas?

  • Author
  • #507308


    OK so I have more info.

    I export from WordPress.com into the usual XML file. I am doing it in small increments (no more than a month).

    I then try to import those into my otherwise working brand-new wordpress.org site, hosted at 1and1.com. Otherwise this is fine (and I host another blog there, all fine too). But the impoirts all fail.

    And not all at the same point. It seems an import will run for a few seconds, then stop. So if I include media they all fail very miserably. But even when importing posts, it will just hand half way.

    If I then repeat the same import, it will recognize the ones it has done and say “already exists”, and it will import maybe one more post. And so on: every time I repeat it will do a little more.

    At this rate it will take me a week to import my many posts. Halep.. anyideas?

    I am using the wordpress import plugin, and there’s only one as far as I can see.

    Help.. can anyone give me any advice?

    The blog I need help with is blog.michaelwillems.ca.



    By the way it does not matter which browser I use.



    So far, this has cost me an entire day – going to a .org hosted solution – and even that fails: import hangs up after a few posts. I have 1,000 posts to move, as well as 1,000 images. Being self employed, I find wasting a day to be enormously painful. I don’t work, I don’t earn. Clearly, wordpress.org is no longer an option. They ruined my blog, which IS my business: intolerable.

    Anyway enough mentioning this: I’ll try to get this move done. So.. any ideas, ANYONE, of how to solve the problem?

    I am sure I am doing it right; the import hangs at a different point each time, and always after just one or two posts. Then I need to restart. So far I’ve done just a few of my 600 posts and it’s taken six hours.

    Any input very welcome…



    Thanks to a German blogger – no-oen here knew??


    Here is how to solve the issue:

    You have to add two lines of code to your .htaccess file to force the use of PHP5

    1. Locate your .htaccess file in your WordPress installation root folder (most FTP tools don’t show the file so you’ll need SSH/command line access or open 1&1’s “WebspaceExplorer”)

    2. Download the file.

    3. Edit with any editor (I use Coda) and add the following two lines at the top:

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    4. Save it and upload the file to your web space again.

    5. Make sure the file name is actually .htaccess (no file ending and starting with .)

    6. You are done and everything works as it should now.



    (It’s not perfect, it still hangs, but now just occasionally, so you restart it and after a few tries it’s ok. No media, but all my posts are up at http://www.speedlighter.ca )


    Moderator Emeritus

    Wow, sounds as though you are doing quite a good job tackling this!

    I think you are not getting much response in this forum because we volunteers answer questions about wp.com blogs, which we have experience with. The wp.org forum is more likely to be helpful. But I’m glad to hear that you are making progress.



    Oh I asked there too. Wasn’t sure if the export from com or the import to org was the issue.


    Moderator Emeritus

    Yeah. Sort of a bridge between the two.



    Yeah. It’s still not perfect (I am missing July-Sept 2009, but when I try to re-import it says it already exists) but hey it’s a start.



    We have the same problem, the XML produced by the export utility always IS EMPTY
    Some idea about it?
    The blog has not spam.
    we already buy hosting to move the blog to wp.org

    1tess! may be you can help us, thanks a lot!
    (we always are trying to export all the content)



    The blog is HUGE to load. Have you attempted to break it down into chunks and export by date?



    yes in the meantime, we can generate goods xml, exporting month by month.
    Now, we are trying to import to the hosting, and the importing process dies giving the following error:

    HTTP Error 500.0 – Internal Server Error
    c:\php\php-cgi.exe – The FastCGI process exceeded configured request timeout

    or 500 and:
    The FastCGI process exceeded configured activity timeout

    If you have some idea about these errors, we wanto know, :)
    Seems a problem in the hosting provider, we are claiming them to resolve the problem. Other user reported:

    The FastCGI timeout setting was increased on the server and corrected the problem.
    ExePath=D:\Program Files\PHP5\php-cgi.exe RequestTimeout=240 ActivityTimeout=300

    thanks a lot!
    [this thread is about export-import, i thing we`re into the scope yet]



    raincoaster, 1tess, can i ask you a question?
    which is the bests hostings to wordpress?
    The wp site speaks about bluehost, dreamhost, mt.
    But now we need a true good host, without this E500.
    GoDaddy may be?
    Can we access the DB with an external phpMyAdmin?
    May us delete that duplicate items in the posts table?
    Which hosting brings the best DB management?
    We wait for the Adminer, it tries for a while, but never starts,.

    Thanks a lot! friends!



    Ok, now we`re using Adminer and phpMyAdmin, out of wordpress.
    Adminer plugin never ended the starting.
    We deleteall commentmeta comments postmeta posts, and obtain a initial state in the new db. [*]

    The hosting provider agree to import all, and we send 22 xml-files, one for each month.

    [*] we let the follow items:
    apswp_links………….. 8 items
    apswp_options…………150 items
    apswp_posts………….. 2 items
    apswp_term_relationships. 9 items
    apswp_term_taxonomy…… 2 items
    apswp_terms………….. 2 items
    apswp_usermeta……….. 15 items
    apswp_users………….. 2 items

The topic ‘Export/Import fails (more info). Ideas?’ is closed to new replies.