Export/Import won’t work

  • Author
    Posts
  • #22319

    hjorthen
    Member

    This might be answered somewhere else, but I’ve been reading and reading and getting more and more confused, so I’ll try to ask the question in an own thread. I’m not sure if I should post the question here or over at wordpress.org, but I’ll give it a go here first and se how it goes.

    I have a blog here at wp.com (http://hjorthen.wordpress.com) wich I am trying to export to a blog that I intend to host myself. (http://hjorthen.org)

    I do as the prescription says and exports the old blog as an xml-file, but when I try to import it to the new blog I get this message:

    The uploaded file could not be moved to .

    What can I do?

    Also, when I look at the xml-file it seems to me that the whole blog isn’t there? It stops somewhere around the end of 2004 (I have been blogging since august 2004) with the following message at the bottom of the file:

    – <wp:comment The XML page cannot be displayed
    Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.

    ——————————————————————————–

    End tag ‘A’ does not match the start tag ‘a’. Error processing resource ‘file:///C:/Documents and Settings/Arne/Desktop/wor…

    <wp:comment_content>I have a <a HREF=”http://www.blogger.com/r?http%3A%2F%2Freluctantyuppie.blogspot.com” rel=”nofo…

    Any ideas anyone?

    #22660

    wank
    Member
    • Have you tried doing a fresh export?
    • Are you uploading the export file to the correct place?
    • What version of wordpress.org are you using? Are you using a plugin to import the xml?
    #22661

    hjorthen
    Member

    The export is fresh as of today

    I am using the import-function on the dashboard to upload the xml-file, if it’s not uploading to the correct place I wouldn’t know:-)

    The version I’m using is WordPress 2.0.3

    #22698

    drmike
    Member

    Which XML exporter are you using just for reference?

    How big is the file as well?

    Only thing that comes to mind right off is the XML file is uploaded to the picture space we have here and if it’s larger than 25 megs, you might run into a problem.

    #22714

    hjorthen
    Member

    I’m using the built-in wordpress tool for exporting, and the same for importing it.

    The xml-file is a little less than 7 megs, but I’m not sure that this is every post on my blog.

    #22778

    wank
    Member

    WordPress 2.0.3 doesn’t have an importer labelled ‘XML’, so I assume you’re using the RSS one? You may be better off with the wordpress-to-wordpress plugin.

    7MB is a biggish file, otherwise I’d suggest opening it in a text editor to check that it’s all there and maybe split into separate files. It’s a shame we can’t select the number of posts to export at once. I think I’ll put in a request.

    #22793

    drmike
    Member
    #22798

    hjorthen
    Member

    Thank you guys, you’re one step ahead of me:-)

    I believe the first error was because I had to change the writing permissions, but getting that taken care of I got a different error message. I’ll try your importers now, see how it goes:-)

    #22799

    hjorthen
    Member

    Nah! Still won’t work. This is the message I’m getting:

    ERROR
    The requested URL could not be retrieved

    While trying to retrieve the URL: http://hjorthen.site/wp-admin/admin.php?

    The following error was encountered:

    * Zero Sized Reply

    Squid did not receive any data for this request.

    Your cache administrator is (email redacted).
    Generated Thu, 27 Jul 2006 23:03:05 GMT by vhost.phx6.nearlyfreespeech.net (squid/2.6-DEVEL)

    #22804

    drmike
    Member

    Best bet would be to bug your support folks. Looks more like an issue with something on their side.

    An aside: I like their pricing but I know my storage requirments and bandwidth would place me in their top 1%. :)

    #22807

    hjorthen
    Member

    Yeah, I’ve tried the support folks, but they claim that this is wordpressrelated and not something they want to be bothered with.

    I think I just might try a different host, see if it works better.

    #22808

    hjorthen
    Member

    …and it worked like a dream with my other hosting company. No problems at all with the WordPress to WordPress-importer, and every post and every comment came through with no hassel whatsoever.

    Wich means that the problem is related at NearlyFreeSpeech.net somehow. Good to know!

    #22813

    drmike
    Member

    Probably. Squid is a pain sometimes getting set up correctly. I know I don’t use it myself with my clients. (I use JPCache for the most part.)

    #22933

    hoanghaithuy
    Member

    I still have problem with exporting.

    #22934

    timethief
    Member

    Please report your problem to staff http://wordpress.com/contact-support/

The topic ‘Export/Import won’t work’ is closed to new replies.