Need help? Check out our Support site, then

Facebook links - no thumbnails (canonical url issue?)

  1. I just started publishing my blog and telling people about it. I seem to be hitting an issue with the canonical tag in my header though. It appears before the Facebook Open Graph tags:

    <link rel="canonical" href="" /><br /> <meta property='og:locale' content='en_US'/><br /> <meta property='fb:admins' content='115800964'/><br /> <meta property='og:title' content='1st Play-Doh Experience - Life's Little Adventures'/><br /> <meta property='og:url' content=''/><br /> <meta property='og:site_name' content='Life's Little Adventures'/><br /> <meta property='og:type' content='article'/><br /> <meta property='og:image' content=''/><br /> <meta property='og:image' content=''/><br /> <meta property='og:image' content=''/><br /> <!-- / Yoast WordPress SEO plugin. -->

    so when I use the Facebook Debug to see why it won't display thumbnails, I get an error that seems it can't resolve the address when I pass it a blog post rather than just the home page.

    Is it because of the canonical URL? Is there any way to get around this without disabling the canonical tag? I couldn't seem to find anything on Google or in the forums concerning this.

    Appreciate the help!

    The blog I need help with is

  2. The blog you specified at does not appear to be hosted at

    This support forum is for blogs hosted at If your question is about a self-hosted WordPress blog then you'll find help at the forums.

    If you don't understand the difference between and, you may find this information helpful.

    If you forgot to include a link to your blog, you can reply and include it below. It'll help people to answer your question.

    This is an automated message.

  3. We cannot help you here at with that site as it’s not being hosted by and we run on different software. This is the correct forum for your software http://wordpress.ORG/support/ If you have not registered a username account yet you can do so on the top right hand corner of the page I just linked to so you can post to those support forums. vs The Differences
    Best wishes with your site.

  4. ah, didnt know that. now i know! thanks!

  5. You're welcome.

  6. Hello,

    I am having this same problem, but my blog IS on I am using the Fresh and Clean theme. When I post links to specific blog posts on facebook, the images do not come up at all. They used to, but they don't anymore. A friend of mine uses the exact same theme, but his links always show a thumbnail image when he posts on facebook. This suggests that this is not a facebook issue, but a wordpress issue.

    My blog is:

    Please help.

  7. @manfuel

    Unfortunately, we have no control over the images that Facebook chooses. We really only send them the URL of the post, and they hunt through that for the excerpt and images to include.

  8. Yes, I've seen this wordpress response before, but a friend with the same exact theme is able to get his thumbnails posted and this is a new problem for me. I have not changed or done anything differently. There seems to be no reason why it would work for my friend, but not for me.

  9. We have no control over which images Facebook chooses to display and we have no control over how long it takes for the image caches at Facebook to be flushed. They make changes frequently and every time they do we get these kind of questions. I'm sorry I cannot help you. Does this help?

Topic Closed

This topic has been closed to new replies.

About this Topic