Need help? Check out our Support site, then

facebook publicize not working

  1. Hi,

    I have the publicize feature on for my blog, connected to my personal Facebook page. When I first connected it, it worked fine. However, for the past 5 or so posts, nothing shows up on my facebook. I even followed the instructions to disconnect the publicize connection and reconnect it. I just published a post and still nothing. Could someone let me know what is wrong?

    thank you!

    The blog I need help with is

  2. Hello there,
    Post the snippet and link manually to Facebook for any missed posts first and then proceed as follows.

    1. Try flushing your FB cache but disconnect from FB first

    2. (a) Try the full reconnect procedure again detailed at including step 3 (removing the FB app), which is probably the most important step.

    3. See also publicize troubleshooting

    Note: RSS Grafitti can be used for posting to Facebook walls if you prefer. RSS Graffiti periodically checks the RSS/Atom feeds that you specify and posts any new entries it finds to the Facebook Walls that you specify. You can get any feed written on any wall (Facebook Profiles, Fan Pages, Groups, Events and Application Profile Pages). In fact, multiple feeds to multiple walls. You choose the combination.

    Please note that reconnecting Publicize with Facebook and/or with Twitter does not re-publicize missed posts, but it will work for future posts.

  3. Hi,

    It didn't work. One thing I have noticed is that whenever I post something, when I hit "publish", as it is loading, a message appears saying the connection was broken and then it reconnects itself to publish the post....but no publicize!


  4. Hi again Kendra,
    I'm sorry what I posted did not help you. Exactly which browser and version of it are you using please? Are you using a wifi connection? I'll tag this thread for Staff assistance. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.

  5. P.S. Please try enabling HTTPS:

    Add both * and * to your list of trusted sites under the Security tab. Make sure to uncheck the box for “Require server verification (https:) for all sites in this zone.”

  6. Hi Timethief,

    Thanks for the response! I am using Safari 5.7.1. And yes, I am using wifi. I will give the https thing a try.

    thanks again.

  7. I do hope it works for you.

  8. Hi Kendra - Can you please try resetting your connection one more time:

    Then, next time you publish, please click the "Edit" link in next to the Facebook publicize line in the Publish module and let me know if the little box there is checked or not. If it's not checked, try checking it prior to publishing and then let me know if it publishes to Facebook or still doesn't.

  9. Hi again,

    I just published something about 10 minutes ago and nothing on FB. I checked under edit as you suggested and yes, the little box there is checked and there was something like a link in the box. Would you have any other ideas on what I could do?

    thanks for your help so far!

  10. Hi Kendra - Ok, thanks. We've had a couple of reports of this, and we haven't been able to narrow down the cause yet. Do you use Windows Live Writer, by any chance?

    Also, next time you have a post ready to go, could you please check if the box is checked *before* you publish it? If there's any kind of message in that same place, like a 'connection refresh' message, could you please make a screenshot of it? Here are instructions for how to make a screenshot:

    You can upload it to your blog's Media Library and I can look at it there. Thanks very much for your help with troubleshooting this.

  11. Hi

    I published a blog post today and still nothing on FB :( As per your question, no, I don't use Live Writer. The last time I published a post, there was a weird looking link in the box (I left alone) and the other box was checked. Today, the box was checked as well and this time what was written was my blog post title. But still no post onto FB.

    I'm trying to brainstorm ideas as well - could it be my server?

  12. Hi Kendra - Ok, thanks for checking that. I've passed this information along to our development team and I'll keep you updated with what they say.

  13. awesome. thank you!


  14. Hi Kendra - Could you please go here in your Facebook account:

    And make a screenshot of what your settings there look like? Here are instructions for how to make a screenshot:

    You can upload the screenshot to your blog's Media Library and we can look at it there. This would help out the developer looking into this. :)

  15. Hi eurello,

    i've uploaded the screenshot!


  16. Thanks very much! I've let our developer know to take a look; he's still looking into this.

  17. With WP 3.8 I get no dialogs in IE11, Firefox, or Chrome when trying the Reset Facebook process above.

    At FB the WP app has been removed. In WP the Sharing FB entry has a connect button. Using IE11 I've placed https://*, https://*, and https://* in the Trusted Sites. Clicking connect results in a blank page. I've even assumed it was a slow process and given it several minutes to render. But, the browser indicates the page has loaded.

    I am having similar problems with Google+

  18. @nalates - Is this your self-hosted site running Jetpack? Can you please try this again in Chrome, and try disabling any browser add-ons or extensions you might be using first? If that doesn't help, can you make a screenshot of what you're seeing? Here are instructions for how to make a screenshot:

    You can share it with me using

  19. I'm hosted on GoDaddy and I am running Jetpack.

    I can send you a shot of the SHARING page showing Facebook/Connect button... But, with my current extensions active a completely empty page is returned. Using Chrome's View Page Source, it is completely empty.

    Turning off ALL extensions and restarting the browser does not change that. Chrome still shows there is not even a space character in the returned page.

    The URL the Connect button gives is:

    I've replaced characters with '#' in 4 places.

  20. hi,

    just following up. i've published a new post today and before i did, i removed the FB publicized and re attached it. but to no avail.


  21. You need to remove the connection to FB, flush your FB cache, and then reconnect.

  22. @nalates - Can you please deactivate all of your plugins except for Jetpack and then try to connect Facebook? Let me know if the same thing happens.

  23. Yes, disabling all extensions and all plug-ins except Jetpack gives the same result in all 3 browsers.

  24. @Raincoaster, if you are addressing me, that was tried long ago.

  25. @nalates, nope. Yours is a issue and I don't answer .org issues.

  26. @nalates - When I test your connection in the Jetpack debugger here, I get an error that your XML-RPC is not responding correctly:

    You can test this out on your end; the debugger will give you some instructions. Please also try these other troubleshooting tips here:

  27. I cannot run a curl command as the server is a shared host at GoDaddy.

    I can add /xmlrpc.php to the URL. The return is a page with 2 line-returns and then on the 3rd line: XML-RPC server accepts POST requests only.

    I'm not sure about whether the 2 blank lines are acceptable.

    If I use the 2014 theme, the 2 blank lines disappear. So, I am assuming the problem is somewhere in the theme. I'm trying to track that down.

  28. @nalates - Please try deactivating all of your plugins and then disconnecting and reconnecting Jetpack. If that doesn't help, please contact Jetpack support, as they'll be able to help you better, and the initial publicize issue is getting a bit buried here :)

  29. Hi again,

    I've tried the cache flushing thing to no avail - just did another post and nothing. Thanks, though.


Topic Closed

This topic has been closed to new replies.

About this Topic