Fail to publish Google Spreadsheet in my post

  • Author
  • #617978



    Here is the link to the post:
    And this is what I wrote in my post:

    [googleapps domain="docs" dir="document/pub" query="id=1Izxn1AkCHnAltv2RUqEUU73ZtTApMrZGcOxM5kf5JHI&embedded=true" /]

    [googleapps domain="spreadsheets" dir="pub" query="hl=en_US&hl=en_US&key=0AmUNJ79PATsXdDRMNmR1WGROWWxNekpMeS1wSmxteFE&single=true&gid=0&output=html&widget=true" width="500" height="300" /]

    Expected Results: A google doc and a spreadsheet
    Result Found: Only a google doc

    1. The Spreadsheet is in public view.
    2. I followed the exact instructions as mentioned on
    3. Found no problem while using google docs but failed in case of google spreadsheets.

    Whoa HELP!!!!!

    The blog I need help with is



    What is the size of the spreadsheet? Do you thing the maximum displayed image width for your theme which 644 pixels may be a factor?



    Max size avail is 644 in Choco theme and irrepective of how long the spreadsheet may be iframe max width defined is 500, so I dnt think that may be a factor for the problem ;)



    This is a new feature and I have not used it so I have no help to offer you. Hopefully, another Volunteer will be able to help. If not then you will have to contact Staff directly for assistance.
    reference link >



    I have dropped an email to the customer support, if they come up with something I would surely post the solution here…



    Thanks so much for committing to returning to this thread and sharing the solution Staff provides you with. Others will certainly appreciate it.



    @ minerva09 – I also have this same problem – docs OK – Spreadshit – fail
    When this feature is offered so it was ok, but after updating – it does not work HTML
    But I have verified that the HTML code works 100% but not here on



    I I love you from the heart – it was a speed fix the problem – thank you very much I knew, that we can count – blessings



    I just have to say this thread is comedy gold thanks to Freudian slips.



    hey guys now thing must be working like totally cool way… if anybody is still facing this problem lemme know…

    actually this was what was happening….

    After some experimenting I came out with the solution… I am not sure if this was a problem from Google or WordPress so I bettter share it here…

    From google doc one receives this code which has to be pasted in edit post page

    <iframe width=’500′ height=’300′ frameborder=’0′ src=’’></iframe>

    After publishing the post the code, this code is seen when you go to edit post:

    [googleapps domain="spreadsheets" dir="pub" query="hl=en_US&hl=en_US&key=0AmUNJ79PATsXdDRMNmR1WGROWWxNekpMeS1wSmxteFE&single=true&gid=0&output=html&widget=true" width="500" height="300" /]

    But the above code dont work. Actually this code was the needed code:

    [googleapps domain="spreadsheets" dir="spreadsheet/pub" query="hl=en_US&hl=en_US&key=0AmUNJ79PATsXdDRMNmR1WGROWWxNekpMeS1wSmxteFE&single=true&gid=0&output=html&widget=true" width="500" height="300" /]

    The difference is in the directory which should be spreadsheet/pub that just pub

    Till now every-time I tried posting a spreadsheet dir coded was pub and thus speadsheet was not displayed in the blog

    I just tried it a minute back and now dir is coded as pub/spreadsheet.

    Since this is done by WordPress may be it was a bug which has been resolved by you all recently or may be it is still a fluctuating bug.

    Further, I reported this observation to the support team..

    Thank you all for posting in this section of formum…

    Love you all…




    I have flagged this thread so it receives Staff attention.



    @timethief: they have already gone through it… :)



    I just did a quick test, and it seems to be working properly with the code you mentioned later on.

    It looks like we’ve already fixed this.



    lolz yes Indeed you guys did it right on time :)

    thanks a ton!!

The topic ‘Fail to publish Google Spreadsheet in my post’ is closed to new replies.