Featured blogpost not Featured

  • Author
    Posts
  • #3024442

    I just spent hours working on a new blog post, I added the featured image on top and also tagged* the post with featured. Still, it didn’t show up in the featured posts on my front page. Why is that, did I do something wrong? In my theme customizer, I have my Static Front Page set to A static page which has worked all fine until now. The featured posts that are on top are only my old ones.

    I’ve now made my post private until I get this issue solved.

    Hope someone can help me out, Id appreciate it. <3

    Metta Yoga.

    The blog I need help with is mettayoga.net.

    #3024549

    musicdoc1
    Member

    Hi,

    In my theme customizer, I have my Static Front Page set to A static page which has worked all fine until now.

    The site https://mettayoga.net/ is displaying the posts page on the front page. It doesn’t have a static front page. Are you referring to another site?

    I just spent hours working on a new blog post, I added the featured image on top and also tagged* the post with featured. Still, it didn’t show up in the featured posts on my front page…

    The Featured Content section of the Dyad 2 theme guide says:

    The image size that works best on the homepage Featured Content slider is 1800px wide by 1280px high.

    The Quick Specs section of the theme guide says:

    The recommended Featured Image size is at least 1800 by 1280. The theme will scale and crop the images depending on the page and device size.

    Was the featured image that you set of sufficient size?

    #3024550

    musicdoc1
    Member

    Does https://mettayoga.net/ have the Dyad theme or the Dyad 2 theme applied?

    #3024573

    I have a Dyad2 theme :)

    In my customizer under Front page displays, I have marked the “a static page”

    But I have not chosen the underneath options. What I mean is that I have just the option – Select- under the Front Page and on Post Page, I have a blank selection.

    Everything worked fine before, I don’t know what I have done wrong :/

    My photo dimensions that I uploaded as featured is the resolution: 5472 ✕ 3648. I’ve used an image from Unsplash.com they are always big enough. Never had this problem before.

    In my post setting, I definitely did mark a featured image and uploaded the above image.

    I hope that helps you to resolve my issue.

    Btw, I noticed your profile pic. When I went to school I had a final exam in english about the civil rights movement. I see you are interested in that as well as I am. <3

    Metta Yoga.

    #3024574

    Yes its about http://www.mettayoga.net

    #3024592

    musicdoc1
    Member

    In my customizer under Front page displays, I have marked the “a static page”

    But I have not chosen the underneath options. What I mean is that I have just the option – Select- under the Front Page and on Post Page, I have a blank selection.

    Choosing the option “- Select-” from the front page and posts page drop-down menus at Customize > Static Front Page, even with “A static page” checked at “Front page displays,” will cause the front page to default to the posts page. It produces the same result as it would if you chose “Your latest posts,” at “Front page displays.”

    In my post setting, I definitely did mark a featured image and uploaded the above image.

    Do you mean that the post is tagged with the featured content tag? If so, and everything else is in order, yet it still doesn’t display the post in the slider, then I’d suggest that you add a “Modlook” tag to the sidebar at right here, which will call for staff attention.

    …about the civil rights movement. I see you are interested in that as well as I am.

    Yes, in August I saw the play “Outcry” by Thais Francis, which rekindled my interest. The performance I attended was only a couple of weeks before the anniversary of Emmett Till’s brutal murder.

    #3024593

    musicdoc1
    Member

    However, if you want the featured content slider to display on the front page, then you should not have a static front page.

    The Dyad 2 theme guide says:

    If the site is using a Static Front Page, the theme will display that page’s Featured Image in the header area. If one is not assigned, the theme will fall back to the Featured Content slider.

    #3024594

    Thank you for your reply musicdoc1 :)

    Choosing the option “- Select-” from the front page and posts page drop-down menus at Customize > Static Front Page, even with “A static page” checked at “Front page displays,” will cause the front page to default to the posts page. It produces the same result as it would if you chose “Your latest posts,” at “Front page displays.”

    What can I do here instead? I a beginner at WordPress so detailed instructions would be most helpful.

    Do you mean that the post is tagged with the featured content tag? If so, and everything else is in order, yet it still doesn’t display the post in the slider, then I’d suggest that you add a “Modlook” tag to the sidebar at right here, which will call for staff attention.

    Yes, definately made a tag name called “Featured” Ok, the “Modlook” tag I wasn’t familiar with, thank you. I will try that now :)

    Yes, in August I saw the play “Outcry” by Thais Francis, which rekindled my interest. The performance I attended was only a couple of weeks before the anniversary of Emmett Till’s brutal murder.

    That must have been a strong play, but much needed. History shall never be forgotten!

    #3024595

    musicdoc1
    Member

    To clarify: if the front page is not set to display a static page, then it will display the posts page (aka the blog page).

    #3024596

    musicdoc1
    Member

    What can I do here instead?

    At “Front page displays,” you may choose “Your latest posts.” However, it’s automatically defaulting to the posts page now, so you needn’t change the present settings.

    #3024597

    musicdoc1
    Member

    Yes, definately made a tag name called “Featured”

    Good, but that wasn’t my question. I asked if you had added the featured content tag to that specific post. It must be added to each post that you want to be displayed in the slider.

    #3024598

    At “Front page displays,” you may choose “Your latest posts.” However, it’s automatically defaulting to the posts page now, so you needn’t change the present settings.

    ok, I did change it now.

    Currently I have my post as private because there is something wrong with the line breaks. I have a text, then a line break again with a long quote, then a line break. But in the preview, I see everything is together with no line breaks. I think id have to wait for support on this one. It really messed up somehow I don’t know.

    #3024599

    Good, but that wasn’t my question. I asked if you had added the featured content tag to that specific post. It must be added to each post that you want to be displayed in the slider.

    Yes I did that also.

    #3024600

    musicdoc1
    Member

    Good.

    Ok, the “Modlook” tag I wasn’t familiar with, thank you. I will try that now :)

    In the sidebar at right in this topic, you’ll find a list of tags. Add the tag “modlook” there.

    #3024601

    Thank you so much, I followed all your steps and added the tag on this thread.

    #3024603

    musicdoc1
    Member

    You’re welcome. : )
    Staff will respond here.

    #3024604

    Thank you, I can’t wait to have this fixed :)

    #3024648

    fstat
    Staff

    Hi there,

    I found three posts on your blog tagged as featured. By unhiding them one by one I was able to see them appear on the featured posts slider at the top of your homepage. Can you please verify that this is also working for you?

    Currently I have my post as private because there is something wrong with the line breaks. I have a text, then a line break again with a long quote, then a line break. But in the preview, I see everything is together with no line breaks. I think id have to wait for support on this one. It really messed up somehow I don’t know.

    If you want to add more line breaks between your paragraphs and your images you can do so by selecting the HTML tab in the post editor and adding the   tag. This tag will force a line break. Here’s a screenshot of where to find the HTML tab:

    http://cld.wthms.co/Cozfcv

    and here are the more detailed instructions on how to use the extra line break tag:

    https://en.support.wordpress.com/advanced-html/#extra-line-breaks

    If this doesn’t work or you have more questions, just let me know and I’ll be happy to help!

    #3024651

    I found three posts on your blog tagged as featured. By unhiding them one by one I was able to see them appear on the featured posts slider at the top of your homepage. Can you please verify that this is also working for you?

    yes, all the three posts that I have published worked fine. But its the new blog post which I have set as private for now because when I did publish it didnt show up in the featured slider on top. This is still a big issue, since I havent published any blog posts since friday! :/

    here are the more detailed instructions on how to use the extra line break tag:

    The extra line tag worked. Thanks a lot! :)

    #3024658

    fstat
    Staff

    The extra line tag worked. Thanks a lot! :)

    That’s great!

    But its the new blog post which I have set as private for now because when I did publish it didnt show up in the featured slider on top. This is still a big issue, since I havent published any blog posts since friday! :/

    Can you give me the post’s title so I can have a look? (No need to make it public ;))

    Thanks!

The topic ‘Featured blogpost not Featured’ is closed to new replies.