Featured Content Doubled

  • Author
    Posts
  • #3417510

    fynnp2002
    Member

    Is there an option to showcase a post, if featured, only in the featured content area and not two times, since it also is in the other area as well?

    The blog I need help with is refuseroutine.wordpress.com.

    #3417726

    musicdoc1
    Member

    Hi,

    Yes, on the Apostrophe 2 theme there is. At Customize > Featured Content, simply uncheck the box labeled “Also display tagged posts outside the Featured Content area,” and then save the customization by clicking the Publish button.

    #3418184

    fynnp2002
    Member

    I did that, but it doesn’t change anything? Does it only work with a certain minimum amount of total posts or something?

    #3418265

    musicdoc1
    Member

    Does it only work with a certain minimum amount of total posts or something?

    No, on my test site I found that it worked as expected with just one featured content post.

    During testing, however, I was able to replicate the results obtained on your site by using a particular combination of settings at Customize > Homepage Settings. If at “Your homepage displays” I choose “a static page,” but fail to choose a static page from the first drop down menu, then the theme evidently automatically assigns the page chosen as the posts page (in the second drop down menu) as the homepage as well. The homepage become essentially a duplicate of the posts page, aka the blog page. I suspect that this particular setting might be the cause in your case.

    Unchecking the “Also display tagged posts outside the Featured Content area” box doesn’t effect the posts page unless the homepage is set as the posts page.

    Alternate fixes:

    1. Choose “Your latest posts” at Customize > Homepage Settings > Your homepage displays. This action alone will resolve the homepage problem, but it will also revert your page titled “Blog” to a static page.

    2. If you prefer to keep the posts on the page titled “Blog” and not on the homepage, then it will be necessary to select a different static page as your homepage. However, you may still display posts on the static homepage in various ways. Some of the ways to display posts on a static page:

    a. Insert a Blog Posts Block (into the content of the page).

    b. Insert a Latest Posts Block.

    c. Insert a Columns Block, and customize it to include a grid of posts (that is, image and/or text links to the full posts).

    d. Insert Display Posts Shortcode, customized as you wish, in accordance with the available display argument options.

    #3418274

    musicdoc1
    Member

    My tests reveal that unchecking the “Also display tagged posts outside the Featured Content area” doesn’t affect any archives pages, other than the blog page, and it only affects the blog page if it is set as the homepage.

    The phrase “outside the Featured Content area” seems inadequate, because it suggests that unchecking the box would hide a featured content post in multiple places (e.g. archives pages, the blog page when it isn’t on the homepage) and not just one place under a specific condition. For this reason I’ve called for staff attention. Staff will respond here.

    #3418325

    kokkieh
    Staff

    Hi there,

    It’s as @musicdoc1 said above. You have your site set to display a static front page, but you don’t have any front page set, and you have the “Home” page set as your posts page.

    Correct those settings, either setting two different pages as front and post page respectively, or change it so the front page displays latest posts, and this should start working correctly.

    #3418469

    fynnp2002
    Member

    I set my homepage as a static page which shows some of my newest posts (the post block) and then set the BLOG page as the page where all of the posts are displayed. If I choose my homepage to show my latest post, the posts do not double and it works, but it doesn’t change anything on the page I now set to display my posts?

    #3418480

    musicdoc1
    Member

    but it doesn’t change anything on the page I now set to display my posts?

    That’s correct, which is why I said above:

    Unchecking the “Also display tagged posts outside the Featured Content area” box doesn’t effect the posts page unless the homepage is set as the posts page.

    It seems like a design flaw to me, because if a static page is chosen as the blog page, and a featured content section is displayed on that page, there will be duplication of featured content posts whether or not the box is unchecked. I’ve reported this elsewhere to staff.

    #3418545

    fynnp2002
    Member

    Is there a way to report something like that or request an adjustment, since this obviously isn’t exactly how it’s supposed to be…

    #3418762

    supernovia
    Staff

    I’m not sure I follow. The home page and Blog page are both very similar right now. Is there a reason you want both?

    #3418823

    musicdoc1
    Member

    @supernovia,

    What @fynnp2002 has revealed is that unchecking the box “Also display tagged posts outside the Featured Content area” only has the intended affect when the homepage is set as the posts page. There are countless reasons why someone might not want to have the posts page on the homepage.

    When using the theme Apostrophe 2, the featured content section may be displayed on any page set as the posts page, but the action of unchecking that box only has the effect that it’s supposed to have if the posts page is set to display on the homepage. Why should we be required to display the posts page on the homepage in order for the action of unchecking that box to work as it’s intended to, preventing post duplication?

    I don’t know if this issue is limited to the Apostrophe theme. I haven’t yet found other themes that behave the same way regarding the effects of unchecking that button.

    #3418963

    musicdoc1
    Member

    Meant to say “unchecking that box” at the end of the last post.

You must be logged in to reply to this topic.