Featured image in iTheme2

  • Author
    Posts
  • #732772

    windwhistle
    Member

    Before I dismiss this beautiful theme from consideration, I’d like to make sure I’m understanding how the featured image works. It appears that if I want an existing post/image to appear in the carousel, I must designate a featured image for that post. If my chosen featured image already exists in the post, it will be duplicated above the post’s headline. In its position as the featured image above the headline, the image will not show a caption and will not function as a link to any larger version/display. This means giving careful thought to the use of images in new posts and probably a redesign of existing posts to avoid the duplication of existing images.

    Am I correct in my understanding of how this theme handles featured images, or am I doing something wrong?

    The blog I need help with is piedtype.com.

    #732909

    justjennifer
    Moderator

    According to the information in the Theme Showcase, for it to appear in the slider, it has to be both with a featured image AND a sticky. Please see the bottom of the page here: http://theme.wordpress.com/themes/itheme2/

    #732915

    windwhistle
    Member

    My apologies if I somehow posted this question twice. I certainly didn’t intend to.

    I understand how the slider works. That’s not my question. My question is, is the duplication of images in a post (as I described above) the way the theme is supposed to work? I’m assuming it is and that if you plan to feature an image, then don’t use it anywhere else in the post. But, is it also intentional that a featured image will not display a caption and will not work as a link to a larger image?

    #732924

    sarahparham
    Member

    I have been using this theme for the last 2 months. I have had no problems uploading the featured image. Yesterday I posted as usual did nothing different and the featured image just won’t appear. I have tried everything. Funnily enough it shows up on iPad just not on the main site view. Please help otherwise I will have to change theme.
    S

    #732960

    justjennifer
    Moderator

    @sarahparham, the site linked to your username is using Structure, not iTheme2. There are other threads about problems with featured images in Structure. Please see:
    https://en.forums.wordpress.com/topic/featured-image-no-longer-appearing-on-homepage-in-structure-theme?replies=3
    and https://en.forums.wordpress.com/topic/my-theme-structure-is-screwed-up-help?replies=18

    @windwhistle, Can you give us a link to the blog you are having trouble with, starting with http:// ? The one linked to your username is using “The Morning After”.

    #732963

    justjennifer
    Moderator

    iTheme2 seems to be similar to Inuit Types in how it relates to featured images being repeated in the body of the post. However, unlike Inuit Types, there’s no way to turn off the repeated image in iTheme2.

    #732987

    windwhistle
    Member

    My test blog is at http://windwhistle.wordpress.com/ I’ve made it public for the moment, but will close it again in a day or so. It’s a mess right now, because I’ve been playing around with how this theme handles featured images. As it stands, it looks like I’d have to spend too much time rearranging images to want to use this theme.

    I have never used Inuit, but yes, a way to turn off the duplication sounds like what iTheme2 might need.

    #733029

    justjennifer
    Moderator

    It would certainly solve the problem. Suggest it to Support once they are back after the 29th.

    If you have the Custom Design upgrade, I don’t wonder if there isn’t a way to suppress the display of the featured image in the post itself. Since I am not well-versed in CSS, I cannot give you any concrete advice on this.

    Otherwise, it would mean not using the same photo in the body of your post. Looking at the theme designer’s demo site, the featured image is the only image in the post.

    #733032

    slgrigg76
    Member

    My featured posts aren’t showing in a carousel, how do I fix it as I dont want them in the main body of my home page, I want them in a carousel but it’s not appearing?

    http://showard76.wordpress.com

    #733039

    @showard76: As justjennifer explained above, you must also set a featured image to your sticky posts for the carousel to work.

    #733040

    slgrigg76
    Member

    I have set a featured image :/

    #733046

    Yes, now you have, and your carousel showed up. Before, you hadn’t set featured images: if you had, they would have shown above the title of each post (as they do now).

    #733047

    slgrigg76
    Member

    yeah, i had added them but it hadn’t stored them properly!? fixed it now :) Thanks

    #733049

    You’re welcome.

    #733052

    windwhistle
    Member

    @just jennifer I have the CSS upgrade. Haven’t checked yet and may not be smart enough to figure a way to suppress the featured image within the post, assuming it’s even possible. What I’d love to have is the ability to lay out the post exactly the way I want it. Then designate an image as the image to be featured in the carousel — without that action changing the appearance of the post at all. (After all, if I wanted an image to run full width across the top of the post, I’d have already laid it out that way.) That’s sort of how The Morning After works. The designated image will appear on the front page as part of the “Latest Post,” or as a thumbnail in a front page “Featured Post,” but the original layout of the post does not change at all.

    But that’s the beauty of WordPress. Every theme is different. Thanks for the input, everyone.

    #733053

    @windwhistle: Yes of course you can remove the FIs from the posts if you have the CD upgrade. Add this in the CSS editor:

    .attachment-large-feature {
    display:none;
    }

    #733054

    windwhistle
    Member

    @ panos Thanks! That works beautifully. (I swear I just looked at the code a minute ago and didn’t see a way to do that. Maybe not enough coffee yet.) Anyway, I may have to reconsider and use this theme after all. Especially since I haven’t changed themes in at least two months.

    #733086

    cheryl621
    Member

    Thanks for those info! iTheme2 is now working =) I had similar problem with the carousel where all the posts I put as “sticky posts” displayed the entire content at the front page rather than only the featured image.

    #733105

    jackjericho
    Member

    Why am I battling so much?

    #733106

    timethief
    Member

    @jackjericho
    You must make your posts sticky posts and assign a featured image of the correct size to them for the carousel to work. The large featured image size is 593 wide by 261 high.

    All you have to do to activate is have a sticky post with a featured image. Once you have one, the featured post area will appear. If you have more than 5, navigation arrows will appear on the left and right. Your visitors can then click through to see all the posts you’ve featured. http://theme.wordpress.com/themes/itheme2/

The topic ‘Featured image in iTheme2’ is closed to new replies.