feed error

  • Author
    Posts
  • #398974

    I’m using a theme from wordpress. When I clicked on the feed ‘posts’ button at the top of the page, it went to an IE error page, and said it cannot display feed – “This feed contains code errors”.

    I haven’t adjusted the code at all. I tried changing themes to see if it was just the particular theme I’d chosen, but I got the same error again. Any help would be appreciated, thank you.

    The blog I need help with is leticiamaguire.wordpress.com.

    #399175

    raincoaster
    Member

    The site linked to your name isn’t a WordPress.com blog and we won’t be able to help you with that. If you have a blog that’s hosted here, please give us a link to it, starting with http.

    #399176
    #399178

    raincoaster
    Member

    Hmm, I’m not getting any errors on the feed using Google Reader. Can you try it again and see if it was a temporary blip? I know staff were tinkering behind the scenes today and that might have affected it.

    #399179

    Just tried again, and got the IE ‘cannot display this feed’ thing again. I got “more information”, and it says:

    An invalid character was found in text content.
    Line: 42 Character: 25

    I have not much idea about coding, so I don’t know what is on Line 42, char 25 (!?)
    However, I don’t want to subscribe to my own feed anyway, but I was worried that other people would get that error. I’m glad you didn’t see an error.

    #399180

    ps: the ‘comment’ feed seems to be working, no problems.

    #399182

    You have some “illegal” characters either in posts or somewhere on your blog and those need to be fixed.

    First off, go to settings > reading and toward the bottom make sure character encoding is set to UTF-8. Anything else will cause issues on the web, and especially with RSS feeds.

    Next go to settings > writing and select “WordPress should correct invalidly nested XHTML automatically” and click save changes.

    Now start opening your posts one at a time in the post editor, make one minor change like adding a space and then deleting it, and then click update post. and check your feed here: http://validator.w3.org/feed/ .

    Your feed address is http://leticiamaguire.wordpress.com/feed .

    #399183

    Keep correcting your posts one by one as described above until the feed validates.

    #399184

    YAY it worked, thank you SO much for your help, I appreciate it immensely!!

    #399186

    I’m glad that did it for you, and you are very welcome.

    #399260

    raptortech97
    Member

    Should I be worried? http://validator.w3.org/feed/ says this:
    This feed is valid, but interoperability with the widest range of feed readers could be improved by implementing the following recommendations.
    line 113, column 0: style attribute contains potentially dangerous content: position:absolute;left:-10000px;top:0;width:1px;height:1px; (16 occurrences) [help]
    <div id="_mcePaste" style="position:absolute;left:-10000px;top:0;width:1px;h ...
    line 175, column 0: content:encoded should not contain script tag (2 occurrences) [help]
    <div class="PDS_Poll" id="PDI_container1944061">< ...

The topic ‘feed error’ is closed to new replies.