Feed problem with media:title

  • Author
    Posts
  • #158038

    edsunder
    Member

    My blog feed is being used on another site and its having a problem parsing the parts that are “media:title”. Is this a problem with the feed or with the parser? They say they are using something from feedparser.org, but this is not an area I’m familiar with. What’s happening is that the parser reads the media:title as a title. Also, they mentioned that there were a couple minor parsing errors noted: http://validator.w3.org/feed/check.cgi?url=http%3A%2F%2Ffssg.wordpress.com%2Ffeed

    Thanks for the help.

    My feed is http://fssg.wordpress.com/feed

    #158436

    geek2cv
    Member

    It’s a known problem with feedparser, see http://code.google.com/p/feedparser/issues/detail?id=76 – I think something has changed with wordpress feeds, otherwise this issue wouldn’t have surfaced everywhere at once. There is an unofficial patch here: http://codefork.com/blog/index.php/2007/10/28/in-praise-of-feedparser/ – haven’t tested that myself.

    Workaround: Tell them to use your atom feed, which is at http://fssg.wordpress.com/feed/atom

    #158437

    My blog is also being used by several feed aggregaters. About 4 days ago, both of them started getting incorrect feeds.

    One is powered by Planet. On that one, it does as mentioned above. The text is dispalyed correctly but the title is messed up either using part of the url or the title of a jpg in the post.

    I saw another blog doing the same thing there, and sure enough, it is a wordpress.com blog.

    The second aggregater is using WordPress with a FeedWordPress plugin.

    That one shows the title correctly, but only shows one letter in the text, a capital “A” which is unrelated to the first letter of the text in the post.

    This seems to me to be an issue with WordPress.com.

    Will posting this here bring this to the attention of the WordPress team, or is this independent?

    Where is teh best place to notify them?

    #158438

    Neglected to mention that on a third aggregater, which I don’t know what they use, it displays fine.

    #158440

    I have access to the WordPress aggregator and changed the to the Atom feed, but it still doesn’t take the text of the feed. The only difference was the capital “A” disappeared.

    #158449

    Yes, I’ve noticed exactly the same problem: posts in a wordpress.com feed were being imported by the Feedwordpress plugin, but the post’s content was being replaced with a capital ‘A’ (which wasn’t even the first letter of the content).

    I upgraded both WordPress.org and Feedwordpress, but to no avail. I have also tried importing several non-wordpress.com feeds, and they all came in fine.

    I don’t remember ever seeing my wordpress.com avatar’s details included in the RSS feed; so yes, we do have a duplicate ‘title’ and ‘media:title’. That might be the root cause I suppose, but the problem I’m seeing is with the content, not the title.

    #158460

    lgpref
    Member

    I’m having the same problem, using Feedparser in a Plone-based CMS website for bringing a WordPress.com blog. And, it failed at the same time that others have mentioned here (Wednesday or Thursday noticed on site.) I reported it to Support, and “Mark” replied after looking about for several days while he waited and checked for other feed reports “but I have had none.” He also said that “nothing has changed.” I emailed him back today, with a link to this Forum topic, and links to the items noted in geek2cv’s reply. My email ticket number is FQA-701028 in case that’s useful….

    #158464

    lgpref
    Member

    UPDATE: I tried the Atom suggestion made by geek2cv just now, and it seems to be working for my blog at the moment –

    WordPress.com blog – http://cmclquickpicks.wordpress.com/
    Feed being used http://cmclquickpicks.wordpress.com/feed/atom

    Shown at http://www.cedarmill.plinkit.org/readers/ (box in bottom rt hand corner).
    FWIW…..

    #158465

    mcmachismo
    Member

    I’m having this problem but I have no idea how to solve it. Though I’m sure the explanations above work I don’t understand it.

    Can anyone explain how to fix this problem in layman’s term? Thanks!!

    #158468

    It is a problem with WordPress.com. I wish I knew what I could do. They don’t seem to be responding to the issue.

    #158470

    mark
    Staff

    “They don’t seem to be responding to the issue.”
    You sent an email at 11:48pm and 11:52pm. Support closes at midnight and I’m answering everything now.

    Please also never point me at a forum post. Always send the full problem to support.

    Our RSS is changing at present. I will clarify this when I can.

    #158472

    Sorry. I missed the memo on the way Support works on this site. When I originally went to report this I couldn’t find a link to Support on my blog so thought the way to do things was through the forms.

    Then suddenly I did see a link to Support so I thought it would be easier for you to see the thread in the forum which would show it wasn’t isolated.

    Won’t happen again.

    #158473

    Just noticed the problem is also affecting feeds imported into Facebook. They’re taking the overwriting the ‘title’ with the ‘media:title’ when they import an item.

    #158494

    radgeek
    Member

    This is a software bug in feed consumers, related to some mistakes, rather easily made under certain conditions, as to how to handle Yahoo’s MediaRSS namespaced elements. It is not, essentially, a problem with WordPress.com’s feeds.

    FeedWordPress users may be pleased to know that this bug has been fixed in the latest release of FeedWordPress, version 0.991.

    #158499

    The problem is that it was working fine with the feed consumers, then suddenly it stopped.

    That indicates a problem in something changing — not in how the feed consumers were operating, but in how the feed was offered.

    Thanks for the link to .991, but would you also have a link as to what other feed consumers could do to fix it, if the fix is not going to be forthcoming from WordPress?

    #158505

    FYI, the .991 upgrade worked great, thanks.

The topic ‘Feed problem with media:title’ is closed to new replies.